<!DOCTYPE html>
<html lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  <!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame
  Remove this if you use the .htaccess -->
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

  <title>Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us| National Catholic Register</title>
  
<meta name="description"
  content="There are saintly patrons for our every occupation, need and concern.">
<meta name="keywords"
  content="catholic saints,all saints&#039; day">
<link rel="canonical" href="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us" />
<meta property="og:site_name" content="NCR" />
<meta property="fb:app_id" content="347756275321330" />
<meta property="fb:pages" content="64182915497">
<meta property="og:description"
  content="There are saintly patrons for our every occupation, need and concern." />
<meta property="og:title"
  content="Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us" />
<meta property="og:image" content="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_96105b35fec2d63b5d42f2da47d8aa36daca87809bb5e84ba88d1d331a3fc3ee.jpg" />
<meta property="og:image:width" content="934" />
<meta property="og:image:height" content="622" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_96105b35fec2d63b5d42f2da47d8aa36daca87809bb5e84ba88d1d331a3fc3ee.jpg" />
<meta name="twitter:site" content="@NCRegister">
<meta name="twitter:creator" content="@NCRegister">
<meta name="twitter:title"
  content="Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us">
<meta name="twitter:description"
  content="There are saintly patrons for our every occupation, need and concern.">
<meta itemprop="name" content="Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us">

<link rel="amphtml" href="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us?amp">

<meta name="sp.guid" content="urn:newsml:ncregister-api.superdesk.pro:2022-10-31T15:20:51.958452:5dbaf213-be47-440f-a0a9-a75bbed1cfc7" />
<meta name="sp.sd"
  content="https://ncregister.superdesk.pro">

  <!-- RSS & Pingback -->
  <meta name="google-site-verification" content="fH2AP0niyimtMl7gbXZxEEOYh0-SDCGbWnO5xzGZ7Ag" />
  <meta name="viewport" content="width=device-width, initial-scale=1">
  <link rel="shortcut icon" href="/bundles/_themes/swp/default-theme@hy9j1k/img/icons/favicon.ico" />
  <link rel="stylesheet" href="/public/dist/bundle.1635179830833.css" />
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js"></script>
  <script async src="https://cdn.onthe.io/io.js/2xVbjp7MTWBn"></script>
  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var mappingHeaderBanner = googletag.sizeMapping(). //all
        addSize([992, 0], [[728, 90], [970, 90]]). //desktop
        addSize([768, 0], [728, 90]). //tablet
        addSize([0, 0], []). //no mobile
        build();
    var mappingFooterBanner = googletag.sizeMapping(). //all
        addSize([992, 0], [[728, 90], [970, 90]]). //desktop
        addSize([768, 0], [728, 90]). //tablet
        addSize([320, 0], [320, 50]). //mobile
        addSize([0, 0], []). //other
        build();
    var mappingARTopBanner = googletag.sizeMapping(). //articles
        addSize([992, 0], []). //desktop
        addSize([768, 0], []). //tablet
        addSize([320, 0], [[320, 50], [320, 100]]). //mobile
        addSize([0, 0], []).
        build();
    var mappingARLeft = googletag.sizeMapping(). //article left
        addSize([992, 0], [[180, 150], [180, 300], 'fluid']). //desktop
        addSize([0, 0], []). //other
        build();
   var mappingSlider = googletag.sizeMapping(). //all
       addSize([992, 0], [[728, 90], [970, 90], [300, 250]]). //desktop
       addSize([768, 0], [[728, 90], [300, 250]]). //tablet
       addSize([320, 0], [[300, 250], [320, 50]]). //mobile
       addSize([0, 0], []). //other
       build();
    googletag.defineSlot('/1319756/NCR_EN_Header_Banner', [[728, 90], [970,90]], 'NCR_EN_Header_Banner').defineSizeMapping(mappingHeaderBanner).addService(googletag.pubads()).setCollapseEmptyDiv(true,true); //all
    googletag.defineSlot('/1319756/NCR_EN_WebLink', ['fluid'], 'NCR_EN_WebLink').addService(googletag.pubads()); //all
    googletag.defineSlot('/1319756/NCR_EN_Footer_Banner', [[320, 50], [728, 90], [970,90]], 'NCR_EN_Footer_Banner').defineSizeMapping(mappingFooterBanner).addService(googletag.pubads()); //all
    googletag.defineSlot('/1319756/NCR_EN_Home_Center', ['fluid'], 'NCR_EN_Home_Center').addService(googletag.pubads()).setCollapseEmptyDiv(true,true); //home
    googletag.defineSlot('/1319756/NCR_EN_Article_A', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_A').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Article_B', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_B').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Article_C', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_C').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Article_D', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_D').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Slider', [[300, 250], [320, 50], [728, 90], [970,90]], 'NCR_EN_Slider').defineSizeMapping(mappingSlider).addService(googletag.pubads()); //articles landings
    googletag.defineSlot('/1319756/NCR_EN_Article_Top', [[728, 90], [320, 50], [320, 100]], 'NCR_EN_Article_Top').defineSizeMapping(mappingARTopBanner).addService(googletag.pubads()).setCollapseEmptyDiv(true,true); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_A', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_A').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_B', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_B').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_C', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_C').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_D', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_D').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_E', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_E').addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_F', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_F').addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_G', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_G').addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_H', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_H').addService(googletag.pubads()); //articles
        googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs(true);
    if (typeof metaTags != 'undefined')
      googletag.pubads().setTargeting('Keyword', metaTags);
    googletag.enableServices();

  });

</script>

  <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-KB6S87');</script>
  <!-- End Google Tag Manager -->

  <script type="text/javascript">
  // Facebook
  window.fbAsyncInit = function() {
    FB.init({
      appId   : '347756275321330',
      xfbml   : true,
      version : 'v2.12'
    });
  };

  (function(d, s, id){
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) {return;}
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

  function getCookie(cname) {
    var cs = document.cookie.split(/;\s*/),
        name = cname + '=';
    for (var i = 0; i < cs.length; i++) {
      if (cs[i].indexOf(name) == 0)
        return cs[i].substr(name.length);
    }
    return '';
  }

  function setCookie(cname, value, expDays) {
    var c = cname + '=' + value;
    if (expDays) {
      var d = new Date();
      d.setTime(d.getTime() + expDays * 24 * 60 * 60 * 1000);
      c += '; expires=' + d.toUTCString() + '; path=/';
    }
    document.cookie = c;
  }
  </script>

    <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gloriousbeef.com/v2cytY6liVaFMo90EoRgi9IJ1NGpdfaUOQugPIppMHEWUKLSQ_mcuHWmFEMW2zIdb",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o[n]=o[n]||t})(window,String.fromCharCode(97,100,109,105,114,97,108));!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");</script>


    <script class="coral-script" src="//ncregister.coral.coralproject.net/assets/js/count.js" defer></script>  
  
  <script type="text/javascript">
  var metaUrl = 'https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us',
    metaPath = 'blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us',
    metaTitle = "Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us",
    metaDescr = "There are saintly patrons for our every occupation, need and concern.",
      metaTags = ['NCR_Blog',  'Amy Smith',   ''   ,  'catholic saints',    'all saints&#039; day' ];
</script>

  <script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "BreadcrumbList",
  "itemListElement": [{
    "@type": "ListItem",
    "position": 1,
    "name": "Front page",
    "item": "https://www.ncregister.com"
  },{
    "@type": "ListItem",
    "position": 2,
    "name": "Blog",
    "item": "https://www.ncregister.com/blog"
  },{
    "@type": "ListItem",
    "position": 3,
    "name": "Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us",
    "item": "https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us"
  }]
}
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us"
  },
  "headline": "Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us",
  "image": [
  	    "https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_96105b35fec2d63b5d42f2da47d8aa36daca87809bb5e84ba88d1d331a3fc3ee.jpg",
            "https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_4da29d4d07944aadf9dce820431ae0825ee7359ab8cfbf05513cc1749148bb2e.jpg",
            "https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_7a82644bcfeb1edc9ca477ca7ef41acc0640c37c2d545debd375f5515cc8fab8.jpg"
       ],
  "datePublished": "2022-11-01T04:24:22+00:00",
  "dateModified": "2022-11-01T04:25:14+00:00",
  "author": {
    "@type": "Person",
    "name": "Amy Smith"
  },
   "publisher": {
    "@type": "Organization",
    "name": "National Catholic Register",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.ncregister.com/public/img/ncregister-logo.png"
    }
  },
  "description": "There are saintly patrons for our every occupation, need and concern."
}
</script>
</head>

<body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KB6S87"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  <div id="fb-root"></div>

    <div id='NCR_EN_Header_Banner' class="centerAd marginY30">
    <script>
      googletag.cmd.push(function () { googletag.display('NCR_EN_Header_Banner'); });
    </script>
  </div>
  
  <div class="topBar">
    <div class="container">
      <div class="row">

                <div class="topBar__links col-xs-12 hidden-xs">
          <span class="topBar__toggle">A Service of EWTN News, Inc.</span>
          <div class="topBar__items">
            <div class="topBar__logoWrap">
              <a href="https://www.ewtnnews.com?utm_source=NCR%20Header%20Link" class="topBar__logo" target="_blank"><img src="/public/img/ewtn.svg"></a>
              <p>EWTN News, Inc. is the world’s largest Catholic news organization, comprised of television, radio,
                print and digital media outlets, dedicated to reporting the truth in light of the Gospel and the
                Catholic Church.</p>
            </div>
            <div class="topBar__links">
              <ul>
                <li>Newspaper</li>
                <li><a href="https://www.ncregister.com/">National Catholic Register</a></li>
              </ul>
              <ul>
                <li>News Agencies</li>
                <li><a href="http://www.catholicnewsagency.com/" target="_BLANK">Catholic News Agency</a></li>
                <li><a href="https://de.catholicnewsagency.com/" target="_BLANK">CNA Deutsch</a></li>
                <li><a href="https://www.aciafrica.org/" target="_BLANK">ACI Africa</a></li>
                <li><a href="https://www.aciafrique.org/" target="_BLANK">ACI Afrique</a></li>
                <li><a href="https://www.acidigital.com/" target="_BLANK">ACI Digital</a></li>
                <li><a href="https://www.aciprensa.com/" target="_BLANK">ACI Prensa</a></li>
                <li><a href="https://www.acistampa.com/" target="_BLANK">ACI Stampa</a></li>
              </ul>
              <ul>
                <li>Digital Media</li>
                <li><a href="https://churchpop.com/" target="_BLANK">ChurchPOP</a></li>
                <li><a href="https://es.churchpop.com/" target="_BLANK">ChurchPOP Español</a></li>
                <li><a href="https://it.churchpop.com/" target="_BLANK">ChurchPOP Italiano</a></li>
                <li><a href="https://pt.churchpop.com/" target="_BLANK">ChurchPOP Português</a></li>
              </ul>
              <ul>
                <li>TV & Radio</li>
                <li><a href="https://www.ewtn.com/tv/shows/ewtn-news-in-depth" target="_BLANK">EWTN News Indepth</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/ewtn-news-nightly" target="_BLANK">EWTN News Nightly</a></li>
                <li><a href="https://www.ewtnnoticias.com/" target="_BLANK">EWTN Noticias</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/ewtn-pro-life-weekly" target="_BLANK">EWTN Pro-life
                    Weekly</a></li>
                <li><a href="https://www.ewtn.com/radio/shows/register-radio" target="_BLANK">Register Radio</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/vaticano" target="_BLANK">Vaticano</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/world-over" target="_BLANK">World Over</a></li>
              </ul>
            </div>
            <span class="topBar__close">x</span>
          </div>
        </div>
        
      </div>
    </div>
  </div>

    <div class="container header__inner">
    <div class="nav__btns header__innerBtns">
      <button class="nav__btn nav__btn--sbcr">Subscribe</button>
      <a class="nav__btn nav__btn--color" href="https://sd.ewtn.com/support-the-register/?source=supportbutton&__hstc=198926896.d85a128133620ac7ff7e851cec25f2f4.1583330347856.1589813305651.1589973817849.36&__hssc=198926896.1.1589973817849&__hsfp=1140930536" target="_blank">Support the register</a>
    </div>
    <div class="header__innerNews hidden-xs">
      <div class="header__breakingNews">
    <p class="header_breakingNews--text"><a href="/subscription/free-trial?KEY=922FREE">Get 6 Free Issues!</a></p>
</div>
    </div>
  </div>

  <header class="header header--sticky nav--sticky">
    <div class="container">
      <div class="header__wrap row">
        <div class="nav nav__itemsInner">
          <div class="nav__items">
            <div class="nav__item nav__item--menu">
            </div>
            <div class="nav__item nav__item--search">
              <img src="/bundles/_themes/swp/default-theme@hy9j1k/img/search.svg">
            </div>
            <div class="nav__search">
              <button class="nav__search__close">x</button>
              <form name="filter" method="get" action="/search">
                <input type="search" placeholder="Search" name="q">
                <button type="submit">Search</button>
              </form>
            </div>
          </div>
          <h1 class="header__logo">
            <a href="https://www.ncregister.com/"><img src="/public/img/ncregister-logo.svg"></a>
            <span>National Catholic Register News</span>
            <span class="header__printUrl">https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us</span>
          </h1>
        </div>

        <div class="nav nav--inner">
                            <div id="header" class="okayNav-header">
            <nav role="navigation" id="nav-main" class="okayNav" style="flex: 1;">
                <ul>
                
                <li class="first">        <a href="/topic/vatican-ii-at-60">Vatican II at 60</a>            
    </li>

    
                <li>        <a href="/topic/2022-midterm-elections">2022 Elections</a>            
    </li>

    
                <li>        <a href="/topic/pope-francis">Pope Francis</a>            
    </li>

    
                <li>        <a href="/section/blogs">Blogs</a>            
    </li>

    
                <li>        <a href="/section/vatican">Vatican</a>            
    </li>

    
                <li>        <a href="/section/register-radio">Register Radio</a>            
    </li>

    
                <li class="last">        <a href="/section/jobs">Job Board</a>            
    </li>


                </ul>
            </nav>
        </div><!-- /header -->
    
        </div>

      </div>
    </div>
    <div class="nav__dropdown">
  <div class="nav__dropdown__img">
    <div class="nav__dropdown__cover">
      <a href="https://www.ncregister.com/subscription/options"><img class="lazyloaded" src="../theme_logo/76/90/9b0ef0701d385783f396d092327a.jpeg" alt="Print issue"></a>
    </div>
    <a href="https://www.ncregister.com/subscription/options"><span>Subscribe</span> to our Print Edition</a>
  </div>
                  <div>
            <ul>
                                    
                            <li class="first">        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first last">        <a href="/">Home</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li>        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/section/news">News</a>            
    </li>


                                
                <li class="item2">        <a href="/section/blogs">Blogs</a>            
    </li>


                                
                <li class="item3">        <a href="/section/commentaries">Commentaries</a>            
    </li>


                                
                <li class="item4">        <a href="/section/features">Features</a>            
    </li>


                                
                <li class="item5">        <a href="/section/interviews">Interviews</a>            
    </li>


                                
                <li class="item6">        <a href="/section/audio">Audio</a>            
    </li>


                                
                <li class="item7">        <a href="/section/video">Video</a>            
    </li>


                                
                <li class="item8">        <a href="/section/cartoons">Cartoons</a>            
    </li>


                                
                <li class="item9 last">        <a href="/section/galleries">Galleries</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li>        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/trending">Most Popular</a>            
    </li>


                                
                <li class="item2">        <a href="/topic/elections2020">U.S. Elections 2020</a>            
    </li>


                                
                <li class="item3">        <a href="/topic/coronavirus">Coronavirus</a>            
    </li>


                                
                <li class="item4">        <a href="/section/college-guide">College Guide</a>            
    </li>


                                
                <li class="item5 last">        <a href="/section/register-radio">Register Radio</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li>        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/section/nation">Nation</a>            
    </li>


                                
                <li class="item2">        <a href="/section/world">World</a>            
    </li>


                                
                <li class="item3">        <a href="/section/vatican">Vatican</a>            
    </li>


                                
                <li class="item4">        <a href="/section/education">Education</a>            
    </li>


                                
                <li class="item5">        <a href="/section/culture-of-life">Culture of Life</a>            
    </li>


                                
                <li class="item6">        <a href="/section/movies">Movies</a>            
    </li>


                                
                <li class="item7">        <a href="/section/arts-entertainment">Arts &amp; Entertainment</a>            
    </li>


                                
                <li class="item8">        <a href="/section/travel">Travel</a>            
    </li>


                                
                <li class="item9">        <a href="/tag/saints">Saints</a>            
    </li>


                                
                <li class="item10">        <a href="/tag/liturgy">Liturgy</a>            
    </li>


                                
                <li class="item11">        <a href="/section/books">Books</a>            
    </li>


                                
                <li class="item12">        <a href="/section/editorial">Editorials</a>            
    </li>


                                
                <li class="item13">        <a href="/section/publishers-note">Publisher&#039;s Note</a>            
    </li>


                                
                <li class="item14 last">        <a href="/section/letter">Letters to the Editor</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li class="last">        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/info/contacts">Contact Us</a>            
    </li>


                                
                <li class="item2">        <a href="https://sd.ewtn.com/support-the-register/?source=supportbutton&amp;__hstc=144805675.0e3c00bbb75b80b016dbdf5451a501e2.1593690492614.1594303257779.1594367786010.20&amp;__hssc=144805675.5.1594367786010&amp;__hsfp=3480365011">Support the Register</a>            
    </li>


                                
                <li class="item3">        <a href="/subscription/options">Print subscriptions</a>            
    </li>


                                
                <li class="item4">        <a href="/feeds/e-newsletter">E-Newsletter Sign-up</a>            
    </li>


                                
                <li class="item5">        <a href="/info/about-us">About Us</a>            
    </li>


                                
                <li class="item6">        <a href="/section/jobs">Job Board</a>            
    </li>


                                
                <li class="item7">        <a href="https://ewtnadvertising.com/">Advertise</a>            
    </li>


                                
                <li class="item8 last">        <a href="https://www.ewtnreligiouscatalogue.com/">EWTN Religious Catalogue</a>            
    </li>



            </ul>
        </div>
    
    </li>



            </ul>
        </div>
    
</div>
  </header>
  
  
<main class="container marginTop30">
  <div class="row">
    <div class="article--left col-md-2 col-sm-12 col-xs-12">
      <!-- AddToAny BEGIN -->
<div class="a2a_kit a2a_kit_size_32 a2a_default_style marginBottom10" data-a2a-icon-color="#fff,#333">
<a class="a2a_button_email"></a>
<a class="a2a_button_twitter"></a>
<a class="a2a_button_facebook"></a>
<a class="a2a_button_print"></a>
<a class="a2a_dd" href="https://www.addtoany.com/share"></a>
</div>
<script async src="https://static.addtoany.com/menu/page.js"></script>
<!-- AddToAny END -->

            <div id='NCR_EN_Article_Left_A' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_A'); });
        </script>
      </div>

      <div id='NCR_EN_Article_Left_B' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_B'); });
        </script>
      </div>

      <div id='NCR_EN_Article_Left_C' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_C'); });
        </script>
      </div>

      <div id='NCR_EN_Article_Left_D' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_D'); });
        </script>
      </div>
    </div><!-- article--left -->

    <div class="article col-md-8 col-sm-12 col-xs-12">
      <article data-io-article-url="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us" >

                
        
        <!-- /1319756/NCR_EN_Article_Top -->
        <div id='NCR_EN_Article_Top'>
          <script>
            googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Top'); });
          </script>
        </div>

                <h1 class="article__headline"> Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us</h1>

        
                        <div class="article__lead">
          <p>There are saintly patrons for our every occupation, need and concern.</p>
        </div>
        
               
        
                                        
                              
  
                                   
  
        <figure class="article__featured">
         <picture>
           <source media="(max-width: 680px)" srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_4da29d4d07944aadf9dce820431ae0825ee7359ab8cfbf05513cc1749148bb2e.webp" type="image/webp">                 
           <source media="(max-width: 680px)" srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_4da29d4d07944aadf9dce820431ae0825ee7359ab8cfbf05513cc1749148bb2e.jpg" type="image/jpeg">
           <source media="(min-width: 681px)" srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_96105b35fec2d63b5d42f2da47d8aa36daca87809bb5e84ba88d1d331a3fc3ee.webp" type="image/webp">           <source media="(min-width: 681px)" srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_96105b35fec2d63b5d42f2da47d8aa36daca87809bb5e84ba88d1d331a3fc3ee.jpg" type="image/jpeg">
           <img src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_96105b35fec2d63b5d42f2da47d8aa36daca87809bb5e84ba88d1d331a3fc3ee.jpg" alt="The Church has many saints among its ranks." title="The Church has many saints among its ranks. ">
         </picture>
        <figcaption>The Church has many saints among its ranks. (photo: Amy Smith photos; public domain photos)</figcaption>
      </figure>
  
                <div class="articleMetadata marginTop30">
                                 
            <span class="articleMetadata__byline">          
              <a href="https://www.ncregister.com/author/amy-smith">Amy Smith</a>            </span>
                      
                                                                                             
          
          <span class="articleMetadata__section"><a href="/section/blogs">Blogs</a></span>

          <time class="articleMetadata__info" datetime="2022-11-01T04:24:22+00:00">November 1, 2022</time>
                  </div>
                        
                        
        
                                <div class="article__text">
          
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        
                              <p>The crucifix.</p>

                                                                      <p>A holy card.</p>

                                                                      <p>A painting of the Blessed Mother.</p>

                                                                      <p>My Catholic heart is comforted when seeing Christ upon the cross, especially amid a particularly hectic day; a saint’s visage on a time-worn holy card prompts my heart to pray, imploring the intercession of a holy person who lived in this so-not-perfect world but persevered on this journey and who now beholds God; and a lovely representation of the Queen of All Saints calls to my mind the time-honored <i>Memorare</i>.</p>

                                                                                                    <p>“Sacred images in our churches and homes are intended to awaken and nourish our faith in the mystery of Christ. Through the icon of Christ and his works of salvation, it is he whom we adore,” states the Catechism of Catholic Church, 1192.&nbsp;</p>

                                                                                                    <blockquote>“Through sacred images of the holy Mother of God, of the angels and of the saints, we venerate the persons represented.”</blockquote>

                                                                      <p>Our friends the saints are ever ready to intercede for us.</p>

                                                                                                    <p>“The witnesses who have preceded us into the kingdom, especially those whom the Church recognizes as saints, share in the living tradition of prayer by the example of their lives, the transmission of their writings, and their prayer today. They contemplate God, praise him and constantly care for those whom they have left on earth. When they entered into the joy of their Master, they were ‘put in charge of many things.’ Their intercession is their most exalted service to God’s plan. We can and should ask them to intercede for us and for the whole world” (2683).</p>

                                                                                                    <div class="inBodyAd marginBottom30">
            <div id='NCR_EN_Article_A'>
              <script>
                googletag.cmd.push(function () { googletag.display('NCR_EN_Article_A'); });
              </script>
            </div>
          </div>
                                                  <p>Like many, I have received roses from St. Thérèse. She reminds me — when I need it most — of the need for childlike trust in God.<br/>
 <br/>
There are, of course, saintly patrons for our every occupation, need and concern.<br/>
 <br/>
I am so grateful for their holy help and feel close to them, for they truly understand all of life’s joy and sorrow, stresses and surprises. They are true heroes and heroines, which we are all in need of, as Notre Dame professor Abigail Favale <a href="https://twitter.com/FavaleAbs/status/1576289153058099200?s=20&amp;t=S_7LORQypr_UpZgTCJo1CA">recently tweeted about</a>.<br/>
 <br/>
They prayed. They worked. They discerned. They were sad. They rejoiced. They cared for family and friends. They sometimes wondered why God allowed this or that to happen. They were grateful when God showed them the way. <i><br/>
 </i><br/>
And they are ever ready to assist us when we need encouragement or help. They come to our aid when we seek their support for difficulties and prayers for loved ones, co-workers, friends, the world and ourselves.&nbsp;</p>

                                                                                                    <p>They are happy for us when we recognize God’s blessings in our lives.<br/>
 <br/>
Most of all, they show us the way to heaven.<br/>
 <br/>
I’m so thankful that St. Faustina shared the powerful prayer of “Jesus, I trust in you” with us.<br/>
 <br/>
She also reminds us to go to the Sacred Heart: “I must strive to make the interior of my soul a resting place for the Heart of Jesus.”<br/>
 <br/>
That’s a beautiful way to put it — for if we rest in the Heart of Jesus, we will be able to reflect, to seek and listen for his direction as we strive heavenward.<br/>
 <br/>
“Pray, hope and don’t worry.”</p>

                                                                                                    <p>Padre Pio was so wise.&nbsp;</p>

                                                                      <p>When we pray, we hope (which is a theological virtue), and we will be less anxious, and we will worry less. That doesn’t mean we will never worry, but it is a reminder to remain rooted in Christ.</p>

                                                                                                    <div class="inBodyAd marginBottom30">
            <div id='NCR_EN_Article_B'>
              <script>
                googletag.cmd.push(function () { googletag.display('NCR_EN_Article_B'); });
              </script>
            </div>
          </div>
                                                  <p>St. John Paul II is such a beloved saint — I love him because he shared hope with the world.&nbsp;</p>

                                                                      <p>He reminds us, “Never, ever give up on hope.”<br/>
 <br/>
He brought his hopeful witness to countless people worldwide, including to his beloved homeland under communist rule and to young people at World Youth Days.<br/>
 <br/>
<i>Never, ever give up on hope!</i><br/>
 <br/>
St. Thérèse is one of my favorite saints — I love her holy witness of living the “Little Way” — loving God and others in the little things. I also draw inspiration from her writings. I particularly love this line from her autobiography, <a href="https://www.ewtnreligiouscatalogue.com/the-story-of-a-soul-autobiography-of-st-therese/p/BKSNT01384"><i>The Story of a Soul</i></a>:<br/>
 <br/>
“My hope was never mistaken.”<br/>
 <br/>
She knew her hope was never mistaken if she stayed close to Jesus. And she reminds us to do likewise.</p>

                                                                                                    <p>There is much to glean from the example of the Little Flower’s mother, St. Zélie Martin, too.<br/>
 <br/>
Amid her busy life raising five daughters and cultivating a Christ-centered household with her husband, St. Louis, she turned to God, even amid suffering the loss of some of her little ones and when enduring cancer. <br/>
 <br/>
St. Zélie reminds us: “Carry on bravely.”<br/>
 <br/>
This quote becomes a prayer when I need heavenly aid and a reminder that, with Christ by my side, I, too, can carry on bravely. And so can you.<br/>
 <br/>
St. Francis de Sales is one of my favorite saint friends, due to his patronage of journalists and writers like me.</p>

                                                                                                    <p>I find encouragement in many of his writings, but I especially love this advice: “Bloom where you are planted.”</p>

                                                                      <p>That lovely little quote is a beautiful reminder that we can indeed “bloom” where we are — right here, right now, following God along the way. We shouldn’t think that we could bloom better elsewhere, but work on focusing on how best to cultivate our unique way to bloom, using the gifts God has blessed us with — and to help others bloom, too.</p>

                                                                                                    <p>St. Gianna is another dear saint friend. She is a holy example for me of the <a href="https://www.ncregister.com/interview/pursuing-god-s-mission-with-feminine-style">feminine genius and living well as a Catholic woman in the modern world</a>, and I seek her intercession for such concerns as well as those related to health (she was a doctor, as well as a wife and mother).<br/>
 <br/>
My favorite quote of hers — and my favorite saint quote overall — is: “Live holy the present moment.”<br/>
 <br/>
Yes, sometimes it’s easier at certain moments than others to truly live the moment in a holy way. We all know that well. But it is still a wonderful goal for us each and every day. God will help us. So will our friends the saints.<br/>
 <br/>
And, of course, there is dear St. Joseph. He knew that dwelling in quiet was an opportunity to listen for God. He had to be quiet to hear the message of the angel in dreams that prompted him to keep Mary and Jesus safe. He shows us to follow God in all things.<br/>
 <br/>
Through it all, I strive to walk with Mother Mary, Queen of All Saints. She has calmed my anxieties, <a href="https://www.ncregister.com/blog/need-help-pray-a-memorare">one Memorare at a time</a>. She has helped me grow in trust of God. She has showed me more and more what it means to have “kept all these things, reflecting on them in her heart.”<br/>
 <br/>
That is what Mary, the Mother of God, always does: She draws us closer to Jesus.<br/>
 <br/>
So I will keep seeking the saints’ intercession, and, most of all, I will keep walking with Mother Mary — one Memorare at a time, just like St. Francis de Sales.</p>

                                                                                                    <div class="inBodyAd marginBottom30">
            <div id='NCR_EN_Article_C'>
              <script>
                googletag.cmd.push(function () { googletag.display('NCR_EN_Article_C'); });
              </script>
            </div>
          </div>
                                                  <p>And I encourage you to do likewise.<br/>
 <br/>
St. Faustina, St. Pio, St. John Paul II, St. Thérèse, St. Zélie, St. Francis de Sales, St. Gianna, St. Joseph and Mother Mary, pray for us!&nbsp;</p>

                                                                                                    <p>All you holy men and women, pray for us!</p>

                                                                      <p><br/></p>

                                                                      <p><i>Editor’s Note: Parts of this blog were adapted from Amy’s talk from the </i><a href="https://www.ncregister.com/blog/listening-for-god-conference-aims-to-help-catholics-recognize-godcidences-in-life"><i>“Listening for God” virtual conference</i></a><i>.</i></p>

                                                                                                    <p>&nbsp;</p>
                                                                    </div>
                        
        
                                                      <ul class="article__keywords">
            <li>Keywords: </li>
              
                <li><a href="https://www.ncregister.com/tag/catholic-saints">catholic saints</a></li>
                                  
                <li><a href="https://www.ncregister.com/tag/all-saints-day">all saints&#039; day</a></li>
              
          </ul>
                                              				  				    				                  
			      <div class="authorMetadata">       
			        <figure class="authorMetadata__image"><img src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/authors/amy-smith_bfb10e8ae3a3099df74158b19769099c01437ccc.jpeg" alt="Amy Smith"></figure>
			        <div class="authorMetadata__info">
			          <p><a href="https://www.ncregister.com/author/amy-smith">Amy Smith</a> Amy Smith is the Register’s associate editor who edits features for the “Culture of Life” section. Fueled by prayer and coffee, she enjoys writing about everything from Jane Austen to saints for the Register. She is the author of  <a href="https://www.ewtnreligiouscatalogue.com/the-plans-god-has-for-you/p/BKCTM13115"><em>The Plans God Has for You: Hopeful Lessons for Young Women</em></a> (Emmaus Road Publishing, 2020). Her writing has also appeared in various other Catholic publications. She has a master’s degree in journalism and a B.A. in English. Find her online at <a href="https://www.instagram.com/hopefulwordsmith/">Instagram.com/hopefulwordsmith</a> and <a href="https://twitter.com/hope_wordsmith">Twitter.com/hope_wordsmith</a>.</p>
						<ul class="authorFull__social">														<li><a href="https://www.instagram.com/hopefulwordsmith" target="_BLANK"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-ig.svg" alt="Instagram"></a></li>							<li><a href="https://twitter.com/@hope_wordsmith" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-tw.svg" alt="Twitter"></a></li>						</ul>			        </div>
			      </div>
                  
        <!-- /1319756/NCR_EN_Slider -->

        <div id='NCR_EN_Slider'>
          <script>
            googletag.cmd.push(function() { googletag.display('NCR_EN_Slider'); });
          </script>
        </div>

        <button class="article__commBtnHide" style="display:none;">Toggle Comments</button>
<div id="coral_thread" class="article__comms">
  <button class="article__commBtn marginBottom10">Show Comments <span class="coral-count article__commsCou
nt" data-coral-url="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us" data-coral-notext="true"></span></button>
</div>


<script type="text/javascript">
  $("#coral_thread button").on("click", function() {
      var d = document, s = d.createElement('script');
      s.src = 'https://ncregister.coral.coralproject.net/assets/js/embed.js';
      s.async = false;
      s.defer = true;
      s.onload = function() {
          Coral.createStreamEmbed({
              id: "coral_thread",
              autoRender: true,
              rootURL: 'https://ncregister.coral.coralproject.net/',
              // Uncomment these lines and replace with the ID of the
              // story's ID and URL from your CMS to provide the
              // tightest integration. Refer to our documentation at
              // https://docs.coralproject.net for all the configuration
              // options.
                            storyID: '108952',
              storyURL: 'https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us',              
                        });
      };
      (d.head || d.body).appendChild(s);

      $(".article__commBtnHide").css('display','block');
  });

  $(".article__commBtnHide").on("click", function() {
     $("#coral_thread iframe").toggleClass("hide");
  });
</script>
                
      </article>

            <div class="row marginTop30">

        <div class="col-md-8 col-sm-12 col-xs-12">
          <div id="tabs" class="tabs marginBottom30">
            <ul class="tabs__items">
              <li class="tabs__item"><a href="#tab1" class="tabs__item--active">Related Stories</a></li>
              <li class="tabs__item"><a href="#tab2">Latest News</a></li>
              <li class="tabs__item"><a href="#tab3">Blogs</a></li>
            </ul>

            <div class="tabs__content row">

              <div id="#tab1" class="tab__content tab__content--active">
                <div class="articleGrid articleGrid--twoColumns">

                                                
    
            
        
        <article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--cna">
        <a href="https://www.ncregister.com/cna/4-ideas-to-celebrate-holywins-with-your-family-on-the-eve-of-all-saints">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221030131048_f72c9b2db9aff1f26f116806fc3f9e046694ccc0fe611411d5a68fe0c477a161.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221030131048_f72c9b2db9aff1f26f116806fc3f9e046694ccc0fe611411d5a68fe0c477a161.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221030131048_f72c9b2db9aff1f26f116806fc3f9e046694ccc0fe611411d5a68fe0c477a161.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221030131048_f72c9b2db9aff1f26f116806fc3f9e046694ccc0fe611411d5a68fe0c477a161.jpg" alt="St. Thérèse as St. Joan of Arc" title="St. Thérèse as St. Joan of Arc ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/cna/4-ideas-to-celebrate-holywins-with-your-family-on-the-eve-of-all-saints">4 Ideas to Celebrate ‘Holywins’ With Your Family on the Eve of All Saints</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Celebrate Halloween with Catholic devotion and fun. </p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">CNA Staff</span>
            
                                                                                                               
            
            <a href="/section/features">Features</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/cna/4-ideas-to-celebrate-holywins-with-your-family-on-the-eve-of-all-saints#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/cna/4-ideas-to-celebrate-holywins-with-your-family-on-the-eve-of-all-saints" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>
                        
        
        <article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--feature">
        <a href="https://www.ncregister.com/features/saint-book-picks">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221025151048_bb9f2abd602cbaaab5b8a3fe45fe62a6e8a7d440eaca5ae1216fd969727a78c4.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221025151048_bb9f2abd602cbaaab5b8a3fe45fe62a6e8a7d440eaca5ae1216fd969727a78c4.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221025151048_bb9f2abd602cbaaab5b8a3fe45fe62a6e8a7d440eaca5ae1216fd969727a78c4.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221025151048_bb9f2abd602cbaaab5b8a3fe45fe62a6e8a7d440eaca5ae1216fd969727a78c4.jpg" alt="Four good reads are timely for All Saints’ Day." title="Four good reads are timely for All Saints’ Day. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/features/saint-book-picks">Seeking Saintly Guidance: A Reading List</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>BOOKS PICKS for All Saints’ Day and Beyond</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/joseph-pronechen">Joseph Pronechen</a></span>
            
                                                                                                               
            
            <a href="/section/books">Books</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/features/saint-book-picks#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/features/saint-book-picks" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>
                        
        
        <article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--cna">
        <a href="https://www.ncregister.com/cna/st-john-paul-ii-the-eucharist-is-the-secret-of-my-day">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221022121016_34d12b21188633dea12979d2f4c9e25539480f1250ce9a1758f23283a93d45a8.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221022121016_34d12b21188633dea12979d2f4c9e25539480f1250ce9a1758f23283a93d45a8.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221022121016_34d12b21188633dea12979d2f4c9e25539480f1250ce9a1758f23283a93d45a8.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221022121016_34d12b21188633dea12979d2f4c9e25539480f1250ce9a1758f23283a93d45a8.jpg" alt="Pope St. John Paul II holds a monstrance amid Eucharistic adoration during his 1988 papal visit through Africa." title="Pope St. John Paul II holds a monstrance amid Eucharistic adoration during his 1988 papal visit through Africa. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/cna/st-john-paul-ii-the-eucharist-is-the-secret-of-my-day">St. John Paul II: ‘The Eucharist Is the Secret of My Day’</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>15 quotes from the beloved saint on his love for the Blessed Sacrament</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Katie Yoder/CNA</span>
            
                                                                                                               
            
            <a href="/section/features">Features</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/cna/st-john-paul-ii-the-eucharist-is-the-secret-of-my-day#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/cna/st-john-paul-ii-the-eucharist-is-the-secret-of-my-day" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>
                        
        
        <article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--news">
        <a href="https://www.ncregister.com/news/in-memoriam-father-john-horgan">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221021161044_0150145da00be1df6a68674f4f9e740ce7fee0f059ddfab3cfdb3735b0362351.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221021161044_0150145da00be1df6a68674f4f9e740ce7fee0f059ddfab3cfdb3735b0362351.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221021161044_0150145da00be1df6a68674f4f9e740ce7fee0f059ddfab3cfdb3735b0362351.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221021161044_0150145da00be1df6a68674f4f9e740ce7fee0f059ddfab3cfdb3735b0362351.jpg" alt="Father John Horgan was well-known to EWTN audiences." title="Father John Horgan was well-known to EWTN audiences. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/news/in-memoriam-father-john-horgan">In Memoriam, Father John Horgan: ‘Faith Was the Driving Force of His Whole Life’</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Remembering the expert on saints and angels who was a dedicated ‘priest of Jesus Christ,’ according to those who knew him.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/joseph-pronechen">Joseph Pronechen</a></span>
            
                                                                                                               
            
            <a href="/section/nation">Nation</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/news/in-memoriam-father-john-horgan#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/news/in-memoriam-father-john-horgan" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>
                                
                </div>
              </div>

              <div id="#tab2" class="tab__content">
                <div class="articleGrid articleGrid--twoColumns">
                  


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--commentary">
        <a href="https://www.ncregister.com/commentaries/humility-lives-in-all-the-saints">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103116104_2b9bc79531bb792194f391560df8e75fb4158e94e88bc7aa974ab6983ef576aa.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103116104_2b9bc79531bb792194f391560df8e75fb4158e94e88bc7aa974ab6983ef576aa.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103116104_2b9bc79531bb792194f391560df8e75fb4158e94e88bc7aa974ab6983ef576aa.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103116104_2b9bc79531bb792194f391560df8e75fb4158e94e88bc7aa974ab6983ef576aa.jpg" alt="Sts. Albert the Great, Thérèse and Martin de Porres are models of humility." title="Sts. Albert the Great, Thérèse and Martin de Porres are models of humility. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/commentaries/humility-lives-in-all-the-saints">Humility Lives in All the Saints</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>COMMENTARY: Let us take a quick glimpse at how a handful of saints embodied humility, recognizing both their own human weakness and the great things God called them to do through the strength of his grace.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/kevin-vost-psy-d">Kevin Vost, Psy.D.</a></span>
            
                                                                                                               
            
            <a href="/section/commentaries">Commentaries</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/commentaries/humility-lives-in-all-the-saints#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/commentaries/humility-lives-in-all-the-saints" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--cna">
        <a href="https://www.ncregister.com/cna/total-abortions-decreased-by-6-in-the-u-s-after-roe-v-wade-was-overturned">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031171016_424a749e917f13834813c802d4e20512a234e90c54f5bbf0ae730a946ed9a1d2.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031171016_424a749e917f13834813c802d4e20512a234e90c54f5bbf0ae730a946ed9a1d2.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031171016_424a749e917f13834813c802d4e20512a234e90c54f5bbf0ae730a946ed9a1d2.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031171016_424a749e917f13834813c802d4e20512a234e90c54f5bbf0ae730a946ed9a1d2.jpg" alt="" title=" ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/cna/total-abortions-decreased-by-6-in-the-u-s-after-roe-v-wade-was-overturned">Total Abortions Decreased by 6% in the U.S. After Roe v. Wade Was Overturned</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Pro-life research organizations applauded the finding.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Katie Yoder/CNA</span>
            
                                                                                                               
            
            <a href="/section/nation">Nation</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/cna/total-abortions-decreased-by-6-in-the-u-s-after-roe-v-wade-was-overturned#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/cna/total-abortions-decreased-by-6-in-the-u-s-after-roe-v-wade-was-overturned" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--cna">
        <a href="https://www.ncregister.com/cna/colombia-celebrates-beatification-of-maria-berenice-duque-foundress-of-three-congregations">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103115108_966caf17e721bafa3b582c09a091d07ee3c06098a9de73f6bd393eb674cb36c2.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103115108_966caf17e721bafa3b582c09a091d07ee3c06098a9de73f6bd393eb674cb36c2.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103115108_966caf17e721bafa3b582c09a091d07ee3c06098a9de73f6bd393eb674cb36c2.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/2022103115108_966caf17e721bafa3b582c09a091d07ee3c06098a9de73f6bd393eb674cb36c2.jpg" alt="" title=" ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/cna/colombia-celebrates-beatification-of-maria-berenice-duque-foundress-of-three-congregations">Colombia Celebrates Beatification of María Berenice Duque, Foundress of Three Congregations</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>The cause for her beatification began in Medellín on May 23, 2002.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">CNA Staff</span>
            
                                                                                                               
            
            <a href="/section/world">World</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/cna/colombia-celebrates-beatification-of-maria-berenice-duque-foundress-of-three-congregations#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/cna/colombia-celebrates-beatification-of-maria-berenice-duque-foundress-of-three-congregations" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--cna">
        <a href="https://www.ncregister.com/cna/us-bishops-offer-pro-family-policy-recommendations-ahead-of-midterms">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031161040_1654b352721c2d72ab4a4a7dc1b36b4c2af82cc67d2ba41a8d6e21bad140772d.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031161040_1654b352721c2d72ab4a4a7dc1b36b4c2af82cc67d2ba41a8d6e21bad140772d.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031161040_1654b352721c2d72ab4a4a7dc1b36b4c2af82cc67d2ba41a8d6e21bad140772d.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031161040_1654b352721c2d72ab4a4a7dc1b36b4c2af82cc67d2ba41a8d6e21bad140772d.jpg" alt="A mom holds her newborn." title="A mom holds her newborn. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/cna/us-bishops-offer-pro-family-policy-recommendations-ahead-of-midterms">US Bishops Offer Pro-Family Policy Recommendations Ahead of Midterms</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>The USCCB expressed support for such measures as reasonable accommodations for pregnant and breastfeeding mothers; support for a child tax credit; tax credits and other assistance for pregnancy resource centers; initiatives to support federal paid family leave; strengthening of maternal and child health care; and adoption support.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Jonah McKeown/CNA</span>
            
                                                                                                               
            
            <a href="/section/nation">Nation</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/cna/us-bishops-offer-pro-family-policy-recommendations-ahead-of-midterms#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/cna/us-bishops-offer-pro-family-policy-recommendations-ahead-of-midterms" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

                </div>
              </div>

              <div id="#tab3" class="tab__content">
                <div class="articleGrid articleGrid--twoColumns">
                  
<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_7a82644bcfeb1edc9ca477ca7ef41acc0640c37c2d545debd375f5515cc8fab8.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_7a82644bcfeb1edc9ca477ca7ef41acc0640c37c2d545debd375f5515cc8fab8.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_7a82644bcfeb1edc9ca477ca7ef41acc0640c37c2d545debd375f5515cc8fab8.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031151028_7a82644bcfeb1edc9ca477ca7ef41acc0640c37c2d545debd375f5515cc8fab8.jpg" alt="The Church has many saints among its ranks." title="The Church has many saints among its ranks. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us">Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>There are saintly patrons for our every occupation, need and concern.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/amy-smith">Amy Smith</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/exorcist-says-demons-are-not-to-be-feared">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031141016_97d459a3feb6e6e74477a484a974420ff65e35dd1207396472304e1aaeb09c4f.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031141016_97d459a3feb6e6e74477a484a974420ff65e35dd1207396472304e1aaeb09c4f.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031141016_97d459a3feb6e6e74477a484a974420ff65e35dd1207396472304e1aaeb09c4f.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031141016_97d459a3feb6e6e74477a484a974420ff65e35dd1207396472304e1aaeb09c4f.jpg" alt="Ary Scheffer, “The Temptation of Christ”, 1854 " title="Ary Scheffer, “The Temptation of Christ”, 1854  ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/exorcist-says-demons-are-not-to-be-feared">Exorcist Goes Viral on Social Media, Says ‘Demons Are Not to Be Feared’</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>‘They’re on a short leash,’ says Father Chad Ripperger. ‘They can only do what Christ permits.’</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/sarah-robsdottir">Sarah Robsdottir</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/exorcist-says-demons-are-not-to-be-feared#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/exorcist-says-demons-are-not-to-be-feared" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/the-only-really-good-reason-to-cheat">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031131012_30b3890b5dc8f02d7ef3a7f4ab5b7cfe3996757cf43b3df435c38ccb5d4399d6.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031131012_30b3890b5dc8f02d7ef3a7f4ab5b7cfe3996757cf43b3df435c38ccb5d4399d6.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031131012_30b3890b5dc8f02d7ef3a7f4ab5b7cfe3996757cf43b3df435c38ccb5d4399d6.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031131012_30b3890b5dc8f02d7ef3a7f4ab5b7cfe3996757cf43b3df435c38ccb5d4399d6.jpg" alt="‘Cheating’" title="‘Cheating’ ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/the-only-really-good-reason-to-cheat">This Is the Only Really Good Reason to Cheat</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>‘Sin creates a proclivity to sin; it engenders vice by repetition of the same acts.’ (CCC 1865)</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/matt-d-antuono">Matt D’Antuono</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/the-only-really-good-reason-to-cheat#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/the-only-really-good-reason-to-cheat" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">
                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
      
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/from-wicca-to-catholicism-how-humility-conquers-pride-and-more-great-links">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031101040_99ab090d76c0466f12e80f26c80a99b6158a6d5b3caa3ec786617193fcc8e40a.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031101040_99ab090d76c0466f12e80f26c80a99b6158a6d5b3caa3ec786617193fcc8e40a.jpg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031101040_99ab090d76c0466f12e80f26c80a99b6158a6d5b3caa3ec786617193fcc8e40a.jpg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-ncreg.s3.us-east-2.amazonaws.com/pb-ncregister/swp/hv9hms/media/20221031101040_99ab090d76c0466f12e80f26c80a99b6158a6d5b3caa3ec786617193fcc8e40a.jpg" alt="Model Wicca Witch Photo" title="Model Wicca Witch Photo ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/from-wicca-to-catholicism-how-humility-conquers-pride-and-more-great-links">From Wicca to Catholicism, How Humility Conquers Pride, and More Great Links!</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>The Best In Catholic Blogging</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/tito-edwards">Tito Edwards</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/from-wicca-to-catholicism-how-humility-conquers-pride-and-more-great-links#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/from-wicca-to-catholicism-how-humility-conquers-pride-and-more-great-links" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

                </div>
              </div>

            </div>
          </div>

          <script>

            var tabItems = document.getElementsByClassName('tabs__items')[0].getElementsByTagName('a');
            var tabContent = document.getElementById('tabs').getElementsByClassName('tab__content');

            for (var i = 0; i < tabItems.length; i++) {
              tabItems[i].addEventListener('click', activateTab, false);
            }


            function activateTab(event) {
              for (var e = 0; e < tabItems.length; e++) {
                tabItems[e].classList.remove("tabs__item--active");
                if (tabContent[e] != null) {
                  tabContent[e].classList.remove("tab__content--active");
                }
              }
              this.classList.add("tabs__item--active");
              document.getElementById(this.getAttribute("href")).classList.add("tab__content--active");
              event.preventDefault();
            }

          </script>
        </div>

        <div class="col-md-4 col-sm-12 col-xs-12">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
  <div class="accordion marginBottom30">
    <h3 class="sectionHeading marginTop30"><span class="sectionHeading__big">Trending</span></h3>
    <div class="accordion__section">
      <div class="accordion__sectionContent">
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/features/sewing-the-sacred-finding-the-catholic-faith-amid-fashion">Sewing the Sacred: Finding the Catholic Faith Amid Fashion</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/love-is-blind-down-syndrome-remarks">Love for Kids With Down Syndrome Turns Cold on Netflix Show ‘Love Is Blind’</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/exorcist-says-demons-are-not-to-be-feared">Exorcist Goes Viral on Social Media, Says ‘Demons Are Not to Be Feared’</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/features/saint-book-picks">Seeking Saintly Guidance: A Reading List</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/cna/4-ideas-to-celebrate-holywins-with-your-family-on-the-eve-of-all-saints">4 Ideas to Celebrate ‘Holywins’ With Your Family on the Eve of All Saints</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/what-the-church-says-about-usury">What Benedict XVI, Francis and Other Popes and Councils Say About Usury</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/who-will-be-next-usccb-president-2022">Who Will Be the Next USCCB President? Assessing the Field</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/for-syriac-catholics-hope-prevails-in-turkey">For Syriac Catholics, Hope Prevails in Turkey</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/zacchaeus-31st-sunday-year-c">31st Sunday and Zacchaeus — ‘Today I Must Stay at Your House’</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/cna/pope-francis-prays-for-victims-of-deadly-islamic-terrorist-attack-in-somalia">Pope Francis Prays for Victims of Deadly Islamic Terrorist Attack in Somalia</a></h4>
        </article>
              </div>
    </div>
  </div>
  
        </div>

      </div>
      
    </div>

    <div class="col-md-2 col-sm-12 col-xs-12">
          </div>

  </div>
</main>

<script type="text/javascript" async>
window.addEventListener('load',function(){
var xhr = new XMLHttpRequest();
var read_date = new Date();
var request_randomizer = "&" + read_date.getTime() + Math.random();
xhr.open('GET', '/_swp_analytics?articleId=108952'+request_randomizer+'&ref='+document.referrer);
xhr.send();
})
</script>


    <div id='NCR_EN_Footer_Banner' class="centerAd marginY30">
    <script>
      googletag.cmd.push(function () { googletag.display('NCR_EN_Footer_Banner'); });
    </script>
  </div>
  
  <!-- Footer -->

    <footer class="footer marginTop30">
    <div class="footer__wrap">
      <div class="footer__wrapItems">
        <a class="footer__logo" href="https://www.ncregister.com/"><img
            src="/bundles/_themes/swp/default-theme@hy9j1k/img/ncregister-logo.svg"></a>
        <ul class="footer__social">
          <li><a href="https://www.facebook.com/NCRegister" target="_BLANK"><img
                src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-fb.svg" alt="Facebook"></a></li>
          <li><a href="https://twitter.com/NCRegister" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-tw.svg"
                alt="Twitter"></a></li>
          <li><a href="https://www.instagram.com/ncregister/" target="_blank"><img
                src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-ig.svg" alt="Instagram"></a></li>
          <li><a href="https://www.youtube.com/user/NCRegister" target="_blank"><img
                src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-yt.svg" alt="Youtube"></a></li>
          <li><a href="https://www.ncregister.com/feeds/general-news.xml" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-rss.svg"
                alt="RSS"></a></li>
          <li><a href="https://www.ncregister.com/feeds/e-newsletter" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-email.svg"
                alt="Email"></a></li>
        </ul>
      </div>
    </div>
    
        <div class="container">
                        <div>
        <ul class="footer__items ">
                            
                            <li class="first">        <a href="#">Social media</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="https://www.facebook.com/NCRegister">Facebook</a>            
    </li>

    
                <li>        <a href="https://twitter.com/NCRegister">Twitter</a>            
    </li>

    
                <li>        <a href="https://www.instagram.com/ncregister/">Instagram</a>            
    </li>

    
                <li class="last">        <a href="https://www.youtube.com/user/NCRegister">Youtube</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li>        <a href="#">Tools &amp; Features</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="/feeds/e-newsletter">E-Newsletters</a>            
    </li>

    
                <li>        <a href="/info/rss-feeds">RSS Feeds</a>            
    </li>

    
                <li>        <a href="#">Register News Widget</a>            
    </li>

    
                <li>        <a href="https://soundcloud.com/ewtn-radio">Register Radio Podcast</a>            
    </li>

    
                <li class="last">        <a href="/section/college-guide">College Guide</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li>        <a href="#">Print Subscriptions</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="/subscription/subscribe?KEY=922NBT">Subscribe</a>            
    </li>

    
                <li>        <a href="/subscription/options">Manage a Subscription</a>            
    </li>

    
                <li>        <a href="/subscription/gift?KEY=922NBG">Give a Subscription</a>            
    </li>

    
                <li class="last">        <a href="/subscription/bulk-order">Order Bulk Subscriptions</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li>        <a href="#">Marketplace</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="https://ewtnadvertising.com/">Advertise</a>            
    </li>

    
                <li>        <a href="/section/jobs">Job Board</a>            
    </li>

    
                <li class="last">        <a href="https://www.ewtnreligiouscatalogue.com/">EWTN Religious Catalogue</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li class="last">        <a href="#">More</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="/info/about-us">About Us</a>            
    </li>

    
                <li>        <a href="/info/contacts">Contact Us</a>            
    </li>

    
                <li>        <a href="https://sd.ewtn.com/support-the-register/?source=supportbutton&amp;__hstc=144805675.0e3c00bbb75b80b016dbdf5451a501e2.1593690492614.1594029723284.1594036196954.9&amp;__hssc=144805675.12.1594036196954&amp;__hsfp=3480365011">Support Us</a>            
    </li>

    
                <li>        <a href="/archives">Archives</a>            
    </li>

    
                <li>        <a href="/info/editorial-guidelines">Writers Guidelines</a>            
    </li>

    
                <li>        <a href="/info/submit-letter-to-editor">Submit Letter to Editor</a>            
    </li>

    
                <li>        <a href="/info/reproduction-or-reuse-of-register-content">Reprints and Permissions</a>            
    </li>

    
                <li class="last">        <a href="/info/ncr-privacy-policy">Privacy Policy</a>            
    </li>


        </ul>
      </div>
    
    </li>


        </ul>
      </div>
    
    </div>
    
    <div class="footer__text">
      <div class="container">
        <p>Copyright © 2022 EWTN News, Inc. All rights reserved. EIN 27-4581132<br>
          Reproduction of material from this website without written permission, or unlicensed commercial use or
          monetization of National Catholic Register RSS feeds is strictly prohibited.</p>
      </div>
    </div>
  </footer>
  
  <div class="popUp">
    <div class="popUp__headlineWrap">
      <h3 class="popUp__headline">Subscription Options</h3>
      <button class="popUp__close">x</button>
    </div>
    <div class="popUp__wrap">
      <div class="popUp__img">
        <img src="/public/img/Pop_Up_visual.jpg">
      </div>
      <div class="popUp__items">
        <ul>
          <li>
            <p><span>Subscriber Service Center</span>Already a subscriber? Renew or manage your subscription <a
                href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR"
                target="_blank">here</a>.</p>
          </li>
          <li>
            <p><span>Subscribe</span>Start your Register subscription today.</p>
            <a href="https://www.ncregister.com/subscription/subscribe?KEY=922NSP" class="popUp__btn">Subscribe Now</a>
          </li>
          <li>
            <p><span>Sign up for 6 Free Issues</span>Try us out with a free trial subscription.</p>
            <a href="https://www.ncregister.com/subscription/free-trial?KEY=922MHFR" class="popUp__btn">Order Now</a>
          </li>
          <li>
            <p><span>Give a Gift Subscription</span>Bless friends, family or clergy with a gift of the Register.</p>
            <a href="https://www.ncregister.com/subscription/gift?KEY=922NGT" class="popUp__btn">Order Now</a>
          </li>
          <li>
            <p><span>Order Bulk Subscriptions</span>Get a discount on 6 or more copies sent to your parish, organization
              or school.</p>
            <a href="https://www.ncregister.com/subscription/bulk-order" class="popUp__btn">Order Now</a>
          </li>
          <li>
            <p><span>Sign-up for E-Newsletter</span>Get Register Updates sent daily or weeklyto your inbox. </p>
            <a href="https://www.ncregister.com/feeds/e-newsletter" class="popUp__btn">Sign Up</a>
          </li>
        </ul>
      </div>
    </div>
  </div>
  <div class="popUp__bck"></div>
  <div class="nav__dropdownBck"></div>

  <script src="/public/dist/bundle.1635179830833.js"></script>
</body>

  <script>
window._io_config = window._io_config || {};
window._io_config["0.2.0"] = window._io_config["0.2.0"] || [];
window._io_config["0.2.0"].push({
  page_url: "https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us",
  page_url_canonical: "https://www.ncregister.com/blog/holy-help-our-friends-the-saints-are-ever-ready-to-intercede-for-us",
  page_title: "Holy Help: Our Friends the Saints Are Ever Ready to Intercede for Us",
  page_type: "article",
  page_language: "en",
    article_authors: ["Amy Smith"],
    article_categories: ["Blogs, "],
  article_type: "news",
  article_word_count: "1215",
  article_publication_date: "Tue, 01 Nov 2022 04:24:22 +0000"
});
</script>

</html>
