<!DOCTYPE html>
<html lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  <!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame
  Remove this if you use the .htaccess -->
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

  <title>After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge| National Catholic Register</title>
  
<meta name="description"
  content="Fr. Clark and two women were arrested Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations a...">
<meta name="keywords"
  content="priest defiles altar,new orleans,archbishop gregory aymond">
<link rel="canonical" href="https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge" />
<meta property="og:site_name" content="NCR" />
<meta property="fb:app_id" content="347756275321330" />
<meta property="fb:pages" content="64182915497">
<meta property="og:description"
  content="Fr. Clark and two women were arrested Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations atop the altar, which was illuminated by stage lights." />
<meta property="og:title"
  content="After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge" />
<meta property="og:image" content="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_ef89c6d3dc14edd8f3a2a6fc2868f94c16d51f3a8f1ac192186af86ff95c00e9.jpeg" />
<meta property="og:image:width" content="934" />
<meta property="og:image:height" content="622" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_ef89c6d3dc14edd8f3a2a6fc2868f94c16d51f3a8f1ac192186af86ff95c00e9.jpeg" />
<meta name="twitter:site" content="@NCRegister">
<meta name="twitter:creator" content="@NCRegister">
<meta name="twitter:title"
  content="After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge">
<meta name="twitter:description"
  content="Fr. Clark and two women were arrested Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations atop the altar, which was illuminated by stage lights.">
<meta itemprop="name" content="After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge">

<link rel="amphtml" href="https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge?amp">

<meta name="sp.guid" content="urn:newsml:ncregister-api.superdesk.pro:2020-10-13T01:40:25.152127:5e3d488e-01a9-44b6-88b4-1f18cc7daf43" />
<meta name="sp.sd"
  content="https://ncregister.superdesk.pro">

  <!-- RSS & Pingback -->
  <meta name="google-site-verification" content="fH2AP0niyimtMl7gbXZxEEOYh0-SDCGbWnO5xzGZ7Ag" />
  <meta name="viewport" content="width=device-width, initial-scale=1">
  <link rel="shortcut icon" href="/bundles/_themes/swp/default-theme@hy9j1k/img/icons/favicon.ico" />
  <link rel="stylesheet" href="/public/dist/bundle.1601369928734.css" />
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js"></script>
  <script async src="https://cdn.onthe.io/io.js/2xVbjp7MTWBn"></script>
  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  <script async src="//78b862e3e94243179acffa9ac56fc2a1.js.ubembed.com" ></script>

<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var mappingHeaderBanner = googletag.sizeMapping(). //all
        addSize([992, 0], [[728, 90], [970, 90]]). //desktop
        addSize([768, 0], [728, 90]). //tablet
        addSize([0, 0], []). //no mobile
        build();
    var mappingFooterBanner = googletag.sizeMapping(). //all
        addSize([992, 0], [[728, 90], [970, 90]]). //desktop
        addSize([768, 0], [728, 90]). //tablet
        addSize([320, 0], [320, 50]). //mobile
        addSize([0, 0], []). //other
        build();
    var mappingARTopBanner = googletag.sizeMapping(). //articles
        addSize([992, 0], []). //desktop
        addSize([768, 0], []). //tablet
        addSize([320, 0], [320, 50]). //mobile
        addSize([0, 0], []).
        build();
    var mappingARLeft = googletag.sizeMapping(). //article left
        addSize([992, 0], [[180, 150], [180, 300], 'fluid']). //desktop
        addSize([0, 0], []). //other
        build();
   var mappingSlider = googletag.sizeMapping(). //all
       addSize([992, 0], [[728, 90], [970, 90], [300, 250]]). //desktop
       addSize([768, 0], [[728, 90], [300, 250]]). //tablet
       addSize([320, 0], [[300, 250], [320, 50]]). //mobile
       addSize([0, 0], []). //other
       build();
    googletag.defineSlot('/1319756/NCR_EN_Header_Banner', [[728, 90], [970,90]], 'NCR_EN_Header_Banner').defineSizeMapping(mappingHeaderBanner).addService(googletag.pubads()).setCollapseEmptyDiv(true,true); //all
    googletag.defineSlot('/1319756/NCR_EN_WebLink', ['fluid'], 'NCR_EN_WebLink').addService(googletag.pubads()); //all
    googletag.defineSlot('/1319756/NCR_EN_Footer_Banner', [[320, 50], [728, 90], [970,90]], 'NCR_EN_Footer_Banner').defineSizeMapping(mappingFooterBanner).addService(googletag.pubads()); //all
    googletag.defineSlot('/1319756/NCR_EN_Home_Center', ['fluid'], 'NCR_EN_Home_Center').addService(googletag.pubads()).setCollapseEmptyDiv(true,true); //home
    googletag.defineSlot('/1319756/NCR_EN_Article_A', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_A').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Article_B', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_B').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Article_C', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_C').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Article_D', [[1, 1], [300, 250], 'fluid'], 'NCR_EN_Article_D').addService(googletag.pubads()); //articles landings home
    googletag.defineSlot('/1319756/NCR_EN_Slider', [[300, 250], [320, 50], [728, 90], [970,90]], 'NCR_EN_Slider').defineSizeMapping(mappingSlider).addService(googletag.pubads()); //articles landings
    googletag.defineSlot('/1319756/NCR_EN_Article_Top', [[728, 90], [320, 50]], 'NCR_EN_Article_Top').defineSizeMapping(mappingARTopBanner).addService(googletag.pubads()).setCollapseEmptyDiv(true,true); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_A', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_A').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_B', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_B').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_C', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_C').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_Left_D', [[180, 150], [180, 300], 'fluid'], 'NCR_EN_Article_Left_D').defineSizeMapping(mappingARLeft).addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_E', ['fluid'],'NCR_EN_Article_E').addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_F', ['fluid'],'NCR_EN_Article_F').addService(googletag.pubads()); //articles
    googletag.defineSlot('/1319756/NCR_EN_Article_G', ['fluid'],'NCR_EN_Article_G').addService(googletag.pubads()); //articles
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs(true);
    if (typeof metaTags != 'undefined')
      googletag.pubads().setTargeting('Keyword', metaTags);
    googletag.enableServices();

  });

</script>

  <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-KB6S87');</script>
  <!-- End Google Tag Manager -->

  <script type="text/javascript">
  // Facebook
  window.fbAsyncInit = function() {
    FB.init({
      appId   : '347756275321330',
      xfbml   : true,
      version : 'v2.12'
    });
  };

  (function(d, s, id){
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) {return;}
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

  function getCookie(cname) {
    var cs = document.cookie.split(/;\s*/),
        name = cname + '=';
    for (var i = 0; i < cs.length; i++) {
      if (cs[i].indexOf(name) == 0)
        return cs[i].substr(name.length);
    }
    return '';
  }

  function setCookie(cname, value, expDays) {
    var c = cname + '=' + value;
    if (expDays) {
      var d = new Date();
      d.setTime(d.getTime() + expDays * 24 * 60 * 60 * 1000);
      c += '; expires=' + d.toUTCString() + '; path=/';
    }
    document.cookie = c;
  }
  </script>

    <script class="coral-script" src="//ncregister.coral.coralproject.net/assets/js/count.js" defer></script>  
  
  <script type="text/javascript">
  var metaUrl = 'https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge',
    metaPath = 'news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge',
    metaTitle = "After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge",
    metaDescr = "Fr. Clark and two women were arrested Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations atop the altar, which was illuminated by stage lights.",
      metaTags = ['NCR_News',   ''   ,  'priest defiles altar',    'new orleans',    'archbishop gregory aymond' ];
</script>

  <script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "BreadcrumbList",
  "itemListElement": [{
    "@type": "ListItem",
    "position": 1,
    "name": "Front page",
    "item": "https://www.ncregister.com"
  },{
    "@type": "ListItem",
    "position": 2,
    "name": "News",
    "item": "https://www.ncregister.com/news"
  },{
    "@type": "ListItem",
    "position": 3,
    "name": "After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge",
    "item": "https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge"
  }]
}
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge"
  },
  "headline": "After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge",
  "image": [
  	    "https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_ef89c6d3dc14edd8f3a2a6fc2868f94c16d51f3a8f1ac192186af86ff95c00e9.jpeg",
            "https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_adccb8ac00d96d02144209c55f26a71dd8d07471430aee758150ba2d35bc71cd.jpeg",
            "https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_e56eb61affe5233d74c5603eb7a6218338668fa46b58788ba0814bba7c4fe1d1.jpeg"
       ],
  "datePublished": "2020-10-13T00:01:40+00:00",
  "dateModified": "2020-10-13T00:01:57+00:00",
  "author": {
    "@type": "Person",
    "name": "JD Flynn/CNA"
  },
   "publisher": {
    "@type": "Organization",
    "name": "National Catholic Register",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.ncregister.com/public/img/ncregister-logo.png"
    }
  },
  "description": "Fr. Clark and two women were arrested Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations atop the altar, which was illuminated by stage lights."
}
</script>
</head>

<body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KB6S87"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  <div id="fb-root"></div>

    <div id='NCR_EN_Header_Banner' class="centerAd marginY30">
    <script>
      googletag.cmd.push(function () { googletag.display('NCR_EN_Header_Banner'); });
    </script>
  </div>
  
  <div class="topBar">
    <div class="container">
      <div class="row">

                <div class="topBar__links col-xs-12 hidden-xs">
          <span class="topBar__toggle">A Service of EWTN News, Inc.</span>
          <div class="topBar__items">
            <div class="topBar__logoWrap">
              <a href="https://www.ewtnnews.com?utm_source=NCR%20Header%20Link" class="topBar__logo" target="_blank"><img src="/public/img/ewtn.svg"></a>
              <p>EWTN News, Inc. is the world’s largest Catholic news organization, comprised of television, radio,
                print and digital media outlets, dedicated to reporting the truth in light of the Gospel and the
                Catholic Church.</p>
            </div>
            <div class="topBar__links">
              <ul>
                <li>Newspaper</li>
                <li><a href="https://www.ncregister.com/">National Catholic Register</a></li>
              </ul>
              <ul>
                <li>News Agencies</li>
                <li><a href="http://www.catholicnewsagency.com/" target="_BLANK">Catholic News Agency</a></li>
                <li><a href="https://de.catholicnewsagency.com/" target="_BLANK">CNA Deutsch</a></li>
                <li><a href="https://www.aciafrica.org/" target="_BLANK">ACI Africa</a></li>
                <li><a href="https://www.aciafrique.org/" target="_BLANK">ACI Afrique</a></li>
                <li><a href="https://www.acidigital.com/" target="_BLANK">ACI Digital</a></li>
                <li><a href="https://www.aciprensa.com/" target="_BLANK">ACI Prensa</a></li>
                <li><a href="https://www.acistampa.com/" target="_BLANK">ACI Stampa</a></li>
              </ul>
              <ul>
                <li>Digital Media</li>
                <li><a href="https://churchpop.com/" target="_BLANK">ChurchPOP</a></li>
                <li><a href="https://es.churchpop.com/" target="_BLANK">ChurchPOP Español</a></li>
                <li><a href="https://it.churchpop.com/" target="_BLANK">ChurchPOP Italiano</a></li>
                <li><a href="https://pt.churchpop.com/" target="_BLANK">ChurchPOP Português</a></li>
              </ul>
              <ul>
                <li>TV & Radio</li>
                <li><a href="https://www.ewtn.com/tv/shows/ewtn-news-nightly" target="_BLANK">EWTN News Nightly</a></li>
                <li><a href="https://www.ewtnnoticias.com/" target="_BLANK">EWTN Noticias</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/ewtn-pro-life-weekly" target="_BLANK">EWTN Pro-life
                    Weekly</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/vaticano" target="_BLANK">Vaticano</a></li>
                <li><a href="https://www.ewtn.com/tv/shows/world-over" target="_BLANK">World Over</a></li>
              </ul>
            </div>
            <span class="topBar__close">x</span>
          </div>
        </div>
        
      </div>
    </div>
  </div>

    <div class="container header__inner">
    <div class="nav__btns header__innerBtns">
      <button class="nav__btn nav__btn--sbcr">Subscribe</button>
      <a class="nav__btn nav__btn--color" href="https://sd.ewtn.com/support-the-register/?source=supportbutton&__hstc=198926896.d85a128133620ac7ff7e851cec25f2f4.1583330347856.1589813305651.1589973817849.36&__hssc=198926896.1.1589973817849&__hsfp=1140930536" target="_blank">Support the register</a>
    </div>
    <div class="header__innerNews hidden-xs">
      <div class="header__breakingNews">
    <p class="header_breakingNews--text"><a href="/subscription/free-trial?KEY=920FREE">Get 6 Free Issues!</a></p>
</div>
    </div>
  </div>

  <header class="header header--sticky nav--sticky">
    <div class="container">
      <div class="header__wrap row">
        <div class="nav nav__itemsInner">
          <div class="nav__items">
            <div class="nav__item nav__item--menu">
            </div>
            <div class="nav__item nav__item--search">
              <img src="/bundles/_themes/swp/default-theme@hy9j1k/img/search.svg">
            </div>
            <div class="nav__search">
              <button class="nav__search__close">x</button>
              <form name="filter" method="get" action="/search">
                <input type="search" placeholder="Search" name="q">
                <button type="submit">Search</button>
              </form>
            </div>
          </div>
          <h1 class="header__logo">
            <a href="https://www.ncregister.com/"><img src="/public/img/ncregister-logo.svg"></a>
            <span>National Catholic Register News</span>
          </h1>
        </div>

        <div class="nav nav--inner">
                            <div id="header" class="okayNav-header">
            <nav role="navigation" id="nav-main" class="okayNav" style="flex: 1;">
                <ul>
                
                <li class="first">        <a href="/topic/coronavirus">Coronavirus</a>            
    </li>

    
                <li>        <a href="/topic/pope-francis">Pope Francis</a>            
    </li>

    
                <li>        <a href="/topic/elections2020">U.S. Elections 2020</a>            
    </li>

    
                <li>        <a href="/section/blogs">Blogs</a>            
    </li>

    
                <li>        <a href="/section/world">World</a>            
    </li>

    
                <li>        <a href="/section/vatican">Vatican</a>            
    </li>

    
                <li>        <a href="/section/features">Features</a>            
    </li>

    
                <li>        <a href="/section/movies">Movies</a>            
    </li>

    
                <li>        <a href="/tag/saints">Saints</a>            
    </li>

    
                <li>        <a href="/section/register-radio">Register Radio</a>            
    </li>

    
                <li class="last">        <a href="/section/jobs">Job Board</a>            
    </li>


                </ul>
            </nav>
        </div><!-- /header -->
    
        </div>

      </div>
    </div>
    <div class="nav__dropdown">
  <div class="nav__dropdown__img">
    <div class="nav__dropdown__cover">
      <a href="https://www.ncregister.com/subscription/options"><img class="lazyloaded" src="../theme_logo/76/90/9b0ef0701d385783f396d092327a.jpeg" alt="Print issue"></a>
    </div>
    <a href="https://www.ncregister.com/subscription/options"><span>Subscribe</span> to our Print Edition</a>
  </div>
                  <div>
            <ul>
                                    
                            <li class="first">        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first last">        <a href="/">Home</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li>        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/section/news">News</a>            
    </li>


                                
                <li class="item2">        <a href="/section/blogs">Blogs</a>            
    </li>


                                
                <li class="item3">        <a href="/section/commentaries">Commentaries</a>            
    </li>


                                
                <li class="item4">        <a href="/section/features">Features</a>            
    </li>


                                
                <li class="item5">        <a href="/section/interviews">Interviews</a>            
    </li>


                                
                <li class="item6">        <a href="/section/audio">Audio</a>            
    </li>


                                
                <li class="item7">        <a href="/section/video">Video</a>            
    </li>


                                
                <li class="item8">        <a href="/section/cartoons">Cartoons</a>            
    </li>


                                
                <li class="item9 last">        <a href="/section/galleries">Galleries</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li>        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/trending">Most Popular</a>            
    </li>


                                
                <li class="item2">        <a href="/topic/elections2020">U.S. Elections 2020</a>            
    </li>


                                
                <li class="item3">        <a href="/topic/coronavirus">Coronavirus</a>            
    </li>


                                
                <li class="item4">        <a href="/section/college-guide">College Guide</a>            
    </li>


                                
                <li class="item5 last">        <a href="/section/register-radio">Register Radio</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li>        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/section/nation">Nation</a>            
    </li>


                                
                <li class="item2">        <a href="/section/world">World</a>            
    </li>


                                
                <li class="item3">        <a href="/section/vatican">Vatican</a>            
    </li>


                                
                <li class="item4">        <a href="/section/education">Education</a>            
    </li>


                                
                <li class="item5">        <a href="/section/culture-of-life">Culture of Life</a>            
    </li>


                                
                <li class="item6">        <a href="/section/movies">Movies</a>            
    </li>


                                
                <li class="item7">        <a href="/section/arts-entertainment">Arts &amp; Entertainment</a>            
    </li>


                                
                <li class="item8">        <a href="/section/travel">Travel</a>            
    </li>


                                
                <li class="item9">        <a href="/tag/saints">Saints</a>            
    </li>


                                
                <li class="item10">        <a href="/tag/liturgy">Liturgy</a>            
    </li>


                                
                <li class="item11">        <a href="/section/books">Books</a>            
    </li>


                                
                <li class="item12">        <a href="/section/editorial">Editorials</a>            
    </li>


                                
                <li class="item13">        <a href="/section/publishers-note">Publisher&#039;s Note</a>            
    </li>


                                
                <li class="item14 last">        <a href="/section/letter">Letters to the Editor</a>            
    </li>



            </ul>
        </div>
    
    </li>


                    
                            <li class="last">        <a href="#">--</a>                        <div>
            <ul>
                                                
                <li class="item1 first">        <a href="/info/contacts">Contact Us</a>            
    </li>


                                
                <li class="item2">        <a href="https://sd.ewtn.com/support-the-register/?source=supportbutton&amp;__hstc=144805675.0e3c00bbb75b80b016dbdf5451a501e2.1593690492614.1594303257779.1594367786010.20&amp;__hssc=144805675.5.1594367786010&amp;__hsfp=3480365011">Support the Register</a>            
    </li>


                                
                <li class="item3">        <a href="/subscription/options">Print subscriptions</a>            
    </li>


                                
                <li class="item4">        <a href="/subscription/e-newsletter">E-Newsletter Sign-up</a>            
    </li>


                                
                <li class="item5">        <a href="/info/about-us">About Us</a>            
    </li>


                                
                <li class="item6">        <a href="/section/jobs">Job Board</a>            
    </li>


                                
                <li class="item7">        <a href="https://ewtnadvertising.com/">Advertise</a>            
    </li>


                                
                <li class="item8 last">        <a href="https://www.ewtnreligiouscatalogue.com/">EWTN Religious Catalogue</a>            
    </li>



            </ul>
        </div>
    
    </li>



            </ul>
        </div>
    
</div>
  </header>
  
  
<main class="container marginTop30">
  <div class="row">
    <div class="article--left col-md-2 col-sm-12 col-xs-12">
      <!-- AddToAny BEGIN -->
<div class="a2a_kit a2a_kit_size_32 a2a_default_style marginBottom10" data-a2a-icon-color="#fff,#333">
<a class="a2a_button_email"></a>
<a class="a2a_button_twitter"></a>
<a class="a2a_button_facebook"></a>
<a class="a2a_button_print"></a>
<a class="a2a_dd" href="https://www.addtoany.com/share"></a>
</div>
<script async src="https://static.addtoany.com/menu/page.js"></script>
<!-- AddToAny END -->

            <div id='NCR_EN_Article_Left_A' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_A'); });
        </script>
      </div>

      <div id='NCR_EN_Article_Left_B' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_B'); });
        </script>
      </div>

      <div id='NCR_EN_Article_Left_C' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_C'); });
        </script>
      </div>

      <div id='NCR_EN_Article_Left_D' class="marginBottom30">
        <script>
          googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Left_D'); });
        </script>
      </div>
    </div><!-- article--left -->

    <div class="article col-md-8 col-sm-12 col-xs-12">
      <article data-io-article-url="https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge?utm_campaign=Feed%3A%20NCRegisterDailyBlog%20National%20Catholic%20Register&amp;utm_medium=feed&amp;utm_source=feedburner" >

                
        
        <!-- /1319756/NCR_EN_Article_Top -->
        <div id='NCR_EN_Article_Top'>
          <script>
            googletag.cmd.push(function () { googletag.display('NCR_EN_Article_Top'); });
          </script>
        </div>

                <h1 class="article__headline"> After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge</h1>

        
                        <div class="article__lead">
          <p>Fr. Clark and two women were arrested Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations atop the altar, which was illuminated by stage lights.</p>
        </div>
        
               
        
                                        
                                                          
  
        <figure class="article__featured">
         <picture>
           <source media="(max-width: 680px)" srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_adccb8ac00d96d02144209c55f26a71dd8d07471430aee758150ba2d35bc71cd.webp" type="image/webp">                 
           <source media="(max-width: 680px)" srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_adccb8ac00d96d02144209c55f26a71dd8d07471430aee758150ba2d35bc71cd.jpeg" type="image/jpeg">
           <source media="(min-width: 681px)" srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_ef89c6d3dc14edd8f3a2a6fc2868f94c16d51f3a8f1ac192186af86ff95c00e9.webp" type="image/webp">           <source media="(min-width: 681px)" srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_ef89c6d3dc14edd8f3a2a6fc2868f94c16d51f3a8f1ac192186af86ff95c00e9.jpeg" type="image/jpeg">
           <img src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101302100_ef89c6d3dc14edd8f3a2a6fc2868f94c16d51f3a8f1ac192186af86ff95c00e9.jpeg" alt="Fr. Travis Clark after his Sept. 30 arrest." title="Fr. Travis Clark after his Sept. 30 arrest. ">
         </picture>
        <figcaption>Fr. Travis Clark after his Sept. 30 arrest. (photo: Courtesy photo / St. Tammany Parish Sheriff&#039;s Office.)</figcaption>
      </figure>
  
                <div class="articleMetadata marginTop30">
                              <span class="articleMetadata__byline">JD Flynn/CNA</span>
          
                                                                                             
          
          <span class="articleMetadata__section"><a href="/section/nation">Nation</a></span>

          <time class="articleMetadata__info" datetime="2020-10-13T00:01:40+00:00">October 13, 2020</time>
                  </div>
                        
                        
        
                        <div class="article__text">
          
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
                              <p>NEW ORLEANS, La. — Archbishop Gregory Aymond on Saturday consecrated a new altar at the Louisiana parish where a priest reportedly filmed a pornographic video atop the parish altar with two women last month. Details have emerged about the priest, who is expected to face criminal and canonical charges after the episode.</p>

                                                                                          <p>Those who know the priest say he kept to himself, while a seminary professor said Fr. Clark was a poor student who made little effort, which should have been a red flag.</p>

                                                            <p>“The desecration of this church and altar is demonic, demonic,” Archbishop Aymond said at Sts Peter and Paul Church in Pearl River, Louisiana Oct. 10, during a Mass at which he also reconsecrated the parish church.</p>

                                                                                          <p>“Let me be clear, there is no excuse for what took place here. It is sinful, and it is totally unacceptable. Travis has been unfaithful to his vocation; he’s violated his commitment to celibacy; and also, he was using that which was holy to do demonic things,” Archbishop Aymond said, according to the <i>Clarion Herald</i>.</p>

                                                                                          <p>“He will not be able to serve in priestly ministry, and he will not be able to serve as a priest anytime in the future,” Archbishop Aymond emphasized, while urging the parish to “continue to focus on the Lord Jesus and his mission and ministry here.”</p>

                                                            <p>The altar upon which Fr. Clark and two women engaged in filmed sexual congress was destroyed and burned at Archbishop Aymond’s order, which came as soon he learned on Oct. 8 the details of Clark’s activity in the parish Church, a spokesperson told CNA.</p>

                                                                                          <div class="inBodyAd marginBottom30">
            <div id='NCR_EN_Article_A'>
              <script>
                googletag.cmd.push(function () { googletag.display('NCR_EN_Article_A'); });
              </script>
            </div>
          </div>
                                                  <p>Fr. Clark and two women were <a href="https://www.ncregister.com/news/new-orleans-priest-defiles-altar-with-pornographic-filmmaking-arrested-for-obscenity">arrested</a> Sept. 30 and charged with obscenity after a neighbor observed through a window that they were filming sexual relations atop the altar, which was illuminated by stage lights. The priest was removed from ministry by the archbishop on Oct. 1.</p>

                                                            <p>One of the women with whom Fr. Clark made the pornographic film refers to herself as a “Satanatrix,” and the “proprietress of the Church of Satanatrix,” who posted on social media Sept. 29 that she would be traveling with another woman to “defile a house of God.”</p>

                                                                                          <p>The women’s attorney said in a statement this week that it is “appalling” that his clients are “being vilified” and facing charges for conduct he said was not illegal, because the church in which the filming took place was on private property. But police said the church’s altar was visible from the street, apparently through the glass doors of the parish entrance.</p>

                                                                                          <p>Archbishop Aymond celebrated Mass at the parish Oct. 3, last weekend, after Fr. Clark was arrested. The archbishop celebrated Mass on the desecrated altar, an archdiocesan spokesperson told CNA, “because we were not aware of what had happened in the church.”</p>

                                                            <p>“As soon as the archbishop learned of the details, arrangements were made for the altar to be removed and a new one consecrated and the church reconsecrated,” the spokesperson added.</p>

                                                                                          <p>The archdiocese said that “there was no desecrating of the Blessed Sacrament,” during the sexual episode, and that “we are not aware of any other sacred vessels being desecrated at this time.”</p>

                                                            <p>Fr. Clark was ordained a priest in 2013 and became pastor of St. Peter and Paul last year. The archdiocese told CNA that the priest had “never before been the subject of any sexual misconduct claims.”</p>

                                                                                          <p>When he was ordained a deacon in 2012, Fr. Clark told the <i>Clarion Herald</i> that among his role models was <a href="https://www.catholicnewsagency.com/news/lawyer-says-new-orleans-priest-groomed-teens-by-text-archdiocese-doubles-down-on-defense-14265">Fr. Patrick Wattigny</a>, a high school chaplain who admitted this month that in 2013 he sexually abused a minor, and who is accused of sending “grooming” text messages to a high school student earlier this year.&nbsp;</p>

                                                                                          <div class="inBodyAd marginBottom30">
            <div id='NCR_EN_Article_B'>
              <script>
                googletag.cmd.push(function () { googletag.display('NCR_EN_Article_B'); });
              </script>
            </div>
          </div>
                                                  <p>Priests in the Archdiocese of New Orleans told CNA that Fr. Clark is a quiet guy with a reputation among the presbyterate for keeping to himself. Priests in the archdiocese said that Fr. Clark’s nickname in the seminary was Lurch, in reference to the gloomy, shambling butler on television’s The Addams Family.</p>

                                                                                          <p>Some priests said that Fr. Clark is regarded as kind, attentive to the Serra Club and other projects, but was known by some to have a compulsive video game habit, sometimes staying up all night to play games.</p>

                                                            <p>Priests also told CNA that they are praying for Fr. Clark and his parish. Some speculated that the priest might have gotten involved with the women through a pornography addiction, and failed to appreciate the escalating circumstances until it was too late, especially regarding the demonic aspect of the pornographic performance he filmed.</p>

                                                                                          <p>Still, one priest said that while many in the presbyterate are surprised by Fr. Clark's action, the priest has no excuse for his choices.</p>

                                                            <p>Chistopher Baglow, a theologian who taught Fr. Clark in seminary, told CNA that he believes Fr. Clark’s misdeeds point to a problem with seminary evaluation.</p>

                                                            <p>In the seminary, nothing about Fr. Clark’s behavior suggested that the priest would later do the things he is accused of, Baglow said. But he did recall concerns about the seminarian.</p>

                                                                                          <p>The theologian remembered Clark for being a student who didn’t participate in class, was negligent of assignments and seemed often “to be flying under the radar.”</p>

                                                            <p>“It was clear he wasn’t trying, and some made it known,” Baglow said. “It was often countered that pastoral gifts and holiness do not require great theological genius, and the concern was expressed by some colleagues that we should avoid focusing too much on academics.”</p>

                                                                                          <div class="inBodyAd marginBottom30">
            <div id='NCR_EN_Article_C'>
              <script>
                googletag.cmd.push(function () { googletag.display('NCR_EN_Article_C'); });
              </script>
            </div>
          </div>
                                                  <p>But Baglow said his concern about Fr. Clark, or other students who gave evidence of not trying, was not about academics, but about character.</p>

                                                            <p>Baglow said he does not expect academic excellence from all students. But he does believe seminaries should expect effort, and evidence of virtue in students and seminary life.</p>

                                                                                          <p>“Tolerating mediocrity in a man allows tolerance for other kinds of unacceptable things.”</p>

                                                            <p>“Mediocrity can be a cover for other problems — sometimes very serious problems,” Baglow said.</p>

                                                            <p>Condoning “mediocrity” in the evaluation of seminarians, the theologian said, lowers the Church’s standards in the caliber of men who become priests. The Church should accept men for priesthood who want to be excellent academically, spiritually, pastorally, and morally, Baglow told CNA.</p>

                                                                                          <p>The theologian told CNA that in his view “the system isn’t broken, it’s just missing a part.”</p>

                                                            <p>He urged that seminaries develop committees of “well-formed knowledgeable Catholic lay people who are part of vocation evaluation and discernment.”</p>

                                                            <p>Such committees would give recommendations about the suitability of candidates for orders independent of seminary staff or faculty, Baglow said, giving bishops the benefit of perspective and judgment outside the clerical and ecclesiastical milieu.</p>

                                                                                          <p>CNA asked the Archdiocese of New Orleans what canonical penalties Fr. Clark could face, and whether he will face the prospect of penal or administrative laicization.</p>

                                                            <p>“It is Archbishop Aymond’s intention that Travis Clark never again practice priestly ministry. He is in conversations with canon lawyers about the appropriate actions to take moving forward,” the archdiocesan spokesperson said.</p>
                                                                                        </div>
                
                                                      <ul class="article__keywords">
            <li>Keywords: </li>
              
                <li><a href="https://www.ncregister.com/tag/priest-defiles-altar">priest defiles altar</a></li>
                                  
                <li><a href="https://www.ncregister.com/tag/new-orleans">new orleans</a></li>
                                  
                <li><a href="https://www.ncregister.com/tag/archbishop-gregory-aymond">archbishop gregory aymond</a></li>
              
          </ul>
                                    
        <!-- /1319756/NCR_EN_Slider -->

        <div id='NCR_EN_Slider'>
          <script>
            googletag.cmd.push(function() { googletag.display('NCR_EN_Slider'); });
          </script>
        </div>

        
<button class="article__commBtnHide" style="display:none;">Toggle Comments</button>
<div id="coral_thread" class="article__comms">
  <button class="article__commBtn marginBottom10">Show Comments <span class="coral-count article__commsCount" data-coral-url="https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge" data-coral-notext="true"></span></button>
</div>


<script type="text/javascript">
  $("#coral_thread button").on("click", function() {
      var d = document, s = d.createElement('script');
      s.src = 'https://ncregister.coral.coralproject.net/assets/js/embed.js';
      s.async = false;
      s.defer = true;
      s.onload = function() {
          Coral.createStreamEmbed({
              id: "coral_thread",
              autoRender: true,
              rootURL: 'https://ncregister.coral.coralproject.net/',
              // Uncomment these lines and replace with the ID of the
              // story's ID and URL from your CMS to provide the
              // tightest integration. Refer to our documentation at
              // https://docs.coralproject.net for all the configuration
              // options.
                        });
      };
      (d.head || d.body).appendChild(s);

      $(".article__commBtnHide").css('display','block');
  });

  $(".article__commBtnHide").on("click", function() {
     $("#coral_thread iframe").toggleClass("hide");
  });
</script>
                
      </article>

            <div class="row marginTop30">

        <div class="col-md-8 col-sm-12 col-xs-12">
          <div id="tabs" class="tabs marginBottom30">
            <ul class="tabs__items">
              <li class="tabs__item"><a href="#tab1" class="tabs__item--active">Related Stories</a></li>
              <li class="tabs__item"><a href="#tab2">Latest News</a></li>
              <li class="tabs__item"><a href="#tab3">Blogs</a></li>
            </ul>

            <div class="tabs__content row">

              <div id="#tab1" class="tab__content tab__content--active">
                <div class="articleGrid articleGrid--twoColumns">
                                                      
        
    <article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--news">
        <a href="https://www.ncregister.com/news/international-appeal-launched-to-promote-st-john-paul-ii-s-teaching">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223108_36e3d15f18c2673f5885a471147764cc552a6b251ff943e01aaef898ff394f6e.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223108_36e3d15f18c2673f5885a471147764cc552a6b251ff943e01aaef898ff394f6e.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223108_36e3d15f18c2673f5885a471147764cc552a6b251ff943e01aaef898ff394f6e.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223108_36e3d15f18c2673f5885a471147764cc552a6b251ff943e01aaef898ff394f6e.jpeg" alt="Pope John Paul II celebrates the Feast Day of the Immaculate Conception near the Spanish steps in Rome, on December 08, 2004." title="Pope John Paul II celebrates the Feast Day of the Immaculate Conception near the Spanish steps in Rome, on December 08, 2004. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/news/international-appeal-launched-to-promote-st-john-paul-ii-s-teaching">International Appeal Launched to Promote St. John Paul II’s Teaching</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>St. John Paul II, who served as pope for 26 years until 2005, was a prolific writer of poems, plays, and theological and philosophical works.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Catholic News Agency</span>
            
                                                                                                               
            
            <a href="/section/world">World</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/news/international-appeal-launched-to-promote-st-john-paul-ii-s-teaching#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/news/international-appeal-launched-to-promote-st-john-paul-ii-s-teaching" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

        
    <article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--news">
        <a href="https://www.ncregister.com/news/amy-coney-barrett-hearings-day-1-healthcare-and-anti-catholicism">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223100_06b1d7c01e7a32d8d6d0e9c20d311895b4e6b6fd2f1a9cb105d34ade086db266.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223100_06b1d7c01e7a32d8d6d0e9c20d311895b4e6b6fd2f1a9cb105d34ade086db266.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223100_06b1d7c01e7a32d8d6d0e9c20d311895b4e6b6fd2f1a9cb105d34ade086db266.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101223100_06b1d7c01e7a32d8d6d0e9c20d311895b4e6b6fd2f1a9cb105d34ade086db266.jpeg" alt="Judge Amy Coney Barrett before the Senate Judiciary Committee, Oct. 12, 2020." title="Judge Amy Coney Barrett before the Senate Judiciary Committee, Oct. 12, 2020. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/news/amy-coney-barrett-hearings-day-1-healthcare-and-anti-catholicism">Amy Coney Barrett Hearings Day 1: Healthcare and Anti-Catholicism</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Barrett, in her opening remarks, said that she believed “Americans of all backgrounds deserve an independent court that interprets our Constitution and laws as they are written.”</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Matt Hadro/CNA</span>
            
                                                                                                               
            
            <a href="/section/nation">Nation</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/news/amy-coney-barrett-hearings-day-1-healthcare-and-anti-catholicism#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/news/amy-coney-barrett-hearings-day-1-healthcare-and-anti-catholicism" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

        
    <article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--news">
        <a href="https://www.ncregister.com/news/federal-judges-decline-to-block-new-york-worship-restrictions">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012221036_a6d7de603fd0878f8df5ebc4b5038604f5f943b369be5e456699e8b2f136a165.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012221036_a6d7de603fd0878f8df5ebc4b5038604f5f943b369be5e456699e8b2f136a165.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012221036_a6d7de603fd0878f8df5ebc4b5038604f5f943b369be5e456699e8b2f136a165.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012221036_a6d7de603fd0878f8df5ebc4b5038604f5f943b369be5e456699e8b2f136a165.jpeg" alt="Saint James Cathedral in Brooklyn." title="Saint James Cathedral in Brooklyn. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/news/federal-judges-decline-to-block-new-york-worship-restrictions">Federal Judges Decline to Block New York Worship Restrictions</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Gov. Cuomo last week threatened to close religious institutions if they did not agree to and enforce public health rules proposed by the city, once the rules were enacted.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Catholic News Agency</span>
            
                                                                                                               
            
            <a href="/section/nation">Nation</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/news/federal-judges-decline-to-block-new-york-worship-restrictions#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/news/federal-judges-decline-to-block-new-york-worship-restrictions" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

        
    <article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--news">
        <a href="https://www.ncregister.com/news/amy-coney-barrett-to-tell-senators-i-believe-i-can-serve-my-country">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191012_077a9fa58763bd5c86cbe72a9bd707556db536db5863c3a07d743fc8f0cf92b2.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191012_077a9fa58763bd5c86cbe72a9bd707556db536db5863c3a07d743fc8f0cf92b2.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191012_077a9fa58763bd5c86cbe72a9bd707556db536db5863c3a07d743fc8f0cf92b2.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191012_077a9fa58763bd5c86cbe72a9bd707556db536db5863c3a07d743fc8f0cf92b2.jpeg" alt="Judge Amy Coney Barrett before the Senate Judiciary Committee, Oct. 12, 2020." title="Judge Amy Coney Barrett before the Senate Judiciary Committee, Oct. 12, 2020. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/news/amy-coney-barrett-to-tell-senators-i-believe-i-can-serve-my-country">Amy Coney Barrett to Tell Senators: ‘I Believe I Can Serve My Country’</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>In remarks released Sunday, the judge said that she was “forever grateful” for the path blazed by the late Justice Ruth Bader Ginsburg, and that it would be the “honor of a lifetime” to serve on the Supreme Court.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Christine Rousselle/CNA</span>
            
                                                                                                               
            
            <a href="/section/nation">Nation</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/news/amy-coney-barrett-to-tell-senators-i-believe-i-can-serve-my-country#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/news/amy-coney-barrett-to-tell-senators-i-believe-i-can-serve-my-country" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

    
                </div>
              </div>

              <div id="#tab2" class="tab__content">
                <div class="articleGrid articleGrid--twoColumns">
                  


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--feature">
        <a href="https://www.ncregister.com/features/totalitarianism-s-toll-as-told-by-the-people-who-lived-it">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201013001020_9ee88b5377bc6e93fcc9d4ff67690b4aa6e1082530abd74c8ee6822cf9394570.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201013001020_9ee88b5377bc6e93fcc9d4ff67690b4aa6e1082530abd74c8ee6822cf9394570.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201013001020_9ee88b5377bc6e93fcc9d4ff67690b4aa6e1082530abd74c8ee6822cf9394570.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201013001020_9ee88b5377bc6e93fcc9d4ff67690b4aa6e1082530abd74c8ee6822cf9394570.jpeg" alt="The latest book by Rod Dreher is a timely tome for 2020." title="The latest book by Rod Dreher is a timely tome for 2020. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/features/totalitarianism-s-toll-as-told-by-the-people-who-lived-it">Totalitarianism’s Toll, as Told By the People Who Lived It</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Rod Dreher’s latest book, ‘Live Not by Lies,’ chronicles worrisome changes in U.S. politics and culture.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/joan-frawley-desmond">Joan Frawley Desmond</a></span>
            
                                                                                                               
            
            <a href="/section/books">Books</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/features/totalitarianism-s-toll-as-told-by-the-people-who-lived-it#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/features/totalitarianism-s-toll-as-told-by-the-people-who-lived-it" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--feature">
        <a href="https://www.ncregister.com/features/tv-picks-10-11-20">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201005191056_ad298a94-507b-421f-83a5-34932707e62d.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201005191056_ad298a94-507b-421f-83a5-34932707e62d.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201005191056_ad298a94-507b-421f-83a5-34932707e62d.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201005191056_ad298a94-507b-421f-83a5-34932707e62d.jpeg" alt="The last Marian apparition at Fatima took place on Oct. 13, 1917." title="The last Marian apparition at Fatima took place on Oct. 13, 1917. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/features/tv-picks-10-11-20">TV Picks 10.11.20</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Fatima is a highlight this week.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">Daniel J. Engler</span>
            
                                                                                                               
            
            <a href="/section/arts-entertainment">Arts &amp; Entertainment</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/features/tv-picks-10-11-20#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/features/tv-picks-10-11-20" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--feature">
        <a href="https://www.ncregister.com/features/home-video-picks-passes-10-11-20-pm48zaeq">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020100520108_d3c40d38b7cb40f36e5d805c9231d9837a53c9ee5a61a6eaadaa8ee7bc3b8e84.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020100520108_d3c40d38b7cb40f36e5d805c9231d9837a53c9ee5a61a6eaadaa8ee7bc3b8e84.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020100520108_d3c40d38b7cb40f36e5d805c9231d9837a53c9ee5a61a6eaadaa8ee7bc3b8e84.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020100520108_d3c40d38b7cb40f36e5d805c9231d9837a53c9ee5a61a6eaadaa8ee7bc3b8e84.jpeg" alt="‘The Pirates! Band of Misfits’ gets a thumbs-up." title="‘The Pirates! Band of Misfits’ gets a thumbs-up. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/features/home-video-picks-passes-10-11-20-pm48zaeq">Home Video Picks &amp; Passes 10.11.20</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p></p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/deacon-steven-d-greydanus">Deacon Steven D. Greydanus</a></span>
            
                                                                                                               
            
            <a href="/section/arts-entertainment">Arts &amp; Entertainment</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/features/home-video-picks-passes-10-11-20-pm48zaeq#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/features/home-video-picks-passes-10-11-20-pm48zaeq" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--commentary">
        <a href="https://www.ncregister.com/commentaries/letters-10-11-20-47o0fpx7">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020092520094_1d156a7f-52ce-4c0e-81e6-43f4a91b973c.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020092520094_1d156a7f-52ce-4c0e-81e6-43f4a91b973c.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020092520094_1d156a7f-52ce-4c0e-81e6-43f4a91b973c.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020092520094_1d156a7f-52ce-4c0e-81e6-43f4a91b973c.jpeg" alt="Letters to the editor offer a variety of opinions." title="Letters to the editor offer a variety of opinions. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/commentaries/letters-10-11-20-47o0fpx7">Letters 10.11.20</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p></p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline">The Editors</span>
            
                                                                                                               
            
            <a href="/section/letter">Letter to the Editor</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/commentaries/letters-10-11-20-47o0fpx7#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/commentaries/letters-10-11-20-47o0fpx7" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

                </div>
              </div>

              <div id="#tab3" class="tab__content">
                <div class="articleGrid articleGrid--twoColumns">
                  
<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/urgent-times-call-for-global-children-s-eucharistic-rosary-from-ewtn">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012201016_74adba2bb4b3d2cbda35d7c6a4635dfd6927f5764a722edb9eda710752da5a07.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012201016_74adba2bb4b3d2cbda35d7c6a4635dfd6927f5764a722edb9eda710752da5a07.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012201016_74adba2bb4b3d2cbda35d7c6a4635dfd6927f5764a722edb9eda710752da5a07.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012201016_74adba2bb4b3d2cbda35d7c6a4635dfd6927f5764a722edb9eda710752da5a07.jpeg" alt="" title=" ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/urgent-times-call-for-global-children-s-eucharistic-rosary-from-ewtn">Urgent Times Call for Global Children’s Eucharistic Rosary from EWTN</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Children, Parents and Teachers: Join the Global Children’s Eucharistic Holy Hour Our Lady of the Angels Chapel in Irondale on Tuesday, Oct. 13.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/joseph-pronechen">Joseph Pronechen</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/urgent-times-call-for-global-children-s-eucharistic-rosary-from-ewtn#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/urgent-times-call-for-global-children-s-eucharistic-rosary-from-ewtn" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/pope-francis-receives-cardinal-george-pell-in-private-audience">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191024_dc1b8d1c72035a9b872680f8bfa136625a6a7e53abca32de228661b0f781b7f0.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191024_dc1b8d1c72035a9b872680f8bfa136625a6a7e53abca32de228661b0f781b7f0.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191024_dc1b8d1c72035a9b872680f8bfa136625a6a7e53abca32de228661b0f781b7f0.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012191024_dc1b8d1c72035a9b872680f8bfa136625a6a7e53abca32de228661b0f781b7f0.jpeg" alt="Cardinal George Pell returns to his residence in Rome, Sept. 30, 2020." title="Cardinal George Pell returns to his residence in Rome, Sept. 30, 2020. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/pope-francis-receives-cardinal-george-pell-in-private-audience">Pope Francis Receives Cardinal George Pell in Private Audience</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Cardinal Pell, who was prefect of the Secretariat for the Economy from 2014 to 2019, returned to Rome on Sept. 30.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/edward-pentin">Edward Pentin</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/pope-francis-receives-cardinal-george-pell-in-private-audience#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/pope-francis-receives-cardinal-george-pell-in-private-audience" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/warships-and-verities">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012151036_93f2bab5c33422f0512cf16579c0497b43b6f804ca86b256ccb601b18af247a4.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012151036_93f2bab5c33422f0512cf16579c0497b43b6f804ca86b256ccb601b18af247a4.jpeg" type="image/jpeg">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012151036_93f2bab5c33422f0512cf16579c0497b43b6f804ca86b256ccb601b18af247a4.jpeg" type="image/jpeg">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/20201012151036_93f2bab5c33422f0512cf16579c0497b43b6f804ca86b256ccb601b18af247a4.jpeg" alt="The Chaplain of the Fleet (L) and the Archbishop of Canterbury, William Temple (R) process with a crucifer for an Anglican service on the quarterdeck of HMS King George V at Scapa Flow, in the Orkney Islands, Scotland, during World War II. After the war, both institutions would undergo a steep decline in prestige and power, with the Royal Navy dropping from more than 2,000 ships to fewer than 80 operational commissioned ships in 2020, and Anglican churchgoing currently hovering around 1% of the U.K. population." title="The Chaplain of the Fleet (L) and the Archbishop of Canterbury, William Temple (R) process with a crucifer for an Anglican service on the quarterdeck of HMS King George V at Scapa Flow, in the Orkney Islands, Scotland, during World War II. After the war, both institutions would undergo a steep decline in prestige and power, with the Royal Navy dropping from more than 2,000 ships to fewer than 80 operational commissioned ships in 2020, and Anglican churchgoing currently hovering around 1% of the U.K. population. ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/warships-and-verities">Warships and Verities</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>Thank God for the voice of the Catholic Church, then as now affirming truth and speaking with sanity.</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/joanna-bogle">Joanna Bogle</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/warships-and-verities#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/warships-and-verities" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>


<article class="col-md-6 col-sm-6 col-xs-12">

                  
  
  
    
                    
                                                                                                   
        
                                                                                            
  
    
      <figure class=" icon icon--blog">
        <a href="https://www.ncregister.com/blog/an-incredible-resurgence-of-faith-in-milwaukee-is-catholicism-failing-in-the-philippines-and-more">
        <picture>
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101215104_6828c3d7f7408b646a19c04ff6d301f43a4e1a905eb0b86f9a15424322a4656b.webp" type="image/webp">                 
            <source media="(max-width: 680px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101215104_6828c3d7f7408b646a19c04ff6d301f43a4e1a905eb0b86f9a15424322a4656b.png" type="image/png">
                        <source media="(min-width: 681px)" data-srcset="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101215104_6828c3d7f7408b646a19c04ff6d301f43a4e1a905eb0b86f9a15424322a4656b.png" type="image/png">
            <img class="lazyload" data-src="https://publisher-publish.s3.eu-central-1.amazonaws.com/pb-ncregister/swp/hv9hms/media/2020101215104_6828c3d7f7408b646a19c04ff6d301f43a4e1a905eb0b86f9a15424322a4656b.png" alt="Screenshot of Incredible Resurgence of Catholicism in Milwaukee" title="Screenshot of Incredible Resurgence of Catholicism in Milwaukee ">
        </picture>
        </a>
      </figure>

                

          <h3 class="articleGrid__headline"><a href="https://www.ncregister.com/blog/an-incredible-resurgence-of-faith-in-milwaukee-is-catholicism-failing-in-the-philippines-and-more">An Incredible Resurgence Of Faith In Milwaukee, Is Catholicism Failing In The Philippines, And More!</a></h3>
     

    
        <div class="mainArticle__teaser">
      <p>The Best In Catholic Blogging</p>
    </div>
    
                  <div class="articleMetadata">
                                    <span class="articleMetadata__byline"><a href="https://www.ncregister.com/author/tito-edwards">Tito Edwards</a></span>
            
                                                                                                               
            
            <a href="/section/blogs">Blogs</a>
            
                                      
            <a class="articleMetadata__comments articleMetadata__info" href="https://www.ncregister.com/blog/an-incredible-resurgence-of-faith-in-milwaukee-is-catholicism-failing-in-the-philippines-and-more#coral_thread">
              <span class="coral-count" data-coral-url="https://www.ncregister.com/blog/an-incredible-resurgence-of-faith-in-milwaukee-is-catholicism-failing-in-the-philippines-and-more" data-coral-notext="true"></span>
            </a>

                    </div>
    
    
  
</article>

                </div>
              </div>

            </div>
          </div>

          <script>

            var tabItems = document.getElementsByClassName('tabs__items')[0].getElementsByTagName('a');
            var tabContent = document.getElementById('tabs').getElementsByClassName('tab__content');

            for (var i = 0; i < tabItems.length; i++) {
              tabItems[i].addEventListener('click', activateTab, false);
            }


            function activateTab(event) {
              for (var e = 0; e < tabItems.length; e++) {
                tabItems[e].classList.remove("tabs__item--active");
                if (tabContent[e] != null) {
                  tabContent[e].classList.remove("tab__content--active");
                }
              }
              this.classList.add("tabs__item--active");
              document.getElementById(this.getAttribute("href")).classList.add("tab__content--active");
              event.preventDefault();
            }

          </script>
        </div>

        <div class="col-md-4 col-sm-12 col-xs-12">
                                                                                                                                                                                                                                                                                                              
  <div class="accordion marginBottom30">
    <h3 class="sectionHeading marginTop30"><span class="sectionHeading__big">Trending</span></h3>
    <div class="accordion__section">
      <div class="accordion__sectionContent">
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/new-orleans-archbishop-priest-s-desecration-of-altar-demonic">New Orleans Archbishop: Priest’s Desecration of Altar ‘Demonic’</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/the-question-no-one-s-asking">The Question No One’s Asking</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/pope-francis-meets-with-cardinal-pell-at-the-vatican">Pope Francis Meets with Cardinal Pell at the Vatican</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/features/the-wanderer-sings-the-blues">The Wanderer Sings the Blues</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/as-california-wildfires-ravage-napa-residents-see-god-s-hand-at-work-through-his-people">As California Wildfires Ravage Napa, Residents See ‘God’s Hand at Work Through His People’</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/an-incredible-resurgence-of-faith-in-milwaukee-is-catholicism-failing-in-the-philippines-and-more">An Incredible Resurgence Of Faith In Milwaukee, Is Catholicism Failing In The Philippines, And More!</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/commentaries/judge-amy-coney-barrett-s-hearings-will-display-her-intellect-personal-history-and-judicial-philosophy">Judge Amy Coney Barrett’s Hearings Will Display Her Intellect, Personal History and Judicial Philosophy</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/blog/warships-and-verities">Warships and Verities</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/amy-coney-barrett-hearings-day-1-healthcare-and-anti-catholicism">Amy Coney Barrett Hearings Day 1: Healthcare and Anti-Catholicism</a></h4>
        </article>
                <article class="accordion__sectionItem">
          <h4 class="accordion__sectionHeadline"><a href="https://www.ncregister.com/news/abortion-is-pre-eminent-human-rights-issue-florida-bishop-says-as-election-nears">Abortion is ‘Pre-Eminent’ Human Rights Issue, Florida Bishop Says as Election Nears</a></h4>
        </article>
              </div>
    </div>
  </div>
  
        </div>

      </div>
      
    </div>

    <div class="col-md-2 col-sm-12 col-xs-12">
          </div>

  </div>
</main>

<script type="text/javascript" async>
window.addEventListener('load',function(){
var xhr = new XMLHttpRequest();
var read_date = new Date();
var request_randomizer = "&" + read_date.getTime() + Math.random();
xhr.open('GET', '/_swp_analytics?articleId=99236'+request_randomizer+'&ref='+document.referrer);
xhr.send();
})
</script>


    <div id='NCR_EN_Footer_Banner' class="centerAd marginY30">
    <script>
      googletag.cmd.push(function () { googletag.display('NCR_EN_Footer_Banner'); });
    </script>
  </div>
  
  <!-- Footer -->

    <footer class="footer marginTop30">
    <div class="footer__wrap">
      <div class="footer__wrapItems">
        <a class="footer__logo" href="https://www.ncregister.com/"><img
            src="/bundles/_themes/swp/default-theme@hy9j1k/img/ncregister-logo.svg"></a>
        <ul class="footer__social">
          <li><a href="https://www.facebook.com/NCRegister" target="_BLANK"><img
                src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-fb.svg" alt="Facebook"></a></li>
          <li><a href="https://twitter.com/NCRegister" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-tw.svg"
                alt="Twitter"></a></li>
          <li><a href="https://www.instagram.com/ncregister/" target="_blank"><img
                src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-ig.svg" alt="Instagram"></a></li>
          <li><a href="https://www.youtube.com/user/NCRegister" target="_blank"><img
                src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-yt.svg" alt="Youtube"></a></li>
          <li><a href="https://www.ncregister.com/feeds/general-news.xml" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-rss.svg"
                alt="RSS"></a></li>
          <li><a href="/cdn-cgi/l/email-protection#c7a2aaa6aeab87a2bfa6aab7aba2e9a4a8aa" target="_blank"><img src="/bundles/_themes/swp/default-theme@hy9j1k/img/social-email.svg"
                alt="Email"></a></li>
        </ul>
      </div>
    </div>
    
        <div class="container">
                        <div>
        <ul class="footer__items ">
                            
                            <li class="first">        <a href="#">Social media</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="https://www.facebook.com/NCRegister">Facebook</a>            
    </li>

    
                <li>        <a href="https://twitter.com/NCRegister">Twitter</a>            
    </li>

    
                <li>        <a href="https://www.instagram.com/ncregister/">Instagram</a>            
    </li>

    
                <li class="last">        <a href="https://www.youtube.com/user/NCRegister">Youtube</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li>        <a href="#">Tools &amp; Features</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="/subscription/e-newsletter">E-Newsletters</a>            
    </li>

    
                <li>        <a href="/info/rss-feeds">RSS Feeds</a>            
    </li>

    
                <li>        <a href="#">Register News Widget</a>            
    </li>

    
                <li>        <a href="https://soundcloud.com/ewtn-radio">Register Radio Podcast</a>            
    </li>

    
                <li class="last">        <a href="/section/college-guide">College Guide</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li>        <a href="#">Print Subscriptions</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="/subscription/subscribe?KEY=920NBT">Subscribe</a>            
    </li>

    
                <li>        <a href="/subscription/options">Manage a Subscription</a>            
    </li>

    
                <li>        <a href="/subscription/gift?KEY=920NBG">Give a Subscription</a>            
    </li>

    
                <li class="last">        <a href="/subscription/bulk-order">Order Bulk Subscriptions</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li>        <a href="#">Marketplace</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="https://ewtnadvertising.com/">Advertise</a>            
    </li>

    
                <li>        <a href="/section/jobs">Job Board</a>            
    </li>

    
                <li class="last">        <a href="https://www.ewtnreligiouscatalogue.com/">EWTN Religious Catalogue</a>            
    </li>


        </ul>
      </div>
    
    </li>

    
                            <li class="last">        <a href="#">More</a>                          <div>
        <ul class=" menu_level_1">
                            
                <li class="first">        <a href="/info/about-us">About Us</a>            
    </li>

    
                <li>        <a href="/info/contacts">Contact Us</a>            
    </li>

    
                <li>        <a href="https://sd.ewtn.com/support-the-register/?source=supportbutton&amp;__hstc=144805675.0e3c00bbb75b80b016dbdf5451a501e2.1593690492614.1594029723284.1594036196954.9&amp;__hssc=144805675.12.1594036196954&amp;__hsfp=3480365011">Support Us</a>            
    </li>

    
                <li>        <a href="/archives">Archives</a>            
    </li>

    
                <li>        <a href="/info/editorial-guidelines">Writers Guidelines</a>            
    </li>

    
                <li>        <a href="/info/editorial-guidelines">Submit Letter to Editor</a>            
    </li>

    
                <li>        <a href="/info/editorial-guidelines">Reprints and Permissions</a>            
    </li>

    
                <li class="last">        <a href="/info/ncr-privacy-policy">Privacy Policy</a>            
    </li>


        </ul>
      </div>
    
    </li>


        </ul>
      </div>
    
    </div>
    
    <div class="footer__text">
      <div class="container">
        <p>Copyright © 2020 EWTN News, Inc. All rights reserved. <br>
          Reproduction of material from this website without written permission, or unlicensed commercial use or
          monetization of National Catholic Register RSS feeds is strictly prohibited.</p>
      </div>
    </div>
  </footer>
  
  <div class="popUp">
    <div class="popUp__headlineWrap">
      <h3 class="popUp__headline">Subscription Options</h3>
      <button class="popUp__close">x</button>
    </div>
    <div class="popUp__wrap">
      <div class="popUp__img">
        <img src="/public/img/Pop_Up_visual.jpg">
      </div>
      <div class="popUp__items">
        <ul>
          <li>
            <p><span>Subscriber Service Center</span>Already a subscriber? Renew or manage your subscription <a
                href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR"
                target="_blank">here</a>.</p>
          </li>
          <li>
            <p><span>Subscribe</span>Start your Register subscription today.</p>
            <a href="https://www.ncregister.com/subscription/subscribe?KEY=920NSP" class="popUp__btn">Subscribe Now</a>
          </li>
          <li>
            <p><span>Sign up for 6 Free Issues</span>Try us out with a free trial subscription.</p>
            <a href="https://www.ncregister.com/subscription/free-trial?KEY=920MHFR" class="popUp__btn">Order Now</a>
          </li>
          <li>
            <p><span>Give a Gift Subscription</span>Bless friends, family or clergy with a gift of the Register.</p>
            <a href="https://www.ncregister.com/subscription/gift?KEY=920NGT" class="popUp__btn">Order Now</a>
          </li>
          <li>
            <p><span>Order Bulk Subscriptions</span>Get a discount on 6 or more copies sent to your parish, organization
              or school.</p>
            <a href="https://www.ncregister.com/subscription/bulk-order" class="popUp__btn">Order Now</a>
          </li>
          <li>
            <p><span>Sign-up for E-Newsletter</span>Get Register Updates sent daily or weeklyto your inbox. </p>
            <a href="https://www.ncregister.com/subscription/e-newsletter" class="popUp__btn">Sign Up</a>
          </li>
        </ul>
      </div>
    </div>
  </div>
  <div class="popUp__bck"></div>
  <div class="nav__dropdownBck"></div>

  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="/public/dist/bundle.1601369928734.js"></script>
</body>

  <script>
window._io_config = window._io_config || {};
window._io_config["0.2.0"] = window._io_config["0.2.0"] || [];
window._io_config["0.2.0"].push({
  page_url: "https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge?utm_campaign=Feed%3A%20NCRegisterDailyBlog%20National%20Catholic%20Register&amp;utm_medium=feed&amp;utm_source=feedburner",
  page_url_canonical: "https://www.ncregister.com/news/after-demonic-desecration-new-orleans-church-reconsecrated-as-details-about-priest-emerge",
  page_title: "After ‘Demonic’ Desecration, New Orleans Church Reconsecrated as Details About Priest Emerge",
  page_type: "article",
  page_language: "en",
    article_categories: ["News, Nation"],
  article_type: "news",
  article_word_count: "1132",
  article_publication_date: "Tue, 13 Oct 2020 00:01:40 +0000"
});
</script>

</html>
