  <!doctype html>
<html>
<head>
  <script type='text/javascript'>var _sf_startpt=(new Date()).getTime(); // Chartbeat</script>
  <link rel="stylesheet" href="/css/layout/global.css">
  <link rel="stylesheet" href="/css/layout/jquery.fancybox.css">
  <link href="https://fonts.googleapis.com/css?family=Merriweather:300,300i,400,400i|Roboto:300,300i,400,400i,500,500i" rel="stylesheet">
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.3/jquery.min.js"></script>
  <!-- CAN Container tag for NCRegister.com-->
<script async="1">
  (function() {
    __mtm = [ '55bbf6162cceb4ae45ce5480', 'd36wtdrdo22bqa.cloudfront.net/mngr' ];
    var s = document.createElement('script');
    s.async = 1;
    s.src = '//' + __mtm[1] + '/mtm.js';
    var e = document.getElementsByTagName('script')[0];
    (e.parentNode || document.body).insertBefore(s, e);
  })();
</script>
<!-- End CAN Container tag for NCRegister.com-->
<script type="text/javascript">
  // Ads
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();

  googletag.cmd.push(function() {
    googletag.defineSlot('/1319756/Top_Banner', [728, 90], 'header-banner-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Bottom_Banner', [728, 90], 'bottom-banner-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Middle_Banner_Home', [728, 90], 'home-middle-banner-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_Large_AdBar', [850, 50], 'fixed-bottom-banner-ad').addService(googletag.pubads());

    googletag.defineSlot('/1319756/Left_Sidebar_A', [180, 150], 'left-sidebar-a').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Left_Sidebar_B', [180, 150], 'left-sidebar-b').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Left_Sidebar_C', [180, 150], 'left-sidebar-c').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Left_Sidebar_D', [180, 150], 'left-sidebar-d').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_A', [[300, 250], [300, 169]], 'right-sidebar-a').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_B', [[300, 250], [300, 169]], 'right-sidebar-b').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_C', [[300, 250], [300, 169]], 'right-sidebar-c').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_D', [[300, 250], [300, 169]], 'right-sidebar-d').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_Article_1', [300, 250], 'embedded-ad-1').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_300x250_Fallback', [300, 250], 'NCR_300x250_Fallback').addService(googletag.pubads());

    googletag.defineSlot('/1319756/Article_Footer', [468, 60], 'article-footer-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Home_Header_Right', [125, 125], 'home-logo-right').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Interior_Header_Left', [125, 125], 'interior-logo-left').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Interior_Header_Right', [125, 125], 'interior-logo-right').addService(googletag.pubads());

    googletag.defineSlot('/1319756/NCR_EN_Search_1', [615, 80], 'search-text-1').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Search_2', [615, 80], 'search-text-2').addService(googletag.pubads());

    googletag.defineSlot('/1319756/NCR_EN_CollegeGuideLink', [150, 35], 'college-guide-link').addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs(true, true);
    if (typeof metaTags != 'undefined')
      googletag.pubads().setTargeting('Keyword', metaTags);
    googletag.enableServices();
  });

  // Facebook
  window.fbAsyncInit = function() {
    FB.init({
      appId   : '347756275321330',
      xfbml   : true,
      version : 'v2.9'
    });
  };

  (function(d, s, id){
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) {return;}
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

  // Google Analytics
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
     (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
       m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
         })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-767764-1', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

  function getCookie(cname) {
    var cs = document.cookie.split(/;\s*/),
        name = cname + '=';
    for (var i = 0; i < cs.length; i++) {
      if (cs[i].indexOf(name) == 0)
        return cs[i].substr(name.length);
    }
    return '';
  }

  function setCookie(cname, value, expDays) {
    var c = cname + '=' + value;
    if (expDays) {
      var d = new Date();
      d.setTime(d.getTime() + expDays * 24 * 60 * 60 * 1000);
      c += '; expires=' + d.toUTCString() + '; path=/';
    }
    document.cookie = c;
  }
</script>

  <link rel="stylesheet" href="/css/layout/detail.css">

  <title>Why Do Eastern Christians Make Sign of the Cross Backward, Physician-Assisted Suicide, and More!</title>
<link rel="canonical" href="http://www.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste">
<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste">
<meta property="fb:pages" content="64182915497">
<meta property="fb:app_id" content="347756275321330">
<meta property="fb:admins" content="1477213784">
<meta property="og:type" content="article">
<meta property="og:site_name" content="National Catholic Register">
<meta property="og:url" content="http://www.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste">
<meta property="og:description" content="The Best in Catholic Blogging">
<meta property="og:title" content="Why Do Eastern Christians Make Sign of the Cross Backward, Physician-Assisted Suicide, and More!">
<meta property="og:image" content="http://www.ncregister.com/images/uploads/Eastern_Orthodox_Signing_of_the_Cross_Credit_Simply_Orthodox.jpg">
<meta property="og:image:width" content="500">
<meta property="og:image:height" content="375">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@NC_Register">
<meta name="twitter:url" content="http://www.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste">
<meta name="twitter:description" content="The Best in Catholic Blogging">
<meta name="twitter:title" content="Why Do Eastern Christians Make Sign of the Cross Backward, Physician-Assisted Suicide, and More!">
<meta name="twitter:image" content="http://www.ncregister.com/images/uploads/Eastern_Orthodox_Signing_of_the_Cross_Credit_Simply_Orthodox.jpg">
<script type="text/javascript">
  var metaUrl = 'http://www.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste',
      metaPath = 'blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste',
      metaTitle = "Why Do Eastern Christians Make Sign of the Cross Backward, Physician-Assisted Suicide, and More!",
      metaTags = ['    Tito Edwards  '.trim(), '    Blogs  '.trim()];
  if ("" != '')
    [].push.apply(metaTags, "".split(', '));
</script>

</head>
<body>
  <div id="fb-root"></div>
  <div id="page-container">
    <div id="header-container">
      <div id="header-global-nav">
  <div class="header-left">
    <div class="menu">
      <a class="menu-root" data-menu-id="sections-menu" href="javascript:;" >
        <img alt="menu" src="/css/layout/images/hamburger.png"> Sections
      </a>&nbsp;
      <div id="sections-menu" data-menu-id="sections-menu" class="menu-items">
  <a href="/sections/nation" class="item">Nation</a>
  <a href="/sections/vatican" class="item">Vatican</a>
  <a href="/sections/world" class="item">World</a>
  <a href="/sections/commentary" class="item">Commentary</a>
  <a href="/sections/blog" class="item">Blogs</a>
  <a href="/sections/features" class="item">Features</a>
  <a href="/sections/movies" class="item">Movies</a>
  <a href="/sections/books" class="item">Books</a>
  <a href="/sections/travel" class="item">Travel</a>
  <a href="/sections/radio" class="item">Radio</a>
  <a href="/info/resources1" class="item">Resources</a>
  <a href="/college-guide" class="item">College Guide</a>
</div>

    </div>
    <div class="menu">
      <a href="/"><img alt="menu" src="/css/layout/images/home.png"> Home</a>&nbsp;
    </div>
    <div class="menu">
      <a id="search-menu-root" href="javascript:;"><img alt="search" src="/css/layout/images/lens.png"> Search</a>
      <div id="search-form-container">
        <form id="search-form">
          <input name="q" id="search-site" type="text" autocomplete="off" placeholder="Search NCRegister">
        </form>
      </div>
    </div>
  </div>
  <div class="header-right">
    <div class="menu">
      <a class="menu-root" data-menu-id="advertise-menu" href="http://ewtnadvertising.com" target="_blank">Advertise</a>&nbsp;
      <div id="advertise-menu" data-menu-id="advertise-menu" class="menu-items">
        <a href="http://ewtnadvertising.com/print-advertising/" target="_blank" class="item">Register Print Ads</a>
        <a href="http://ewtnadvertising.com" target="_blank" class="item">EWTN News Digital Ads</a>
        <a href="https://orders.ewtnadvertising.com/" target="_blank" class="item">Order Ads Online</a>
        <a href="http://ewtnadvertising.com/ncregister-com-job-board/" target="_blank" class="item">Post a Job ad</a>
      </div>
    </div>
    <div class="menu">
      <a class="menu-root" data-menu-id="subscriptions-menu" href="http://pubads.g.doubleclick.net/gampad/clk?id=53318596&iu=/1319756/Click_Tracker">Subscriptions</a>&nbsp;
      <div id="subscriptions-menu" data-menu-id="subscriptions-menu" class="menu-items">
        <a href="https://sfsdata.com/ncr/Subscribe.aspx?KEY=917MSP" target="_blank" class="item">Subscribe</a>
        <a href="https://sfsdata.com/NCR/GiftR.html?KEY=917GIF" target="_blank" class="item">Give a Gift Subscription</a>
        <a href="/info/bulk-subscriptions" class="item">Discounted Bulk Subscriptions</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Gift Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Payments</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Account Status</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Missed Issue</a>
        <a href="/info/opt-in-popup" class="subscribe-popup item">Daily or Weekly e-Newsletter</a>
      </div>
    </div>
    <a href="http://pubads.g.doubleclick.net/gampad/clk?id=53318476&iu=/1319756/Click_Tracker" target="_blank">Donate</a>&nbsp;
    <a href="/jobs">Jobs</a>&nbsp;
    <a href="http://www.ewtn.com/cataloguefeatured/" target="_blank">Store</a>
    <a href="http://www.catholicnewsagency.com/?utm_source=NCR%20Header%20Link" target="_blank">CNA</a>
  </div>
  <div class="header-center">
    <a href="//www.facebook.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/facebook.png"></a>
    <a href="//twitter.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/twitter.png"></a>
    <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank"><img alt="search" src="/css/layout/images/rss.png"></a>
    <a href="/info/opt-in-popup" class="subscribe-popup"><img alt="daily update" src="/css/layout/images/newsletter.png"></a>
  </div>
</div>
<div id="header-banner-ad" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('header-banner-ad'); });
  </script>
</div>

<div id="header-logo-header">
  <div id="logo-super">
    <div class="header-left divider"></div>
    <div class="header-right divider"></div>
    <div class="header-center divider-text">A Service of EWTN</div>
  </div>
  
    <div class="header-left header-ad">
      <div id="interior-logo-left" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-left'); });
  </script>
</div>

    </div>
    <div class="header-right header-ad">
      <div id="interior-logo-right" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-right'); });
  </script>
</div>

    </div>
  
  <div id="logo-header">
    
      <div id="logo" class="header-center"><a href="/"><img alt="Register Logo" src="/css/layout/images/ncregister-logo-385x115.png"></a></div>
    
  </div>
</div>


    </div>
    <div id="main-container">
      <div id="main" class="lo-row">
  <div id="main-left" class="lo-cell">
    <div id="main-left-top" class="lo-row">
      <div id="main-left-sidebar" class="lo-cell">
        
          <div>
  <div class="share-count-container">
    <div id="share-count">0</div>
    <div>Shares</div>
  </div>
  <div class="icons">
    <div class="entry">
      <a rel="nofollow" href="/site/email/55124">
        <img class="center-vertical icon" alt="Email" src="/css/layout/images/detail-email.png">
      <a>
      <div class="center-vertical caption"><a rel="nofollow" href="/site/email/55124">Email</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" href="javascript:;" class="share-fb">
        <img class="center-vertical icon" alt="Share" src="/css/layout/images/detail-facebook.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" href="javascript:;" class="share-fb">Share</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" class="share-twitter" href="javascript:;">
        <img class="center-vertical icon" alt="Tweet" src="/css/layout/images/detail-twitter.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-twitter" href="javascript:;">Tweet</a></div>
    </div>
    
      <div class="entry">
        <a class="view-comments-link" rel="nofollow" href="#article-view-comments">
          <img class="center-vertical icon" alt="Comment" src="/css/layout/images/detail-comment.png">
        </a>
        <div class="center-vertical caption"><a class="view-comments-link" rel="nofollow" href="#article-view-comments">Comment</a></div>
      </div>
    
    <div class="entry">
      <a rel="nofollow" class="share-print" href="/site/print/55124" target="_blank">
        <img class="center-vertical icon" alt="Print" src="/css/layout/images/detail-print.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-print" href="/site/print/55124" target="_blank">Print</a></div>
    </div>
  </div>
</div>
<div id="lsb-sticky-ads-marker"></div>
<div id="lsb-sticky-ads">
  <div id="left-sidebar-a" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-a'); });
  </script>
</div>

  <div id="left-sidebar-b" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-b'); });
  </script>
</div>

  <div id="left-sidebar-c" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-c'); });
  </script>
</div>

  <div id="left-sidebar-d" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-d'); });
  </script>
</div>

</div>

        
      </div>
      <div id="main-left-main" class="lo-cell">
        
            
  
  
  
  
  
  
    
    
    
  
      <div class="article-image"><img alt="Click on the Why Do Eastern Christians Make Sign of the Cross “Backward” link to read more." src="/images/uploads/Eastern_Orthodox_Signing_of_the_Cross_Credit_Simply_Orthodox.jpg"></div>
    <div class="article-image-caption">Click on the Why Do Eastern Christians Make Sign of the Cross “Backward” link to read more. </div>
    <div class="article-section">
    <a href="/sections/blog">    Blogs  </a>&nbsp;|&nbsp; Nov. 18, 2017
  </div>
  <div class="article-title">Why Do Eastern Christians Make Sign of the Cross Backward, Physician-Assisted Suicide, and More!</div>
      <div class="article-subhead">The Best in Catholic Blogging</div>
    <div class="article-author"><a href="/blog/tito-edwards">    Tito Edwards  </a></div>
    <div class="article-body"><p><a href="https://aleteia.org/2017/11/07/why-do-eastern-christians-make-the-sign-of-the-cross-backwards/"><span style="color: #800000;"><strong>Why Do Eastern Christians Make Sign of the Cross &ldquo;Backward&rdquo;</strong></span></a>&nbsp;- Valentin Fontan-Moret, Aleteia+++</p>

<p><a href="https://www.thecatholicthing.org/2017/11/14/physician-assisted-suicide-a-new-pascals-wager/"><strong><span style="color: #800000;">Physician-Assisted Suicide: A New Pascal&rsquo;s Wager</span></strong></a>&nbsp;&ndash;&nbsp;Fr. Cameron Faller &amp; Fr. Joseph Previtali, The Catholic Thing</p>

<p><a href="http://www.asianews.it/news-en/Pope-to-mark-World-Day-of-the-Poor%2C-with-lunch-for-1%2C500--42318.html"><span style="color: #800000;"><strong>Pope Francis to Mark World Day of the Poor, with Lunch for 1,500</strong></span></a>&nbsp;&ndash; Asia News</p>

<p><a href="https://www.mercatornet.com/features/view/how-technology-cheapened-sex-and-made-men-less-marriageable/20704"><span style="color: #800000;"><strong>How Technology Cheapened Sex, Made Men Less Marriageable</strong></span></a>&nbsp;&ndash; Mark Regnerus Ph.D. &amp; Tracey S. O&rsquo;Donnell, Mercatornet</p>

<p><a href="http://www.catholicstand.com/life-intelligibility-vs-death-inanity/" rel="bookmark" title="Permanent Link to Life and Intelligibility vs. Death and Inanity: Scientism and Meaning"><strong><span style="color: #800000;">Life &amp; Intelligibility vs. Death &amp; Inanity: Scientism &amp; Meaning</span></strong></a>&nbsp;&ndash; Bob Drury, Catholic Stand</p>

<p><a href="http://catholicfundraiser.net/3-steps-best-year-end-campaign-ever/"><span style="color: #800000;"><strong>3 Steps to Your Best Year-End Campaign Ever</strong></span></a>&nbsp;&ndash; Brice Sokolowski, CatholicFundraiser.net</p>

<p><a href="https://anglicanorumcoetibussociety.wordpress.com/2017/11/08/we-should-be-at-the-ecumenical-table/" rel="bookmark"><strong><span style="color: #800000;">The Anglican Ordinariate Should Be at the Ecumenical Table</span></strong></a>&nbsp;&ndash;&nbsp;Deborah Gyapong, Anglicanorum C&oelig;tibus Society Blog</p>

<p><a href="http://wdtprs.com/blog/2017/11/ask-father-marriage-licenses-with-spouse-1-and-spouse-2/"><span style="color: #800000;"><strong>Qu&aelig;ritur: Marriage Licenses with &ldquo;Spouse 1&rdquo; &amp; &ldquo;Spouse 2&rdquo;</strong></span></a>&nbsp;&ndash; Fr. Z&rsquo;s Blog</p>

<p><a href="http://www.catholicherald.co.uk/news/2017/11/06/ecumenical-mass-rumours-are-utterly-false-vatican-says/"><span style="color: #800000;"><strong>Vatican: &lsquo;Ecumenical Mass&rsquo; Rumours are &lsquo;Utterly False&rsquo;</strong></span></a>&nbsp;&ndash; Nick Hallett, Catholic Herald</p>

<p><a href="http://www.catholicworldreport.com/2017/11/08/our-children-and-the-cyber-battlefield/"><span style="color: #800000;"><strong>Our Children &amp; the Cyber-Battlefield</strong></span></a>&nbsp;&ndash; Meryl Kaleida, The Dispatch via The Catholic World Report</p>

<p><a href="http://www.catholicherald.co.uk/news/2017/11/06/pope-francis-says-he-urged-fellow-cardinals-to-back-benedict-xvi-in-2005-conclave/"><strong><span style="color: #800000;">Pope Francis Says He Urged Fellow Cardinals to Back Cardinal Ratzinger in 2005 Conclave</span></strong></a>&nbsp;&ndash; David V. Barrett, Catholic Herald</p>

<p><a href="https://aleteia.org/2017/11/05/the-secret-lives-of-6-heroes-who-risked-death-to-remain-catholic/"><span style="color: #800000;"><strong>Secret Lives of Elizabethan Heroes Who Risked Death to Remain Catholic</strong></span></a>&nbsp;&ndash; Fr. Michael&nbsp;Rennier, Aleteia</p>

<p>For the Most Recent in &#39;The Best in Catholic Blogging&#39; click on&nbsp;<strong><a href="http://bigpulpit.com/" rel="noopener" target="_blank">&#9769; Big Pulpit &#9769;</a></strong>.</p></div>
    

        
        <div id="article-footer-ad" class="ad-slot article-footer">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('article-footer-ad'); });
  </script>
</div>

        
          <script type="text/javascript">var noMoreComments;</script>
<a name="article-view-comments"></a>
<div id="comments-hidden" class="article-view-comments view-comments-link">View Comments</div>
<div id="comments-shown" class="article-comments-container">
  <div class="article-comments-header lo-row">
    <div class="heading lo-cell">Comments</div>
    <div class="join-link lo-cell"><a href="#article-join-discussion">Join the Discussion</a></div>
  </div>
  <div class="article-comments">
    
  </div>
  <a name="article-join-discussion"></a>
  <div class="article-more-comments">
    <div class="instructions-header">Join the Discussion</div>
    <div class="instructions">
      We encourage a lively and honest discussion of our content. We ask that charity guide your words.
        By submitting this form, you are agreeing to our <a href="/info/discussion-guidelines">discussion guidelines</a>.
        Comments are published at our discretion. We won't publish comments that lack charity, are off topic, or are more than 400 words.
        Thank you for keeping this forum thoughtful and respectful.
    </div>
    <form id="comment_form" method="post" action="http://www.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="http://www.ncregister.com/blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste" />
<input type="hidden" name="URI" value="blog/tito-edwards/why-do-eastern-christians-make-sign-of-the-cross-backward-physician-assiste" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="XID" value="" />
<input type="hidden" name="entry_id" value="55124" />
<input type="hidden" name="site_id" value="1" />
</div>

 
                  
      <div class="form-fields">
                  <p>Name:<br /><input class="text" type="text" name="name" value="" /></p>
          <p>Email:<br /><input class="text" type="email" name="email" value="" /></p>
                <p><input type="hidden" name="title" value="" />
          Write your comment:<br />
          <textarea name="comment" cols="" rows="10" wrap="virtual" class="input_element"></textarea>
          <input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments.
        </p>
                  <p class="captcha" >Please enter the word you see in the image below:<br />
            <input class="text" type="text" name="captcha" value="" maxlength="20" /><br />
            <img src="http://www.ncregister.com/images/captchas/1510995601.1128.jpg" width="140" height="30" style="border:0;" alt=" " /></p>
                <p>
          <input type="submit" class="button" name="submit" value="Submit" />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
          <input type="reset" class="button" name="reset" value="Clear" />
        </p>
        <input type="hidden" name="save_info" value="yes" />      </div>
    </form>
  </div>
  <div class="article-no-more-comments">
    Comments are no longer being accepted on this article.
  </div>
</div>

        
      </div>
    </div>
    <div id="main-left-bottom">
    </div>
  </div>
  <div id="main-right" class="lo-cell">
    
      <div id="right-sidebar-a" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-a'); });
  </script>
</div>

<div id="blogger-bio">
  
    <div class="name"><a href="/blog/tito-edwards">Tito Edwards</a></div>
    <div class="image"><img src="/images/sized/images/member_photos/photo_8608-85x85.png" width="85" height="85"  alt="Tito Edwards" /></div>
    <div class="text"><p>Tito Edwards manages Catholic websites for the new evangelization that Pope John Paul II and then Cardinal Ratzinger, now Pope Benedict XVI, has asked for in the third millennium.</p>

<p>After a lifetime of living a nominal Catholic life, he reverted completely to his childhood faith that began on the eve of the funeral of Pope John Paul II.</p>

<p>He publishes <a href="http://bigpulpit.com/">Big Pulpit</a>, <a href="http://CatholicStand.com/">Catholic Stand</a>, <a href="http://IgnitumToday.com/">Ignitum Today</a>, and <a href="http://the-american-catholic.com/">The American Catholic</a>.</p></div>
    <div class="clear"></div>
  
</div>

<div id="trending">
  <h1>Trending</h1>
  <div class="trending-panel">
     
      <div id="trending-entry-1" class="trending-entry lo-row">
        <div class="count lo-cell">
          1.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/edward-pentin/cardinal-burke-addresses-the-dubia-one-year-after-their-publication">Cardinal Burke Addresses the &#8216;Dubia&#8217; One Year After Their Publication</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/edward-pentin/cardinal-burke-addresses-the-dubia-one-year-after-their-publication">
                <img src="/images/sized/images/uploads/IMG_0476-85x85.jpg" width="85" height="85"  alt="Cardinal Burke Addresses the &#8216;Dubia&#8217; One Year After Their Publication" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-2" class="trending-entry lo-row">
        <div class="count lo-cell">
          2.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/ann-carey/progressive-orders-are-passing-awaythe-future-belongs-to-the-faithful">&#8216;Progressive&#8217; Orders are Passing Away&#8212;the Future Belongs to the Faithful</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/ann-carey/progressive-orders-are-passing-awaythe-future-belongs-to-the-faithful">
                <img src="/images/sized/images/uploads/the-nun-518949_1920-85x85.jpg" width="85" height="85"  alt="&#8216;Progressive&#8217; Orders are Passing Away&#8212;the Future Belongs to the Faithful" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-3" class="trending-entry lo-row">
        <div class="count lo-cell">
          3.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/indian-nuns-killer-participates-in-her-beatification-mass">Indian Nun&#8217;s Killer Participates in Her Beatification Mass</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/indian-nuns-killer-participates-in-her-beatification-mass">
                <img src="/images/sized/images/editorial/Anto-BEATINun-85x85.jpg" width="85" height="85"  alt="Indian Nun&#8217;s Killer Participates in Her Beatification Mass" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-4" class="trending-entry lo-row">
        <div class="count lo-cell">
          4.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/married-priests-and-missionary-failure">Married Priests and Missionary Failure</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/married-priests-and-missionary-failure">
                <img src="/images/sized/images/editorial/eucharist-1591663_960_720_pixabay-85x85.jpg" width="85" height="85"  alt="Married Priests and Missionary Failure" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-5" class="trending-entry lo-row">
        <div class="count lo-cell">
          5.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/jenfitz/11-ways-to-prepare-your-boy-to-be-a-great-priest-or-dad">11 Ways to Prepare Your Boy to be a Great Priest</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/jenfitz/11-ways-to-prepare-your-boy-to-be-a-great-priest-or-dad">
                <img src="/images/sized/images/uploads/Fitz-PREPARE-85x85.jpg" width="85" height="85"  alt="11 Ways to Prepare Your Boy to be a Great Priest" />
            </a>
          </div>
              </div>
              <div id="right-sidebar-b" class="ad-slot middle">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-b'); });
  </script>
</div>
           
      <div id="trending-entry-6" class="trending-entry lo-row">
        <div class="count lo-cell">
          6.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/archbishop-joseph-naumann-elected-head-of-bishops-pro-life-committee">Archbishop Joseph Naumann Elected Head of Bishops&#8217; Pro-Life Committee</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/archbishop-joseph-naumann-elected-head-of-bishops-pro-life-committee">
                <img src="/images/sized/images/editorial/Archbishop_Joseph_Naumann_Credit_Scott_Maentz_via_Flickr_CC_BY_20_CNA-85x85.jpg" width="85" height="85"  alt="Archbishop Joseph Naumann Elected Head of Bishops&#8217; Pro-Life Committee" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-7" class="trending-entry lo-row">
        <div class="count lo-cell">
          7.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/rfrech/if-your-teen-is-drifting-away-try-asking-this-question">If Your Teen is Drifting Away, Try Asking This Question</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/rfrech/if-your-teen-is-drifting-away-try-asking-this-question">
                <img src="/images/sized/images/uploads/Frech-QUESTIONS-85x85.jpg" width="85" height="85"  alt="If Your Teen is Drifting Away, Try Asking This Question" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-8" class="trending-entry lo-row">
        <div class="count lo-cell">
          8.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/antonetti/the-fighting-irish-arent-fighting-anymore">The Fighting Irish Aren&#8217;t Fighting Anymore</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/antonetti/the-fighting-irish-arent-fighting-anymore">
                <img src="/images/sized/images/uploads/Antonetti-NOTREDAME-85x85.jpg" width="85" height="85"  alt="The Fighting Irish Aren&#8217;t Fighting Anymore" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-9" class="trending-entry lo-row">
        <div class="count lo-cell">
          9.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/armstrong/muslims-are-converting-to-christianity-in-record-numbers">Muslims Are Converting to Christianity in Record Numbers</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/armstrong/muslims-are-converting-to-christianity-in-record-numbers">
                <img src="/images/sized/images/uploads/ArmstrongP-FRMITCH-85x85.jpg" width="85" height="85"  alt="Muslims Are Converting to Christianity in Record Numbers" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-10" class="trending-entry lo-row">
        <div class="count lo-cell">
          10.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/tito-edwards/reserving-the-eucharist-at-home-the-catholic-world-is-about-to-be-turned-up">Reserving the Eucharist at Home, The Catholic World Is About To Be Turned Upside Down, and More!</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/tito-edwards/reserving-the-eucharist-at-home-the-catholic-world-is-about-to-be-turned-up">
                <img src="/images/sized/images/uploads/Jesus_Christ_Host_Chalice_Eucharist_Credit_New_Theological_Movement-85x85.jpg" width="85" height="85"  alt="Reserving the Eucharist at Home, The Catholic World Is About To Be Turned Upside Down, and More!" />
            </a>
          </div>
              </div>
                        
  </div>
</div>

<div id="right-sidebar-c" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-c'); });
  </script>
</div>

<div class="ad-slot bottom">
  <a href="http://revive.registerticket.com/revive/www/delivery/ck.php?zoneid=71" target="_blank">
    <img src="http://revive.registerticket.com/revive/www/delivery/avw.php?zoneid=71">
  </a>
</div>

<div id="right-sidebar-d" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-d'); });
  </script>
</div>


    
  </div>
</div>
<div id="bottom-banner-ad" class="ad-slot main-center">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('bottom-banner-ad'); });
  </script>
</div>


    </div>
    <div id="footer-container">
      <div class="footer-logo">
  <div><img alt="Register Logo" src="/css/layout/images/ncregister100k.png"></div>
</div>
<div class="footer-text">
  <div class="footer-links">
    <div>
      <a href="/">Home</a>
      <a href="/info/about_the_register">About Us</a>
      <a href="http://pubads.g.doubleclick.net/gampad/clk?id=53318596&iu=/1319756/Click_Tracker">Subscriptions</a>
      <a href="http://pubads.g.doubleclick.net/gampad/clk?id=53318476&iu=/1319756/Click_Tracker" target="_blank">Donate</a>
      <a href="//ewtnadvertising.com" target="_blank">Advertise</a>
      <a href="/PR">Press Releases</a>
      <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank">RSS Daily Register</a>
      <a href="//feeds.feedburner.com/NationalCatholicRegisterBloggers" target="_blank">RSS Bloggers</a>
      <a href="/info/contacts">Contact</a>
      <a href="/jobs">Jobs</a>
    </div>
    <div>
      <a href="/info/opt-in-popup" class="subscribe-popup">Sign up for our E-Newsletter</a>
      <a href="https://www.facebook.com/NCRegister" target="_blank">Facebook</a>
      <a href="https://twitter.com/NCRegister" target="_blank">Twitter</a>
      <a href="https://www.youtube.com/NCRegister" target="_blank">YouTube</a>
      <a href="//instagram.com/ncregister/" target="_blank">Instagram</a>
      <a href="https://play.google.com/store/apps/details?id=com.ewtn.ncrreader&amp;hl=en" target="_blank">Android App</a>
      <a href="https://itunes.apple.com/us/app/national-catholic-register/id736212445?mt=8" target="_blank">iOS App</a>
      <a href="/info/ncr-privacy-policy">Privacy Policy</a>
    </div>
  </div>
  <div class="footer-fine-print">
    Copyright &copy; 2017 EWTN News, Inc.&nbsp; All rights reserved.<br>
    Reproduction of material from this website without written permission, or unlicensed commercial use<br>
    or monetization of <em>National Catholic Register</em> RSS feeds is strictly prohibited.<br>
    Accessed from 54.224.77.253
  </div>
</div>

    </div>
  </div>
  <div id="fixed-bottom-banner">
    <div id="fixed-bottom-banner-ad" class="ad-slot fixed-bottom-banner">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('fixed-bottom-banner-ad'); });
  </script>
</div>

  </div>
  <script type="text/javascript" src="/js/jquery.fancybox.pack.js"></script>
<script type="text/javascript" src="/js/menu.js"></script>
<script type="text/javascript" src="/js/global.js"></script>
<script type='text/javascript'>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 4055;
  _sf_async_config.domain = 'ncregister.com';
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  (function() {
      function loadChartbeat() {
          window._sf_endpt = (new Date()).getTime();
          var e = document.createElement('script');
          e.setAttribute('language', 'javascript');
          e.setAttribute('type', 'text/javascript');
          e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
          document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
          loadChartbeat : function() {
              oldonload();
              loadChartbeat();
          };
  })();
</script>
<script type="text/javascript">
  function suppressOptinPopup() {
    setCookie('op-off', new Date().getTime(), 45);
    jQuery.fancybox.close();
  }

  function suppressDonatePopup() {
    setCookie('dp-off', new Date().getTime(), 45);
    jQuery.fancybox.close();
  }

  function showOptinPopup(now) {
    var opDays = 7;
    setCookie('op-off', now, opDays);
    jQuery.fancybox.open({
      href: '/info/opt-in-popup/auto',
      padding: 0,
      type: 'iframe',
      closeBtn: false
    });
  }

  function showDonatePopup(now) {
    var dpDays = 7;
    setCookie('dp-off', now, dpDays);
    jQuery.fancybox.open({
      href: '/info/donate-popup',
      padding: 0,
      type: 'iframe',
      closeBtn: false
    });
  }

  function showInterstitialPopup() {
    jQuery.fancybox.open({
      href: '/message',
      type: 'iframe',
      padding: 0,
      width: 800,
      height: 625,
      fitToView: false,
      autoSize: false
    });
  }

  function handleOrdinary() {
    var now = new Date().getTime(),
        oneDay = 86400000,
        dpCountDays = 1,
        dpThresh = 2,
        dpOff = getCookie('dp-off'),
        opOff = getCookie('op-off'),
        dpCount = getCookie('dp-count');
    dpOff = dpOff == '' ? null : parseInt(dpOff);
    opOff = opOff == '' ? null : parseInt(opOff);
    dpCount = dpCount == '' ? 0 : parseInt(dpCount);
    setCookie('dp-count', dpCount + 1, dpCountDays);

    if (!dpOff && opOff && (now - opOff) > oneDay && dpCount > dpThresh)
      showDonatePopup(now);
    if (!opOff && (!dpOff || (now - dpOff) > oneDay))
      showOptinPopup(now);
  }

  function handleSeasonal() {
    if (getCookie('ip-off') != '')
      return;

    var ipDays = 2,
        ipCount = getCookie('ip-count');
    ipCount = ipCount == '' ? 0 : parseInt(ipCount);

    setCookie('ip-off', true, ipDays);
    setCookie('ip-count', (ipCount + 1) % 3, ipDays + 1);

    if (ipCount == 2)
      showOptinPopup(new Date().getTime());
    else
      showInterstitialPopup();
  }

  var seasonalOn = '#2016-12-12T05:00Z|2017-04-14T05:00Z';
  if (seasonalOn.startsWith('#'))
    seasonalOn = false;
  else {
    var parts = seasonalOn.split('|'),
        now = new Date(),
        isStart = new Date(parts[0]),
        isStop = new Date(parts[1]);
    seasonalOn = isStart <= now && now < isStop;
  }
  if (seasonalOn)
    handleSeasonal();
  else
    handleOrdinary();
</script>
<script type="text/javascript">
  (function() {
  function async_load(script_url){
  var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
  var s = document.createElement('script'); s.src = protocol + script_url;
  var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
  }
  bm_website_code = '720BD26B5B3D490F';
  jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
  jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
  })();
</script>

  <script type="text/javascript" src="/js/comments.js"></script>

  <script type="text/javascript" src="/js/embedded-article-ad.js"></script>

<script type="text/javascript" src="//connect.facebook.net/en_US/all.js"></script>
<script type="text/javascript">
  var fbWait = [ 3000, 9000 ],
      fbShareRetry = 0;
  function getFbShares() {
    $.ajax({
      url: 'http://graph.facebook.com/?fields=share&id=' + encodeURIComponent(metaUrl),
      dataType: 'json',
      success: function(data) {
        if (data.share) {
          $('#share-count').html(data.share.share_count);
          $('.share-count-container').show();
        } else if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      },
      error: function(resp) {
        if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      }
    });
  }
  getFbShares();

  $('.share-fb').click(function() {
    FB.ui({
      method: 'share',
      display: 'popup',
      href: metaUrl
    });
  });
  $('.share-print').click(function(e) {
    window.open($(e.target).attr('href'), 'Print', 'width=600,height=550,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('.share-twitter').click(function(e) {
    var url = 'https://twitter.com/intent/tweet?hashtags=NCRegister&text=' + encodeURIComponent(metaTitle) + '&url=' + encodeURIComponent(metaUrl)
    window.open(url, 'Tweet', 'width=600,height=400,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('#main-left-main .article-body a').attr('target', '_blank');

  function stickAdsInViewport() {
    var markerBR = $('#lsb-sticky-ads-marker')[0].getBoundingClientRect(),
        $ads = $('#lsb-sticky-ads'),
        adsBR = $ads[0].getBoundingClientRect(),
        mainLeftBR = $('#main-left')[0].getBoundingClientRect();
    if (mainLeftBR.left < 0) {
      $ads.removeClass('sticky top bottom');
      return;
    }
    if ($ads.hasClass('sticky top')) {
      if (adsBR.bottom > mainLeftBR.bottom) {
        $ads.removeClass('top').addClass('bottom');
      } else if (markerBR.top > 12) {
        $ads.removeClass('sticky top');
      }
    } else if ($ads.hasClass('sticky bottom')) {
      if (adsBR.top > 12) {
        $ads.removeClass('bottom').addClass('top');
      }
    } else {
      if (mainLeftBR.bottom - adsBR.height < 12) {
        $ads.addClass('sticky bottom');
      } else if (markerBR.top < 12) {
        $ads.addClass('sticky top');
      }
    }
  }

  $(stickAdsInViewport);
  $(window).on('scroll', stickAdsInViewport);
</script>

</body>
</html>


  
  




