  <!doctype html>
<html>
<head>
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.3/jquery.min.js"></script>
  <script>
  window.dataLayer = window.dataLayer || [];
  window.dataLayer.push({
    articlePubDate: "2018-08-12",
    articleSection: "Blogs",
    articleAuthor: "Tito Edwards",
    articleImageCredit: ""
  });
</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KB6S87');</script>
<!-- End Google Tag Manager -->
<script type="text/javascript">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</script>

  <script type='text/javascript'>var _sf_startpt=(new Date()).getTime(); // Chartbeat</script>
  <link rel="stylesheet" href="/css/layout/global.css">
  <link rel="stylesheet" href="/css/layout/jquery.fancybox.css">
  <link href="https://fonts.googleapis.com/css?family=Merriweather:300,300i,400,400i|Roboto:300,300i,400,400i,500,500i" rel="stylesheet">
  <link rel="stylesheet" href="/css/layout/detail.css">

  <title>The Sign of the Weeping Madonna, A Masterpiece of Catholic Art is Unveiled in Malta, and More Links!</title>
<link rel="canonical" href="http://www.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i">
<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i">
<meta property="fb:pages" content="64182915497">
<meta property="fb:app_id" content="347756275321330">
<meta property="fb:admins" content="1477213784">
<meta property="og:type" content="article">
<meta property="og:site_name" content="National Catholic Register">
<meta property="og:url" content="http://www.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i">
<meta property="og:description" content="The Best in Catholic Blogging">
<meta property="og:title" content="The Sign of the Weeping Madonna, A Masterpiece of Catholic Art is Unveiled in Malta, and More Links!">
<meta property="og:image" content="http://www.ncregister.com/images/uploads/The_Weeping_Madonna_Pic_Credit_Screen_Shot_from_Fr_Dwight_Longenecker.png">
<meta property="og:image:width" content="865">
<meta property="og:image:height" content="481">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@NCRegister">
<meta name="twitter:url" content="http://www.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i">
<meta name="twitter:description" content="The Best in Catholic Blogging">
<meta name="twitter:title" content="The Sign of the Weeping Madonna, A Masterpiece of Catholic Art is Unveiled in Malta, and More Links!">
<meta name="twitter:image" content="http://www.ncregister.com/images/uploads/The_Weeping_Madonna_Pic_Credit_Screen_Shot_from_Fr_Dwight_Longenecker.png">
<script type="text/javascript">
  var metaUrl = 'http://www.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i',
      metaPath = 'blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i',
      metaTitle = "The Sign of the Weeping Madonna, A Masterpiece of Catholic Art is Unveiled in Malta, and More Links!",
      metaDescr = "The Best in Catholic Blogging",
      metaTags = ['Tito Edwards', 'Blogs'];
  if ("" != '')
    [].push.apply(metaTags, "".split(', '));
</script>

</head>
<body>
  <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KB6S87"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

  <div id="fb-root"></div>
  <div id="page-container">
    <div id="header-container">
      <div id="header-global-nav">
  <div class="header-left">
    <div class="menu">
      <a class="menu-root" data-menu-id="sections-menu" href="javascript:;" >
        <img alt="menu" src="/css/layout/images/hamburger.png"> Sections
      </a>&nbsp;
      <div id="sections-menu" data-menu-id="sections-menu" class="menu-items">
  <a href="/sections/nation" class="item">Nation</a>
  <a href="/sections/vatican" class="item">Vatican</a>
  <a href="/sections/world" class="item">World</a>
  <a href="/sections/commentary" class="item">Commentary</a>
  <a href="/sections/blog" class="item">Blogs</a>
  <a href="/sections/features" class="item">Features</a>
  <a href="/sections/movies" class="item">Movies</a>
  <a href="/sections/books" class="item">Books</a>
  <a href="/sections/travel" class="item">Travel</a>
  <a href="/sections/radio" class="item">Radio</a>
  <a href="/info/resources1" class="item">Resources</a>
  <a href="/college-guide" class="item">College Guide</a>
</div>

    </div>
    <div class="menu">
      <a href="/"><img alt="menu" src="/css/layout/images/home.png"> Home</a>&nbsp;
    </div>
    <div class="menu">
      <a id="search-menu-root" href="javascript:;"><img alt="search" src="/css/layout/images/lens.png"> Search</a>
      <div id="search-form-container">
        <form id="search-form">
          <input name="q" id="search-site" type="text" autocomplete="off" placeholder="Search NCRegister">
        </form>
      </div>
    </div>
  </div>
  <div class="header-right">
    <div class="menu">
      <a class="menu-root" data-menu-id="advertise-menu" href="http://ewtnadvertising.com" target="_blank">Advertise</a>&nbsp;
      <div id="advertise-menu" data-menu-id="advertise-menu" class="menu-items">
        <a href="http://ewtnadvertising.com/print-advertising/" target="_blank" class="item">Register Print Ads</a>
        <a href="http://ewtnadvertising.com" target="_blank" class="item">EWTN News Digital Ads</a>
        <a href="https://orders.ewtnadvertising.com/" target="_blank" class="item">Order Ads Online</a>
        <a href="http://ewtnadvertising.com/ncregister-com-job-board/" target="_blank" class="item">Post a Job ad</a>
      </div>
    </div>
    <div class="menu">
      <a class="menu-root" data-menu-id="subscriptions-menu" href="/info/subscribe">Subscriptions</a>&nbsp;
      <div id="subscriptions-menu" data-menu-id="subscriptions-menu" class="menu-items">
        <a href="https://sfsdata.com/ncr/Subscribe.aspx?KEY=918MSP" target="_blank" class="item">Subscribe</a>
        <a href="https://sfsdata.com/NCR/GiftR.html?KEY=918GIF" target="_blank" class="item">Give a Gift Subscription</a>
        <a href="/info/bulk-subscriptions" class="item">Discounted Bulk Subscriptions</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Gift Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Payments</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Account Status</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Missed Issue</a>
        <a href="/info/opt-in" target="_blank" class="item">Daily or Weekly e-Newsletter</a>
      </div>
    </div>
    <a href="https://donate.ncregister.com/p-4-enews-general-fund.aspx?source=N18W" target="_blank">Donate</a>&nbsp;
    <a href="/jobs">Jobs</a>&nbsp;
    <a href="http://www.ewtn.com/cataloguefeatured/" target="_blank">Store</a>
    <a href="http://www.catholicnewsagency.com/?utm_source=NCR%20Header%20Link" target="_blank">CNA</a>
  </div>
  <div class="header-center">
    <a href="//www.facebook.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/facebook.png"></a>
    <a href="//twitter.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/twitter.png"></a>
    <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank"><img alt="search" src="/css/layout/images/rss.png"></a>
    <a href="/info/opt-in" target="_blank"><img alt="daily update" src="/css/layout/images/newsletter.png"></a>
  </div>
</div>
<div id="header-banner-ad" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('header-banner-ad'); });
  </script>
</div>

<div id="header-logo-header">
  <div id="logo-super">
    <div class="header-left divider"></div>
    <div class="header-right divider"></div>
    <div class="header-center divider-text">A Service of EWTN</div>
  </div>
  
    <div class="header-left header-ad">
      <div id="interior-logo-left" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-left'); });
  </script>
</div>

    </div>
    <div class="header-right header-ad">
      <div id="interior-logo-right" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-right'); });
  </script>
</div>

    </div>
  
  <div id="logo-header">
    
      <div id="logo" class="header-center"><a href="/"><img alt="Register Logo" src="/css/layout/images/ncregister-logo-385x115.png"></a></div>
    
  </div>
</div>


    </div>
    <div id="main-container">
      <div id="main" class="lo-row">
  <div id="main-left" class="lo-cell">
    <div id="main-left-top" class="lo-row">
      <div id="main-left-sidebar" class="lo-cell">
        
          <div>
  <div class="share-count-container">
    <div id="share-count">0</div>
    <div>Shares</div>
  </div>
  <div class="icons">
    <div class="entry">
      <a rel="nofollow" class="email-article-link">
        <img class="center-vertical icon" alt="Email" src="/css/layout/images/detail-email.png">
      <a>
      <div class="center-vertical caption"><a rel="nofollow" class="email-article-link">Email</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" href="javascript:;" class="share-fb">
        <img class="center-vertical icon" alt="Share" src="/css/layout/images/detail-facebook.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" href="javascript:;" class="share-fb">Share</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" class="share-twitter" href="javascript:;">
        <img class="center-vertical icon" alt="Tweet" src="/css/layout/images/detail-twitter.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-twitter" href="javascript:;">Tweet</a></div>
    </div>
    
      <div class="entry">
        <a class="view-comments-link" rel="nofollow" href="#article-view-comments">
          <img class="center-vertical icon" alt="Comment" src="/css/layout/images/detail-comment.png">
        </a>
        <div class="center-vertical caption"><a class="view-comments-link" rel="nofollow" href="#article-view-comments">Comment</a></div>
      </div>
    
    <div class="entry">
      <a rel="nofollow" class="share-print" href="/site/print/57665" target="_blank">
        <img class="center-vertical icon" alt="Print" src="/css/layout/images/detail-print.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-print" href="/site/print/57665" target="_blank">Print</a></div>
    </div>
  </div>
</div>
<div id="lsb-sticky-ads-marker"></div>
<div id="lsb-sticky-ads">
  <div id="left-sidebar-a" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-a'); });
  </script>
</div>

  <div id="left-sidebar-b" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-b'); });
  </script>
</div>

  <div id="left-sidebar-c" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-c'); });
  </script>
</div>

  <div id="left-sidebar-d" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-d'); });
  </script>
</div>

</div>

        
      </div>
      <div id="main-left-main" class="lo-cell">
        
            
  
  
  
  
  
  
  
  
    
    
    
  
      <div class="article-image"><img alt="The Weeping Madonna (Pic Credit: Screen Shot from Fr. Dwight Longenecker)" src="/images/uploads/The_Weeping_Madonna_Pic_Credit_Screen_Shot_from_Fr_Dwight_Longenecker.png"></div>
    <div class="article-image-caption">The Weeping Madonna (Pic Credit: Screen Shot from Fr. Dwight Longenecker) </div>
    <div class="article-section">
    <a href="/sections/blog">Blogs</a>&nbsp;|&nbsp; Aug. 12, 2018
  </div>
  <div class="article-title">The Sign of the Weeping Madonna, A Masterpiece of Catholic Art is Unveiled in Malta, and More Links!</div>
      <div class="article-subhead">The Best in Catholic Blogging</div>
    <div class="article-author"><a href="/blog/tito-edwards">Tito Edwards</a></div>
    <div class="article-body"><p><a href="https://dwightlongenecker.com/the-sign-of-the-weeping-madonna/"><span style="color: #800000;"><strong>The Sign of the Weeping Madonna</strong></span></a>&nbsp;- Fr. Dwight Longenecker</p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="https://www.youtube.com/watch?v=CqW1lENuph0&amp;feature=youtu.be"><strong><span style="color: #800000;">Live Perpetual Adoration of the Blessed Sacrament</span></strong></a>&nbsp;&ndash; Adorecast</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn">&nbsp;</span></span><a href="http://www.catholicherald.co.uk/commentandblogs/2018/07/26/a-masterpiece-of-catholic-art-is-unveiled-in-malta/"><strong><span style="color: #800000;">A Masterpiece of Catholic Art is Unveiled in Malta</span></strong></a>&nbsp;&ndash; Fr. Alexander Lucie-Smith Ph.D., Catholic Herald</p>

<p><span style="color: #800000;"><strong><a href="http://bigpulpit.com/category/mccarrick-watch/" style="color: #800000;">McCarrick Watch: Up-to-Date News on the former-Cardinal McCarrick Homosexual Predation &amp; Cover-Up Scandal</a></strong></span>&nbsp;- Big Pulpit</p>

<p><a href="https://epicpew.com/catholic-items-see-probably-dont-know-names/"><span style="color: #800000;"><strong>Catholic Items You See, But Probably Don&rsquo;t Know The Names Of</strong></span></a>&nbsp;&ndash; Amy O&rsquo;Connell, epicPew</p>

<p><a href="https://healingheartofjesus.com/2018/05/17/prayer-for-those-who-have-loved-ones-with-anxiety-and-or-depression/" rel="noopener" target="_blank"><span style="color: #800000;"><strong>A Prayer for Those Who Have Loved Ones with Anxiety and/or Depression</strong></span></a>&nbsp;&ndash; Laura Durant, Healing Heart of Jesus</p>

<p><a href="http://liturgicalnotes.blogspot.com/2018/07/the-sunday-obligation.html"><strong><span style="color: #800000;">The Sunday Obligation</span></strong></a>&nbsp;&ndash; Fr. John Hunwicke, Fr Hunwicke&rsquo;s Mutual Enrichment</p>

<p><a href="http://www.catholicherald.co.uk/commentandblogs/2018/07/27/what-is-it-actually-like-to-be-ordained-a-priest/"><span style="color: #800000;"><strong>What Is It Actually Like To Be Ordained a Priest?</strong></span></a>&nbsp;&ndash; Fr. Michael Ward, Catholic Herald</p>

<p><a href="https://catholic-link.org/catholic-masculinity-men-grow-holiness-part-1/"><strong><span style="color: #800000;">Catholic Masculinity: How Men Can Grow in Holiness</span></strong></a>&nbsp;&ndash; Will Wright, Catholic Link</p>

<p><a href="https://catholicexchange.com/modesty-is-more-than-what-we-wear"><span style="color: #800000;"><strong>Modesty Is More Than What We Wear</strong></span></a>&nbsp;&ndash; Jeannie Ewing, Catholic Exchange</p>

<p><a href="https://www.catholic.com/magazine/online-edition/is-humanae-vitae-infallible-teaching"><strong><span style="color: #800000;">Is Humanae Vitae Infallible Teaching?</span></strong></a>&nbsp;&ndash; Tom Nash, Catholic Answers Magazine</p>

<p><a href="https://catholicexchange.com/13-god-centered-reasons-go-church-every-weekend"><span style="color: #800000;"><strong>13 God-Centered Reasons to Go to Church Every Weekend</strong></span></a>&nbsp;&ndash; Fr. Edward Looney, Catholic Exchange</p>

<p><a href="http://catholicherald.co.uk/commentandblogs/2018/07/20/are-you-just-a-sunday-morning-catholic/"><strong><span style="color: #800000;">Are You Just a Sunday-Morning Catholic?</span></strong></a>&nbsp;&ndash; Francis Phillips, Catholic Herald</p>

<p><a href="https://catholicexchange.com/emotions-unruly-unreliable-guide"><span style="color: #800000;"><strong>Put Your Faith in Christ, Not in Feelings</strong></span></a>&nbsp;&ndash; Constance T. Hull, Catholic Exchange</p>

<p><a href="http://www.newliturgicalmovement.org/2018/07/arranging-ef-breviary-for-rest-of.html"><span style="color: #800000;"><strong>Arranging the EF Breviary for the Rest of the Liturgical Year 2018</strong></span></a>&nbsp;&ndash; Gregory DiPippo, New Liturgical Movement</p>

<p><a href="https://www.catholicworldreport.com/2018/07/22/one-man-can-make-a-difference/"><strong><span style="color: #800000;">The Biography of Dr. Warren Carroll</span></strong></a>&nbsp;&ndash; Alan L. Anderson, The Catholic World Report</p>

<p><a href="http://www.catholicherald.co.uk/news/2018/07/28/man-thanks-australian-saint-for-miracle-parkinsons-cure/"><span style="color: #800000;"><strong>Man Thanks Australian Saint for Miracle Parkinson&rsquo;s Cure</strong></span></a>&nbsp;&ndash; Catherine Sheehan, Catholic Herald</p>

<p>For the Most Recent in &#39;The Best in Catholic Blogging&#39; click on&nbsp;<strong><a href="http://bigpulpit.com/" rel="noopener" target="_blank"><span style="color: #3366ff;"><span style="color: #ff0000;">&#9769;</span> Big Pulpit <span style="color: #ff0000;">&#9769;</span></span></a>.</strong></p></div>
    

        
        <div id="article-footer-ad" class="ad-slot article-footer">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('article-footer-ad'); });
  </script>
</div>

        
          <script type="text/javascript">
  var noMoreComments, entryId = '57665';
</script>
<a name="article-view-comments"></a>
<div id="comments-hidden" class="article-view-comments view-comments-link">View Comments</div>
<div id="comments-shown" class="article-comments-container">
  <div class="article-comments-header lo-row">
    <div class="heading lo-cell view-comments-link" title="Click to fetch latest comments">Comments</div>
    <div class="join-link lo-cell"><a href="#article-join-discussion">Join the Discussion</a></div>
  </div>
  <div id="comments-container" class="article-comments"></div>
  <a name="article-join-discussion"></a>
  <div class="article-more-comments">
    <div class="instructions-header">Join the Discussion</div>
    <div class="instructions">
      We encourage a lively and honest discussion of our content. We ask that charity guide your words.
        By submitting this form, you are agreeing to our <a href="/info/discussion-guidelines">discussion guidelines</a>.
        Comments are published at our discretion. We won't publish comments that lack charity, are off topic, or are more than 400 words.
        Thank you for keeping this forum thoughtful and respectful.
    </div>
    <form id="comment_form" method="post" action="http://www.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="http://www.ncregister.com/blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i" />
<input type="hidden" name="URI" value="blog/tito-edwards/the-sign-of-the-weeping-madonna-a-masterpiece-of-catholic-art-is-unveiled-i" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="XID" value="" />
<input type="hidden" name="entry_id" value="57665" />
<input type="hidden" name="site_id" value="1" />
</div>

 
                  
      <div class="form-fields">
                  <p>Name:<br /><input class="text" type="text" name="name" value="" /></p>
          <p>Email:<br /><input class="text" type="email" name="email" value="" /></p>
                <p><input type="hidden" name="title" value="" />
          Write your comment:<br />
          <textarea name="comment" cols="" rows="10" wrap="virtual" class="input_element"></textarea>
          <!-- <input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments. -->
        </p>
                  <p class="captcha" >Please enter the word you see in the image below:<br />
            <input class="text" type="text" name="captcha" value="" maxlength="20" /><br />
            <img src="//www.ncregister.com/images/captchas/1534065929.9186.jpg" width="140" height="30" style="border:0;" alt=" " /></p>
                <p>
          <input type="submit" class="button" name="submit" value="Submit" />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
          <input type="reset" class="button" name="reset" value="Clear" />
        </p>
        <input type="hidden" name="save_info" value="yes" />      </div>
    </form>
  </div>
  <div class="article-no-more-comments">
    Comments are no longer being accepted on this article.
  </div>
</div>

        
      </div>
    </div>
    <div id="main-left-bottom">
    </div>
  </div>
  <div id="main-right" class="lo-cell">
    
      <div id="right-sidebar-a" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-a'); });
  </script>
</div>


  <div wibbitz="embed-player-widget" class="video-ad"></div>

<div id="blogger-bio">
  
    <div class="name"><a href="/blog/tito-edwards">Tito Edwards</a></div>
    <div class="image"><img src="/images/sized/images/member_photos/photo_8608-85x85.png" width="85" height="85"  alt="Tito Edwards" /></div>
    <div class="text"><p>Tito Edwards manages Catholic websites for the new evangelization that Pope John Paul II and then Cardinal Ratzinger, now Pope Benedict XVI, has asked for in the third millennium.</p>

<p>After a lifetime of living a nominal Catholic life, he reverted completely to his childhood faith that began on the eve of the funeral of Pope John Paul II.</p>

<p>He publishes <a href="http://bigpulpit.com/">Big Pulpit</a>, <a href="http://CatholicStand.com/">Catholic Stand</a>, <a href="http://IgnitumToday.com/">Ignitum Today</a>, and <a href="http://the-american-catholic.com/">The American Catholic</a>.</p></div>
    <div class="clear"></div>
  
</div>

<div id="trending">
  <h1>Trending</h1>
  <div class="trending-panel">
     
      <div id="trending-entry-1" class="trending-entry lo-row">
        <div class="count lo-cell">
          1.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/truth-is-needed-to-free-the-church-from-sacrilege-of-clergy-scandal">Truth Is Needed to Free the Church From Sacrilege of Clergy Scandal</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/truth-is-needed-to-free-the-church-from-sacrilege-of-clergy-scandal">
                <img src="/images/sized/images/editorial/new_Priest_collar_Credit_Lisa_F_Young_via_wwwshutterstockcom_CNA-85x85.jpg" width="85" height="85"  alt="Truth Is Needed to Free the Church From Sacrilege of Clergy Scandal" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-2" class="trending-entry lo-row">
        <div class="count lo-cell">
          2.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/joseph-pronechen/fulton-sheen-answers-for-a-christendom-crisis">Archbishop Sheen&#8217;s Warning of a Crisis in Christendom</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/joseph-pronechen/fulton-sheen-answers-for-a-christendom-crisis">
                <img src="/images/sized/images/editorial/Sheen-85x85.jpg" width="85" height="85"  alt="Archbishop Sheen&#8217;s Warning of a Crisis in Christendom" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-3" class="trending-entry lo-row">
        <div class="count lo-cell">
          3.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/edward-pentin/rock-star-sting-on-the-mass-the-church-and-the-fortress-around-gods-heart">Sting: &#8216;The Church&#8217;s Music and Liturgy Fed This Artistic Soul&#8217;</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/edward-pentin/rock-star-sting-on-the-mass-the-church-and-the-fortress-around-gods-heart">
                <img src="/images/sized/images/uploads/Pentin-STINGINTERVIEW-85x85.jpg" width="85" height="85"  alt="Sting: &#8216;The Church&#8217;s Music and Liturgy Fed This Artistic Soul&#8217;" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-4" class="trending-entry lo-row">
        <div class="count lo-cell">
          4.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/father-michael-schmitz-tells-the-truth-in-love-about-same-sex-attraction">Father Michael Schmitz Tells the Truth in Love About Same-Sex Attraction</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/father-michael-schmitz-tells-the-truth-in-love-about-same-sex-attraction">
                <img src="/images/sized/images/editorial/SchmitzMadeforLove-85x85.jpg" width="85" height="85"  alt="Father Michael Schmitz Tells the Truth in Love About Same-Sex Attraction" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-5" class="trending-entry lo-row">
        <div class="count lo-cell">
          5.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/cardinal-omalley-orders-boston-seminary-inquiry-places-rector-on-sabbatical">Cardinal O&#8217;Malley Orders Boston Seminary Inquiry, Places Rector on &#8216;Sabbatical&#8217;</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/cardinal-omalley-orders-boston-seminary-inquiry-places-rector-on-sabbatical">
                <img src="/images/sized/images/uploads/CNA_Cardinal_OMalley_ordination_Mass_2016-85x85.jpg" width="85" height="85"  alt="Cardinal O&#8217;Malley Orders Boston Seminary Inquiry, Places Rector on &#8216;Sabbatical&#8217;" />
            </a>
          </div>
              </div>
              <div id="right-sidebar-b" class="ad-slot middle">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-b'); });
  </script>
</div>
           
      <div id="trending-entry-6" class="trending-entry lo-row">
        <div class="count lo-cell">
          6.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/msgr-pope/in-the-midst-of-clerical-misdeeds-a-crucial-moment-for-the-laity">In the Midst of Clerical Misdeeds, a Crucial Moment for the Laity</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/msgr-pope/in-the-midst-of-clerical-misdeeds-a-crucial-moment-for-the-laity">
                <img src="/images/sized/images/uploads/Pope-OUTERBANDS-85x85.jpg" width="85" height="85"  alt="In the Midst of Clerical Misdeeds, a Crucial Moment for the Laity" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-7" class="trending-entry lo-row">
        <div class="count lo-cell">
          7.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/fernandez/the-laity-demand-justice-and-action">The Laity Demand Justice and Action</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/fernandez/the-laity-demand-justice-and-action">
                <img src="/images/sized/images/uploads/Theodore_Cardinal_McCarrick_Credit_Wikipedia-85x85.jpg" width="85" height="85"  alt="The Laity Demand Justice and Action" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-8" class="trending-entry lo-row">
        <div class="count lo-cell">
          8.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/pjsmith/bishop-checchio-we-must-eliminate-metoo-seminarians-and-priests-fear-of-ret">Metuchen Bishop: Fear of Retribution Must End for #MeToo Seminarians</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/pjsmith/bishop-checchio-we-must-eliminate-metoo-seminarians-and-priests-fear-of-ret">
                <img src="/images/sized/images/uploads/PJSmith-CHECCHIO-85x85.jpg" width="85" height="85"  alt="Metuchen Bishop: Fear of Retribution Must End for #MeToo Seminarians" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-9" class="trending-entry lo-row">
        <div class="count lo-cell">
          9.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/kschiffer/bishop-shawn-mcknight-it-is-almost-unbearable">Bishop Shawn McKnight: &#8220;It is Almost Unbearable&#8221;</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/kschiffer/bishop-shawn-mcknight-it-is-almost-unbearable">
                <img src="/images/sized/images/uploads/Schiffer-MCKNIGHT-85x85.jpg" width="85" height="85"  alt="Bishop Shawn McKnight: &#8220;It is Almost Unbearable&#8221;" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-10" class="trending-entry lo-row">
        <div class="count lo-cell">
          10.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/archbishop-sample-emphasizes-liturgy-according-to-the-mind-heart-of-the-chu">Archbishop Sample Emphasizes &#8216;Liturgy According to the Mind, Heart of the Church&#8217;</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/archbishop-sample-emphasizes-liturgy-according-to-the-mind-heart-of-the-chu">
                <img src="/images/sized/images/editorial/0805_0000_joejump-85x85.jpg" width="85" height="85"  alt="Archbishop Sample Emphasizes &#8216;Liturgy According to the Mind, Heart of the Church&#8217;" />
            </a>
          </div>
              </div>
                        
  </div>
</div>

<div id="right-sidebar-c" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-c'); });
  </script>
</div>

<div class="ad-slot bottom">
  <a href="http://revive.registerticket.com/revive/www/delivery/ck.php?zoneid=71" target="_blank">
    <img src="http://revive.registerticket.com/revive/www/delivery/avw.php?zoneid=71">
  </a>
</div>

<div id="right-sidebar-d" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-d'); });
  </script>
</div>


    
  </div>
</div>
<div id="bottom-banner-ad" class="ad-slot main-center">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('bottom-banner-ad'); });
  </script>
</div>


    </div>
    <div id="footer-container">
      <div class="footer-logo">
  <div><img alt="Register Logo" src="/css/layout/images/ncregister100k.png"></div>
</div>
<div class="footer-text">
  <div class="footer-links">
    <div>
      <a href="/">Home</a>
      <a href="/info/about_the_register">About Us</a>
      <a href="/info/subscribe">Subscriptions</a>
      <a href="https://donate.ncregister.com/p-4-enews-general-fund.aspx?source=N18W" target="_blank">Donate</a>
      <a href="//ewtnadvertising.com" target="_blank">Advertise</a>
      <a href="/PR">Press Releases</a>
      <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank">RSS Daily Register</a>
      <a href="//feeds.feedburner.com/NationalCatholicRegisterBloggers" target="_blank">RSS Bloggers</a>
      <a href="/info/contacts">Contact</a>
      <a href="/jobs">Jobs</a>
    </div>
    <div>
      <a href="/?mobile=1" class="mobile-only">Mobile Site</a>
      <a href="/info/opt-in" target="_blank">Sign up for our E-Newsletter</a>
      <a href="https://www.facebook.com/NCRegister" target="_blank">Facebook</a>
      <a href="https://twitter.com/NCRegister" target="_blank">Twitter</a>
      <a href="https://www.youtube.com/NCRegister" target="_blank">YouTube</a>
      <a href="//instagram.com/ncregister/" target="_blank">Instagram</a>
      <a href="https://play.google.com/store/apps/details?id=com.ewtn.ncrreader&amp;hl=en" target="_blank">Android App</a>
      <a href="https://itunes.apple.com/us/app/national-catholic-register/id736212445?mt=8" target="_blank">iOS App</a>
      <a href="/info/ncr-privacy-policy">Privacy Policy</a>
          </div>
  </div>
  <div class="footer-fine-print">
    Copyright &copy; 2018 EWTN News, Inc.&nbsp; All rights reserved.<br>
    Reproduction of material from this website without written permission, or unlicensed commercial use<br>
    or monetization of <em>National Catholic Register</em> RSS feeds is strictly prohibited.<br>
    Accessed from 52.90.98.148
  </div>
</div>

    </div>
  </div>
  <div id="fixed-bottom-banner">
    <div id="fixed-bottom-banner-ad" class="ad-slot fixed-bottom-banner">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('fixed-bottom-banner-ad'); });
  </script>
</div>

  </div>
  <script type="text/javascript" src="/js/jquery.fancybox.pack.js"></script>
<script type="text/javascript" src="/js/menu.js"></script>
<script type="text/javascript" src="/js/global.js"></script>
<script type='text/javascript'>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 4055;
  _sf_async_config.domain = 'ncregister.com';
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  (function() {
      function loadChartbeat() {
          window._sf_endpt = (new Date()).getTime();
          var e = document.createElement('script');
          e.setAttribute('language', 'javascript');
          e.setAttribute('type', 'text/javascript');
          e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
          document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
          loadChartbeat : function() {
              oldonload();
              loadChartbeat();
          };
  })();
</script>

  <script type="text/javascript" src="/js/comments.js"></script>

  <script type="text/javascript" src="/js/embedded-article-ad.js"></script>

<script type="text/javascript" src="//cdn4.wibbitz.com/national.catholic.register/embed.js" async></script>
<script type="text/javascript" src="//connect.facebook.net/en_US/all.js"></script>
<script type="text/javascript">
  var fbWait = [ 3000, 9000 ],
      fbShareRetry = 0;
  function getFbShares() {
    $.ajax({
      url: '//graph.facebook.com/?fields=share&id=' + encodeURIComponent(metaUrl),
      dataType: 'json',
      success: function(data) {
        if (data.share) {
          $('#share-count').html(data.share.share_count);
          $('.share-count-container').show();
        } else if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      },
      error: function(resp) {
        if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      }
    });
  }
  getFbShares();

  $('.share-fb').click(function() {
    FB.ui({
      method: 'share',
      display: 'popup',
      href: metaUrl
    });
  });
  $('.share-print').click(function(e) {
    window.open($(e.target).attr('href'), 'Print', 'width=600,height=550,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('.share-twitter').click(function(e) {
    var url = 'https://twitter.com/intent/tweet?hashtags=NCRegister&text=' + encodeURIComponent(metaTitle) + '&url=' + encodeURIComponent(metaUrl)
    window.open(url, 'Tweet', 'width=600,height=400,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('#main-left-main .article-body a').attr('target', '_blank');

  function stickAdsInViewport() {
    var markerBR = $('#lsb-sticky-ads-marker')[0].getBoundingClientRect(),
        $ads = $('#lsb-sticky-ads'),
        adsBR = $ads[0].getBoundingClientRect(),
        mainLeftBR = $('#main-left')[0].getBoundingClientRect();
    if (mainLeftBR.left < 0) {
      $ads.removeClass('sticky top bottom');
      return;
    }
    if ($ads.hasClass('sticky top')) {
      if (adsBR.bottom > mainLeftBR.bottom) {
        $ads.removeClass('top').addClass('bottom');
      } else if (markerBR.top > 12) {
        $ads.removeClass('sticky top');
      }
    } else if ($ads.hasClass('sticky bottom')) {
      if (adsBR.top > 12) {
        $ads.removeClass('bottom').addClass('top');
      }
    } else {
      if (mainLeftBR.bottom - adsBR.height < 12) {
        $ads.addClass('sticky bottom');
      } else if (markerBR.top < 12) {
        $ads.addClass('sticky top');
      }
    }
  }

  $(stickAdsInViewport);
  $(window).on('scroll', stickAdsInViewport);

  $('.email-article-link').attr('href', 'mailto:?subject=' + encodeURIComponent(metaTitle) + '&body=' + encodeURIComponent(metaDescr) + '%0A%0A' + encodeURIComponent(metaUrl));
</script>

</body>
</html>


  
  




