  <!doctype html>
<html>
<head>
  <script type='text/javascript'>var _sf_startpt=(new Date()).getTime(); // Chartbeat</script>
  <link rel="stylesheet" href="/css/layout/global.css">
  <link rel="stylesheet" href="/css/layout/jquery.fancybox.css">
  <link href="https://fonts.googleapis.com/css?family=Merriweather:300,300i,400,400i|Roboto:300,300i,400,400i,500,500i" rel="stylesheet">
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.3/jquery.min.js"></script>
  <!-- REVISED-CAN Container tag for NCRegister.com-->
<script async="1">
  (function() {
    __mtm = [ '55bbf6162cceb4ae45ce5480', 'cdn01.mzbcdn.net/mngr' ];
    var s = document.createElement('script');
    s.async = 1;
    s.src = '//' + __mtm[1] + '/mtm.js';
    var e = document.getElementsByTagName('script')[0];
    (e.parentNode || document.body).insertBefore(s, e);
  })();
</script>
<script type="text/javascript">
  // Ads
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();

  googletag.cmd.push(function() {
    googletag.defineSlot('/1319756/Top_Banner', [728, 90], 'header-banner-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Bottom_Banner', [728, 90], 'bottom-banner-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Middle_Banner_Home', [728, 90], 'home-middle-banner-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_Large_AdBar', [850, 50], 'fixed-bottom-banner-ad').addService(googletag.pubads());

    googletag.defineSlot('/1319756/Left_Sidebar_A', [180, 150], 'left-sidebar-a').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Left_Sidebar_B', [180, 150], 'left-sidebar-b').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Left_Sidebar_C', [180, 150], 'left-sidebar-c').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Left_Sidebar_D', [180, 150], 'left-sidebar-d').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_A', [[300, 250], [300, 169]], 'right-sidebar-a').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_B', [[300, 250], [300, 169]], 'right-sidebar-b').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_C', [[300, 250], [300, 169]], 'right-sidebar-c').addService(googletag.pubads());
    googletag.defineSlot('/1319756/Right_Sidebar_D', [[300, 250], [300, 169]], 'right-sidebar-d').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_Article_1', [300, 250], 'embedded-ad-1').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_300x250_Fallback', [300, 250], 'NCR_300x250_Fallback').addService(googletag.pubads());

    googletag.defineSlot('/1319756/Article_Footer', [468, 60], 'article-footer-ad').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Home_Header_Right', [125, 125], 'home-logo-right').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Interior_Header_Left', [125, 125], 'interior-logo-left').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Interior_Header_Right', [125, 125], 'interior-logo-right').addService(googletag.pubads());

    googletag.defineSlot('/1319756/NCR_EN_Search_1', [615, 80], 'search-text-1').addService(googletag.pubads());
    googletag.defineSlot('/1319756/NCR_EN_Search_2', [615, 80], 'search-text-2').addService(googletag.pubads());

    googletag.defineSlot('/1319756/NCR_EN_CollegeGuideLink', [150, 35], 'college-guide-link').addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs(true, true);
    if (typeof metaTags != 'undefined')
      googletag.pubads().setTargeting('Keyword', metaTags);
    googletag.enableServices();
  });

  // Facebook
  window.fbAsyncInit = function() {
    FB.init({
      appId   : '347756275321330',
      xfbml   : true,
      version : 'v2.9'
    });
  };

  (function(d, s, id){
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) {return;}
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

  // Google Analytics
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
     (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
       m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
         })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-767764-1', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

  function getCookie(cname) {
    var cs = document.cookie.split(/;\s*/),
        name = cname + '=';
    for (var i = 0; i < cs.length; i++) {
      if (cs[i].indexOf(name) == 0)
        return cs[i].substr(name.length);
    }
    return '';
  }

  function setCookie(cname, value, expDays) {
    var c = cname + '=' + value;
    if (expDays) {
      var d = new Date();
      d.setTime(d.getTime() + expDays * 24 * 60 * 60 * 1000);
      c += '; expires=' + d.toUTCString() + '; path=/';
    }
    document.cookie = c;
  }
</script>

  <link rel="stylesheet" href="/css/layout/detail.css">

  <title>Indiana Native Dedicates Herself as Consecrated Virgin, Will We Know Each Other In Heaven, and More!</title>
<link rel="canonical" href="http://www.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot">
<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot">
<meta property="fb:pages" content="64182915497">
<meta property="fb:app_id" content="347756275321330">
<meta property="fb:admins" content="1477213784">
<meta property="og:type" content="article">
<meta property="og:site_name" content="National Catholic Register">
<meta property="og:url" content="http://www.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot">
<meta property="og:description" content="The Best in Catholic Blogging">
<meta property="og:title" content="Indiana Native Dedicates Herself as Consecrated Virgin, Will We Know Each Other In Heaven, and More!">
<meta property="og:image" content="http://www.ncregister.com/images/uploads/Consecrated_Virgin_Jennifer_Sergio_Credit_Todays_Catholic.jpg">
<meta property="og:image:width" content="1954">
<meta property="og:image:height" content="700">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@NC_Register">
<meta name="twitter:url" content="http://www.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot">
<meta name="twitter:description" content="The Best in Catholic Blogging">
<meta name="twitter:title" content="Indiana Native Dedicates Herself as Consecrated Virgin, Will We Know Each Other In Heaven, and More!">
<meta name="twitter:image" content="http://www.ncregister.com/images/uploads/Consecrated_Virgin_Jennifer_Sergio_Credit_Todays_Catholic.jpg">
<script type="text/javascript">
  var metaUrl = 'http://www.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot',
      metaPath = 'blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot',
      metaTitle = "Indiana Native Dedicates Herself as Consecrated Virgin, Will We Know Each Other In Heaven, and More!",
      metaTags = ['    Tito Edwards  '.trim(), '    Blogs  '.trim()];
  if ("" != '')
    [].push.apply(metaTags, "".split(', '));
</script>

</head>
<body>
  <div id="fb-root"></div>
  <div id="page-container">
    <div id="header-container">
      <div id="header-global-nav">
  <div class="header-left">
    <div class="menu">
      <a class="menu-root" data-menu-id="sections-menu" href="javascript:;" >
        <img alt="menu" src="/css/layout/images/hamburger.png"> Sections
      </a>&nbsp;
      <div id="sections-menu" data-menu-id="sections-menu" class="menu-items">
  <a href="/sections/nation" class="item">Nation</a>
  <a href="/sections/vatican" class="item">Vatican</a>
  <a href="/sections/world" class="item">World</a>
  <a href="/sections/commentary" class="item">Commentary</a>
  <a href="/sections/blog" class="item">Blogs</a>
  <a href="/sections/features" class="item">Features</a>
  <a href="/sections/movies" class="item">Movies</a>
  <a href="/sections/books" class="item">Books</a>
  <a href="/sections/travel" class="item">Travel</a>
  <a href="/sections/radio" class="item">Radio</a>
  <a href="/info/resources1" class="item">Resources</a>
  <a href="/college-guide" class="item">College Guide</a>
</div>

    </div>
    <div class="menu">
      <a href="/"><img alt="menu" src="/css/layout/images/home.png"> Home</a>&nbsp;
    </div>
    <div class="menu">
      <a id="search-menu-root" href="javascript:;"><img alt="search" src="/css/layout/images/lens.png"> Search</a>
      <div id="search-form-container">
        <form id="search-form">
          <input name="q" id="search-site" type="text" autocomplete="off" placeholder="Search NCRegister">
        </form>
      </div>
    </div>
  </div>
  <div class="header-right">
    <div class="menu">
      <a class="menu-root" data-menu-id="advertise-menu" href="http://ewtnadvertising.com" target="_blank">Advertise</a>&nbsp;
      <div id="advertise-menu" data-menu-id="advertise-menu" class="menu-items">
        <a href="http://ewtnadvertising.com/print-advertising/" target="_blank" class="item">Register Print Ads</a>
        <a href="http://ewtnadvertising.com" target="_blank" class="item">EWTN News Digital Ads</a>
        <a href="https://orders.ewtnadvertising.com/" target="_blank" class="item">Order Ads Online</a>
        <a href="http://ewtnadvertising.com/ncregister-com-job-board/" target="_blank" class="item">Post a Job ad</a>
      </div>
    </div>
    <div class="menu">
      <a class="menu-root" data-menu-id="subscriptions-menu" href="/info/subscribe">Subscriptions</a>&nbsp;
      <div id="subscriptions-menu" data-menu-id="subscriptions-menu" class="menu-items">
        <a href="https://sfsdata.com/ncr/Subscribe.aspx?KEY=918MSP" target="_blank" class="item">Subscribe</a>
        <a href="https://sfsdata.com/NCR/GiftR.html?KEY=918GIF" target="_blank" class="item">Give a Gift Subscription</a>
        <a href="/info/bulk-subscriptions" class="item">Discounted Bulk Subscriptions</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Gift Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Payments</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Account Status</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Missed Issue</a>
        <a href="/info/opt-in-popup" class="subscribe-popup item">Daily or Weekly e-Newsletter</a>
      </div>
    </div>
    <a href="https://donate.ncregister.com/p-4-enews-general-fund.aspx?source=N18W" target="_blank">Donate</a>&nbsp;
    <a href="/jobs">Jobs</a>&nbsp;
    <a href="http://www.ewtn.com/cataloguefeatured/" target="_blank">Store</a>
    <a href="http://www.catholicnewsagency.com/?utm_source=NCR%20Header%20Link" target="_blank">CNA</a>
  </div>
  <div class="header-center">
    <a href="//www.facebook.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/facebook.png"></a>
    <a href="//twitter.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/twitter.png"></a>
    <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank"><img alt="search" src="/css/layout/images/rss.png"></a>
    <a href="/info/opt-in-popup" class="subscribe-popup"><img alt="daily update" src="/css/layout/images/newsletter.png"></a>
  </div>
</div>
<div id="header-banner-ad" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('header-banner-ad'); });
  </script>
</div>

<div id="header-logo-header">
  <div id="logo-super">
    <div class="header-left divider"></div>
    <div class="header-right divider"></div>
    <div class="header-center divider-text">A Service of EWTN</div>
  </div>
  
    <div class="header-left header-ad">
      <div id="interior-logo-left" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-left'); });
  </script>
</div>

    </div>
    <div class="header-right header-ad">
      <div id="interior-logo-right" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-right'); });
  </script>
</div>

    </div>
  
  <div id="logo-header">
    
      <div id="logo" class="header-center"><a href="/"><img alt="Register Logo" src="/css/layout/images/ncregister-logo-385x115.png"></a></div>
    
  </div>
</div>


    </div>
    <div id="main-container">
      <div id="main" class="lo-row">
  <div id="main-left" class="lo-cell">
    <div id="main-left-top" class="lo-row">
      <div id="main-left-sidebar" class="lo-cell">
        
          <div>
  <div class="share-count-container">
    <div id="share-count">0</div>
    <div>Shares</div>
  </div>
  <div class="icons">
    <div class="entry">
      <a rel="nofollow" href="/site/email/55577">
        <img class="center-vertical icon" alt="Email" src="/css/layout/images/detail-email.png">
      <a>
      <div class="center-vertical caption"><a rel="nofollow" href="/site/email/55577">Email</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" href="javascript:;" class="share-fb">
        <img class="center-vertical icon" alt="Share" src="/css/layout/images/detail-facebook.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" href="javascript:;" class="share-fb">Share</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" class="share-twitter" href="javascript:;">
        <img class="center-vertical icon" alt="Tweet" src="/css/layout/images/detail-twitter.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-twitter" href="javascript:;">Tweet</a></div>
    </div>
    
      <div class="entry">
        <a class="view-comments-link" rel="nofollow" href="#article-view-comments">
          <img class="center-vertical icon" alt="Comment" src="/css/layout/images/detail-comment.png">
        </a>
        <div class="center-vertical caption"><a class="view-comments-link" rel="nofollow" href="#article-view-comments">Comment</a></div>
      </div>
    
    <div class="entry">
      <a rel="nofollow" class="share-print" href="/site/print/55577" target="_blank">
        <img class="center-vertical icon" alt="Print" src="/css/layout/images/detail-print.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-print" href="/site/print/55577" target="_blank">Print</a></div>
    </div>
  </div>
</div>
<div id="lsb-sticky-ads-marker"></div>
<div id="lsb-sticky-ads">
  <div id="left-sidebar-a" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-a'); });
  </script>
</div>

  <div id="left-sidebar-b" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-b'); });
  </script>
</div>

  <div id="left-sidebar-c" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-c'); });
  </script>
</div>

  <div id="left-sidebar-d" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-d'); });
  </script>
</div>

</div>

        
      </div>
      <div id="main-left-main" class="lo-cell">
        
            
  
  
  
  
  
  
    
    
    
  
      <div class="article-image"><img alt="Click on the Indiana Native Dedicates Herself as Consecrated Virgin link to read more." src="/images/uploads/Consecrated_Virgin_Jennifer_Sergio_Credit_Todays_Catholic.jpg"></div>
    <div class="article-image-caption">Click on the Indiana Native Dedicates Herself as Consecrated Virgin link to read more. </div>
    <div class="article-section">
    <a href="/sections/blog">    Blogs  </a>&nbsp;|&nbsp; Jan. 12, 2018
  </div>
  <div class="article-title">Indiana Native Dedicates Herself as Consecrated Virgin, Will We Know Each Other In Heaven, and More!</div>
      <div class="article-subhead">The Best in Catholic Blogging</div>
    <div class="article-author"><a href="/blog/tito-edwards">    Tito Edwards  </a></div>
    <div class="article-body"><p><a href="https://todayscatholic.org/south-bend-native-dedicates-consecrated-virgin/"><span style="color: #800000;"><strong>Indiana Native Dedicates Herself as Consecrated Virgin</strong></span></a>&nbsp;- Jill Boughton,&nbsp; Today&rsquo;s Catholic (Diocese of Fort Wayne-South Bend)+++</p>

<p><a href="https://www.spiritualdirection.com/2017/11/29/will-we-know-each-other-in-heaven"><span style="color: #800000;"><strong>Will We Know Each Other In Heaven?</strong></span></a>&nbsp;&ndash; Charlie McKinney, Catholic Spiritual Direction</p>

<p><a href="http://www.hprweb.com/2017/11/helping-the-souls-in-purgatory/"><span style="color: #800000;"><strong>Helping the Souls in Purgatory</strong></span></a>&nbsp;&ndash; Fr. Thomas G. Morrow, Homiletic &amp; Pastoral Review</p>

<p><a href="http://www.catholicherald.co.uk/commentandblogs/2017/12/30/the-saint-who-showed-what-true-reform-of-the-church-is-like/"><span style="color: #800000;"><strong>The Saint Who Showed what True Reform of the Church is Like</strong></span></a>&nbsp;&ndash; Francis Phillips, Catholic Herald</p>

<p><a href="http://www.hprweb.com/2017/11/the-mystery-of-hell/"><span style="color: #800000;"><strong>The Mystery of Hell</strong></span></a>&nbsp;&ndash; Brent Withers, Homiletic &amp; Pastoral Review</p>

<p><a href="https://aleteia.org/2017/12/28/pray-this-powerful-novena-to-three-holy-saints-for-the-protection-of-life/"><span style="color: #800000;"><strong>Pray This Powerful Novena to 3 Saints for the Protection of Life</strong></span></a>&nbsp;&ndash; Philip Kosloski, Aleteia</p>

<p><a href="http://www.catholicstand.com/planned-parenthood-birth-control-heresy/" rel="bookmark" title="Permanent Link to Planned Parenthood, Birth Control, and Heresy"><span style="color: #800000;"><strong>Planned Parenthood, Birth Control &amp; Heresy</strong></span></a>&nbsp;&ndash; Birgit Jones, Catholic Stand</p>

<p><a href="http://catholicfundraiser.net/happy-new-year-fundraising-plan/"><span style="color: #800000;"><strong>Happy New Year. . . Now, What&rsquo;s Your Fundraising Plan?</strong></span></a>&nbsp;&ndash; Brice Sokolowski, CatholicFundraiser.net</p>

<p><a href="http://www.integratedcatholiclife.org/2018/01/deacon-bickerstaff-god-chose-mary-for-his-mother/"><span style="color: #800000;"><strong>God Chose Mary to be His Mother</strong></span></a>&nbsp;&ndash; Deacon Mike Bickerstaff, Integrated Catholic Life&trade;</p>

<p><a href="http://wdtprs.com/blog/2017/12/nuntii-latini-finis-transmissioni-latinae-imminebat-non/"><span style="color: #800000;"><strong>Nuntii Latini: Finis Transmissioni Latin&aelig; Imminebat. . .&nbsp;<em>Non</em>!</strong></span></a>&nbsp;&ndash; Fr. Z&rsquo;s Blog</p>

<p><a href="https://www.thecatholicthing.org/2018/01/01/the-glories-of-the-mother-of-god/"><span style="color: #800000;"><strong>The Glories of the Mother of God</strong></span></a>&nbsp;&ndash; Blessed John Henry Newman, The Catholic Thing</p>

<p><a href="http://www.newliturgicalmovement.org/2017/12/what-would-canonization-of-paul-vi-mean.html"><strong><span style="color: #800000;">What Would Canonization of Paul VI Mean for Liturgy &amp; Liturgical Reform</span></strong></a>&nbsp;&ndash; Gregory DiPippo, New Liturgical Movement</p>

<p><a href="http://www.crisismagazine.com/2017/lion-teaches-us-humility"><span style="color: #800000;"><strong>A Lion Teaches Us About Humility</strong></span></a>&nbsp;&ndash; Jonathan B. Coe, Crisis Magazine</p>

<p><a href="https://dwightlongenecker.com/false-gospel-true-gospel/"><span style="color: #800000;"><strong>False Gospel True Gospel</strong></span></a>&nbsp;&ndash; Fr. Dwight Longenecker</p>

<p><a href="http://www.catholicworldreport.com/2017/12/30/on-non-infallible-teachings-of-the-magisterium-and-the-meaning-of-obsequium-religiosum/"><span style="color: #800000;"><strong>Non-Infallible Teachings of Magisterium &amp; Meaning of&nbsp;</strong></span><em><span style="color: #800000;"><strong>Obsequium Religiosum</strong></span></em></a>&nbsp;&ndash; Dr. Jeremy Holmes, The Catholic World Report</p>

<p><a href="http://www.catholicculture.org/commentary/the-city-gates.cfm?id=1538"><span style="color: #800000;"><strong>A Prayer for Europe</strong></span></a>&nbsp;&ndash; Phil Lawler, Catholic Culture</p>

<p>For the Most Recent in &#39;The Best in Catholic Blogging&#39; click on&nbsp;<strong><a href="http://bigpulpit.com/" rel="noopener" target="_blank">&#9769; Big Pulpit &#9769;</a></strong>.</p></div>
    

        
        <div id="article-footer-ad" class="ad-slot article-footer">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('article-footer-ad'); });
  </script>
</div>

        
          <script type="text/javascript">var noMoreComments;</script>
<a name="article-view-comments"></a>
<div id="comments-hidden" class="article-view-comments view-comments-link">View Comments</div>
<div id="comments-shown" class="article-comments-container">
  <div class="article-comments-header lo-row">
    <div class="heading lo-cell">Comments</div>
    <div class="join-link lo-cell"><a href="#article-join-discussion">Join the Discussion</a></div>
  </div>
  <div class="article-comments">
    
  </div>
  <a name="article-join-discussion"></a>
  <div class="article-more-comments">
    <div class="instructions-header">Join the Discussion</div>
    <div class="instructions">
      We encourage a lively and honest discussion of our content. We ask that charity guide your words.
        By submitting this form, you are agreeing to our <a href="/info/discussion-guidelines">discussion guidelines</a>.
        Comments are published at our discretion. We won't publish comments that lack charity, are off topic, or are more than 400 words.
        Thank you for keeping this forum thoughtful and respectful.
    </div>
    <form id="comment_form" method="post" action="http://www.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="http://www.ncregister.com/blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot" />
<input type="hidden" name="URI" value="blog/tito-edwards/indiana-native-dedicates-herself-as-consecrated-virgin-will-we-know-each-ot" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="XID" value="" />
<input type="hidden" name="entry_id" value="55577" />
<input type="hidden" name="site_id" value="1" />
</div>

 
                  
      <div class="form-fields">
                  <p>Name:<br /><input class="text" type="text" name="name" value="" /></p>
          <p>Email:<br /><input class="text" type="email" name="email" value="" /></p>
                <p><input type="hidden" name="title" value="" />
          Write your comment:<br />
          <textarea name="comment" cols="" rows="10" wrap="virtual" class="input_element"></textarea>
          <input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments.
        </p>
                  <p class="captcha" >Please enter the word you see in the image below:<br />
            <input class="text" type="text" name="captcha" value="" maxlength="20" /><br />
            <img src="http://www.ncregister.com/images/captchas/1515782100.3572.jpg" width="140" height="30" style="border:0;" alt=" " /></p>
                <p>
          <input type="submit" class="button" name="submit" value="Submit" />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
          <input type="reset" class="button" name="reset" value="Clear" />
        </p>
        <input type="hidden" name="save_info" value="yes" />      </div>
    </form>
  </div>
  <div class="article-no-more-comments">
    Comments are no longer being accepted on this article.
  </div>
</div>

        
      </div>
    </div>
    <div id="main-left-bottom">
    </div>
  </div>
  <div id="main-right" class="lo-cell">
    
      <div id="right-sidebar-a" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-a'); });
  </script>
</div>

<div id="blogger-bio">
  
    <div class="name"><a href="/blog/tito-edwards">Tito Edwards</a></div>
    <div class="image"><img src="/images/sized/images/member_photos/photo_8608-85x85.png" width="85" height="85"  alt="Tito Edwards" /></div>
    <div class="text"><p>Tito Edwards manages Catholic websites for the new evangelization that Pope John Paul II and then Cardinal Ratzinger, now Pope Benedict XVI, has asked for in the third millennium.</p>

<p>After a lifetime of living a nominal Catholic life, he reverted completely to his childhood faith that began on the eve of the funeral of Pope John Paul II.</p>

<p>He publishes <a href="http://bigpulpit.com/">Big Pulpit</a>, <a href="http://CatholicStand.com/">Catholic Stand</a>, <a href="http://IgnitumToday.com/">Ignitum Today</a>, and <a href="http://the-american-catholic.com/">The American Catholic</a>.</p></div>
    <div class="clear"></div>
  
</div>

<div id="trending">
  <h1>Trending</h1>
  <div class="trending-panel">
     
      <div id="trending-entry-1" class="trending-entry lo-row">
        <div class="count lo-cell">
          1.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/apologist-warns-catholics-about-dangers-of-mindfulness">Apologist Warns Catholics About Dangers of &#8216;Mindfulness&#8217;</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/apologist-warns-catholics-about-dangers-of-mindfulness">
                <img src="/images/sized/images/editorial/rsz_brinkmann-85x85.jpg" width="85" height="85"  alt="Apologist Warns Catholics About Dangers of &#8216;Mindfulness&#8217;" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-2" class="trending-entry lo-row">
        <div class="count lo-cell">
          2.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/altar-rail-puts-communicants-on-right-track">Altar Rail Puts Communicants on Right Track</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/altar-rail-puts-communicants-on-right-track">
                <img src="/images/sized/images/editorial/1224_0004_B4-85x85.jpg" width="85" height="85"  alt="Altar Rail Puts Communicants on Right Track" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-3" class="trending-entry lo-row">
        <div class="count lo-cell">
          3.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/pattyknap/a-surprising-pro-life-message-from-eminem">A Surprising Pro-Life Message From Eminem</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/pattyknap/a-surprising-pro-life-message-from-eminem">
                <img src="/images/sized/images/uploads/Knap-RAPPER2-85x85.jpg" width="85" height="85"  alt="A Surprising Pro-Life Message From Eminem" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-4" class="trending-entry lo-row">
        <div class="count lo-cell">
          4.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/rocky-mountain-low-the-downside-of-legalized-marijuana">Rocky Mountain Low: The Downside of Legalized Marijuana</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/rocky-mountain-low-the-downside-of-legalized-marijuana">
                <img src="/images/sized/images/editorial/rsz_marijuana-2754249_1280_pixabay-85x85.png" width="85" height="85"  alt="Rocky Mountain Low: The Downside of Legalized Marijuana" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-5" class="trending-entry lo-row">
        <div class="count lo-cell">
          5.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/jimmy-akin/is-it-possible-to-pray-across-time">Is It Possible to Pray Across Time?</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/jimmy-akin/is-it-possible-to-pray-across-time">
                <img src="/images/sized/images/uploads/Padre_Pio_CNA_World_Catholic_News_CNA_1_5_16-85x85.jpg" width="85" height="85"  alt="Is It Possible to Pray Across Time?" />
            </a>
          </div>
              </div>
              <div id="right-sidebar-b" class="ad-slot middle">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-b'); });
  </script>
</div>
           
      <div id="trending-entry-6" class="trending-entry lo-row">
        <div class="count lo-cell">
          6.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/edward-pentin/cardinal-parolin-amoris-represents-new-paradigm-new-spirit-new-approach">Cardinal Parolin: Amoris Laetitia Represents New Paradigm, Spirit and Approach</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/edward-pentin/cardinal-parolin-amoris-represents-new-paradigm-new-spirit-new-approach">
                <img src="/images/sized/images/uploads/Cardinal_Pietro_Parolin_Credit_Saeima_Wikipedia_CC_20_CNA-85x85.jpg" width="85" height="85"  alt="Cardinal Parolin: Amoris Laetitia Represents New Paradigm, Spirit and Approach" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-7" class="trending-entry lo-row">
        <div class="count lo-cell">
          7.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/catholics-mourn-loss-of-roy-rohter-co-founder-of-california-academy">Mudslide Claims Life of California Academy&#8217;s Catholic Founder</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/catholics-mourn-loss-of-roy-rohter-co-founder-of-california-academy">
                <img src="/images/sized/images/editorial/Rohter_main_pic_from_school-85x85.jpg" width="85" height="85"  alt="Mudslide Claims Life of California Academy&#8217;s Catholic Founder" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-8" class="trending-entry lo-row">
        <div class="count lo-cell">
          8.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/edward-pentin/three-bishops-issue-profession-of-truth-about-sacramental-marriage">Three Bishops Issue Profession of Truth About Sacramental Marriage</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/edward-pentin/three-bishops-issue-profession-of-truth-about-sacramental-marriage">
                <img src="/images/sized/images/uploads/IMG_5604-85x85.jpg" width="85" height="85"  alt="Three Bishops Issue Profession of Truth About Sacramental Marriage" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-9" class="trending-entry lo-row">
        <div class="count lo-cell">
          9.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/us-bishops-set-course-on-liturgical-translations">US Bishops Set Course on Liturgical Translations</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/us-bishops-set-course-on-liturgical-translations">
                <img src="/images/sized/images/editorial/katherine-hanlon-417923_unsplash_Bible_and_crucifix-85x85.jpg" width="85" height="85"  alt="US Bishops Set Course on Liturgical Translations" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-10" class="trending-entry lo-row">
        <div class="count lo-cell">
          10.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/pope-francis-j.r.r.-tolkien-and-the-lords-prayer">Pope Francis, J.R.R. Tolkien and the Lord&#8217;s Prayer</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/pope-francis-j.r.r.-tolkien-and-the-lords-prayer">
                <img src="/images/sized/images/editorial/ring-1671094_1280_lordoftherings_ring-85x85.jpg" width="85" height="85"  alt="Pope Francis, J.R.R. Tolkien and the Lord&#8217;s Prayer" />
            </a>
          </div>
              </div>
                        
  </div>
</div>

<div id="right-sidebar-c" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-c'); });
  </script>
</div>

<div class="ad-slot bottom">
  <a href="http://revive.registerticket.com/revive/www/delivery/ck.php?zoneid=71" target="_blank">
    <img src="http://revive.registerticket.com/revive/www/delivery/avw.php?zoneid=71">
  </a>
</div>

<div id="right-sidebar-d" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-d'); });
  </script>
</div>


    
  </div>
</div>
<div id="bottom-banner-ad" class="ad-slot main-center">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('bottom-banner-ad'); });
  </script>
</div>


    </div>
    <div id="footer-container">
      <div class="footer-logo">
  <div><img alt="Register Logo" src="/css/layout/images/ncregister100k.png"></div>
</div>
<div class="footer-text">
  <div class="footer-links">
    <div>
      <a href="/">Home</a>
      <a href="/info/about_the_register">About Us</a>
      <a href="/info/subscribe">Subscriptions</a>
      <a href="https://donate.ncregister.com/p-4-enews-general-fund.aspx?source=N18W" target="_blank">Donate</a>
      <a href="//ewtnadvertising.com" target="_blank">Advertise</a>
      <a href="/PR">Press Releases</a>
      <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank">RSS Daily Register</a>
      <a href="//feeds.feedburner.com/NationalCatholicRegisterBloggers" target="_blank">RSS Bloggers</a>
      <a href="/info/contacts">Contact</a>
      <a href="/jobs">Jobs</a>
    </div>
    <div>
      <a href="/info/opt-in-popup" class="subscribe-popup">Sign up for our E-Newsletter</a>
      <a href="https://www.facebook.com/NCRegister" target="_blank">Facebook</a>
      <a href="https://twitter.com/NCRegister" target="_blank">Twitter</a>
      <a href="https://www.youtube.com/NCRegister" target="_blank">YouTube</a>
      <a href="//instagram.com/ncregister/" target="_blank">Instagram</a>
      <a href="https://play.google.com/store/apps/details?id=com.ewtn.ncrreader&amp;hl=en" target="_blank">Android App</a>
      <a href="https://itunes.apple.com/us/app/national-catholic-register/id736212445?mt=8" target="_blank">iOS App</a>
      <a href="/info/ncr-privacy-policy">Privacy Policy</a>
    </div>
  </div>
  <div class="footer-fine-print">
    Copyright &copy; 2018 EWTN News, Inc.&nbsp; All rights reserved.<br>
    Reproduction of material from this website without written permission, or unlicensed commercial use<br>
    or monetization of <em>National Catholic Register</em> RSS feeds is strictly prohibited.<br>
    Accessed from 52.90.98.148
  </div>
</div>

    </div>
  </div>
  <div id="fixed-bottom-banner">
    <div id="fixed-bottom-banner-ad" class="ad-slot fixed-bottom-banner">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('fixed-bottom-banner-ad'); });
  </script>
</div>

  </div>
  <script type="text/javascript" src="/js/jquery.fancybox.pack.js"></script>
<script type="text/javascript" src="/js/menu.js"></script>
<script type="text/javascript" src="/js/global.js"></script>
<script type='text/javascript'>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 4055;
  _sf_async_config.domain = 'ncregister.com';
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  (function() {
      function loadChartbeat() {
          window._sf_endpt = (new Date()).getTime();
          var e = document.createElement('script');
          e.setAttribute('language', 'javascript');
          e.setAttribute('type', 'text/javascript');
          e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
          document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
          loadChartbeat : function() {
              oldonload();
              loadChartbeat();
          };
  })();
</script>
<script type="text/javascript">
  function suppressOptinPopup() {
    setCookie('op-off', new Date().getTime(), 45);
    jQuery.fancybox.close();
  }

  function suppressDonatePopup() {
    setCookie('dp-off', new Date().getTime(), 45);
    jQuery.fancybox.close();
  }

  function showOptinPopup(now) {
    var opDays = 7;
    setCookie('op-off', now, opDays);
    jQuery.fancybox.open({
      href: '/info/opt-in-popup/auto',
      padding: 0,
      type: 'iframe',
      closeBtn: false
    });
  }

  function showDonatePopup(now) {
    var dpDays = 7;
    setCookie('dp-off', now, dpDays);
    jQuery.fancybox.open({
      href: '/info/donate-popup',
      padding: 0,
      type: 'iframe',
      closeBtn: false
    });
  }

  function showInterstitialPopup() {
    jQuery.fancybox.open({
      href: '/message',
      type: 'iframe',
      padding: 0,
      width: 800,
      height: 625,
      fitToView: false,
      autoSize: false
    });
  }

  function handleOrdinary() {
    var now = new Date().getTime(),
        oneDay = 86400000,
        dpCountDays = 1,
        dpThresh = 2,
        dpOff = getCookie('dp-off'),
        opOff = getCookie('op-off'),
        dpCount = getCookie('dp-count');
    dpOff = dpOff == '' ? null : parseInt(dpOff);
    opOff = opOff == '' ? null : parseInt(opOff);
    dpCount = dpCount == '' ? 0 : parseInt(dpCount);
    setCookie('dp-count', dpCount + 1, dpCountDays);

    if (!dpOff && opOff && (now - opOff) > oneDay && dpCount > dpThresh)
      showDonatePopup(now);
    if (!opOff && (!dpOff || (now - dpOff) > oneDay))
      showOptinPopup(now);
  }

  function handleSeasonal() {
    if (getCookie('ip-off') != '')
      return;

    var ipDays = 2,
        ipCount = getCookie('ip-count');
    ipCount = ipCount == '' ? 0 : parseInt(ipCount);

    setCookie('ip-off', true, ipDays);
    setCookie('ip-count', (ipCount + 1) % 3, ipDays + 1);

    if (ipCount == 2)
      showOptinPopup(new Date().getTime());
    else
      showInterstitialPopup();
  }

  var seasonalOn = '#2016-12-12T05:00Z|2017-04-14T05:00Z';
  if (seasonalOn.startsWith('#'))
    seasonalOn = false;
  else {
    var parts = seasonalOn.split('|'),
        now = new Date(),
        isStart = new Date(parts[0]),
        isStop = new Date(parts[1]);
    seasonalOn = isStart <= now && now < isStop;
  }
  if (seasonalOn)
    handleSeasonal();
  else
    handleOrdinary();
</script>
<script type="text/javascript">
  (function() {
  function async_load(script_url){
  var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
  var s = document.createElement('script'); s.src = protocol + script_url;
  var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
  }
  bm_website_code = '720BD26B5B3D490F';
  jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
  jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
  })();
</script>

  <script type="text/javascript" src="/js/comments.js"></script>

  <script type="text/javascript" src="/js/embedded-article-ad.js"></script>

<script type="text/javascript" src="//connect.facebook.net/en_US/all.js"></script>
<script type="text/javascript">
  var fbWait = [ 3000, 9000 ],
      fbShareRetry = 0;
  function getFbShares() {
    $.ajax({
      url: 'http://graph.facebook.com/?fields=share&id=' + encodeURIComponent(metaUrl),
      dataType: 'json',
      success: function(data) {
        if (data.share) {
          $('#share-count').html(data.share.share_count);
          $('.share-count-container').show();
        } else if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      },
      error: function(resp) {
        if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      }
    });
  }
  getFbShares();

  $('.share-fb').click(function() {
    FB.ui({
      method: 'share',
      display: 'popup',
      href: metaUrl
    });
  });
  $('.share-print').click(function(e) {
    window.open($(e.target).attr('href'), 'Print', 'width=600,height=550,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('.share-twitter').click(function(e) {
    var url = 'https://twitter.com/intent/tweet?hashtags=NCRegister&text=' + encodeURIComponent(metaTitle) + '&url=' + encodeURIComponent(metaUrl)
    window.open(url, 'Tweet', 'width=600,height=400,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('#main-left-main .article-body a').attr('target', '_blank');

  function stickAdsInViewport() {
    var markerBR = $('#lsb-sticky-ads-marker')[0].getBoundingClientRect(),
        $ads = $('#lsb-sticky-ads'),
        adsBR = $ads[0].getBoundingClientRect(),
        mainLeftBR = $('#main-left')[0].getBoundingClientRect();
    if (mainLeftBR.left < 0) {
      $ads.removeClass('sticky top bottom');
      return;
    }
    if ($ads.hasClass('sticky top')) {
      if (adsBR.bottom > mainLeftBR.bottom) {
        $ads.removeClass('top').addClass('bottom');
      } else if (markerBR.top > 12) {
        $ads.removeClass('sticky top');
      }
    } else if ($ads.hasClass('sticky bottom')) {
      if (adsBR.top > 12) {
        $ads.removeClass('bottom').addClass('top');
      }
    } else {
      if (mainLeftBR.bottom - adsBR.height < 12) {
        $ads.addClass('sticky bottom');
      } else if (markerBR.top < 12) {
        $ads.addClass('sticky top');
      }
    }
  }

  $(stickAdsInViewport);
  $(window).on('scroll', stickAdsInViewport);
</script>

</body>
</html>


  
  




