  <!doctype html>
<html>
<head>
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.3/jquery.min.js"></script>
  <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KB6S87');</script>
<!-- End Google Tag Manager -->
<script type="text/javascript">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</script>

  <script type='text/javascript'>var _sf_startpt=(new Date()).getTime(); // Chartbeat</script>
  <link rel="stylesheet" href="/css/layout/global.css">
  <link rel="stylesheet" href="/css/layout/jquery.fancybox.css">
  <link href="https://fonts.googleapis.com/css?family=Merriweather:300,300i,400,400i|Roboto:300,300i,400,400i,500,500i" rel="stylesheet">
  <link rel="stylesheet" href="/css/layout/detail.css">

  <title>Don&#8217;t Shy from Adoration,Paschal Blue Moon on Vigil of Easter, Death is Not the End, and More!</title>
<link rel="canonical" href="http://www.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th">
<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th">
<meta property="fb:pages" content="64182915497">
<meta property="fb:app_id" content="347756275321330">
<meta property="fb:admins" content="1477213784">
<meta property="og:type" content="article">
<meta property="og:site_name" content="National Catholic Register">
<meta property="og:url" content="http://www.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th">
<meta property="og:description" content="The Best in Catholic Blogging">
<meta property="og:title" content="Don&#8217;t Shy from Adoration,Paschal Blue Moon on Vigil of Easter, Death is Not the End, and More!">
<meta property="og:image" content="http://www.ncregister.com/images/uploads/Charles_II_of_Spain_in_Adoration_of_the_Holy_Eucharist.png">
<meta property="og:image:width" content="460">
<meta property="og:image:height" content="300">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@NC_Register">
<meta name="twitter:url" content="http://www.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th">
<meta name="twitter:description" content="The Best in Catholic Blogging">
<meta name="twitter:title" content="Don&#8217;t Shy from Adoration,Paschal Blue Moon on Vigil of Easter, Death is Not the End, and More!">
<meta name="twitter:image" content="http://www.ncregister.com/images/uploads/Charles_II_of_Spain_in_Adoration_of_the_Holy_Eucharist.png">
<script type="text/javascript">
  var metaUrl = 'http://www.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th',
      metaPath = 'blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th',
      metaTitle = "Don&#8217;t Shy from Adoration,Paschal Blue Moon on Vigil of Easter, Death is Not the End, and More!",
      metaTags = ['    Tito Edwards  '.trim(), '    Blogs  '.trim()];
  if ("" != '')
    [].push.apply(metaTags, "".split(', '));
</script>

</head>
<body>
  <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KB6S87"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

  <div id="fb-root"></div>
  <div id="page-container">
    <div id="header-container">
      <div id="header-global-nav">
  <div class="header-left">
    <div class="menu">
      <a class="menu-root" data-menu-id="sections-menu" href="javascript:;" >
        <img alt="menu" src="/css/layout/images/hamburger.png"> Sections
      </a>&nbsp;
      <div id="sections-menu" data-menu-id="sections-menu" class="menu-items">
  <a href="/sections/nation" class="item">Nation</a>
  <a href="/sections/vatican" class="item">Vatican</a>
  <a href="/sections/world" class="item">World</a>
  <a href="/sections/commentary" class="item">Commentary</a>
  <a href="/sections/blog" class="item">Blogs</a>
  <a href="/sections/features" class="item">Features</a>
  <a href="/sections/movies" class="item">Movies</a>
  <a href="/sections/books" class="item">Books</a>
  <a href="/sections/travel" class="item">Travel</a>
  <a href="/sections/radio" class="item">Radio</a>
  <a href="/info/resources1" class="item">Resources</a>
  <a href="/college-guide" class="item">College Guide</a>
</div>

    </div>
    <div class="menu">
      <a href="/"><img alt="menu" src="/css/layout/images/home.png"> Home</a>&nbsp;
    </div>
    <div class="menu">
      <a id="search-menu-root" href="javascript:;"><img alt="search" src="/css/layout/images/lens.png"> Search</a>
      <div id="search-form-container">
        <form id="search-form">
          <input name="q" id="search-site" type="text" autocomplete="off" placeholder="Search NCRegister">
        </form>
      </div>
    </div>
  </div>
  <div class="header-right">
    <div class="menu">
      <a class="menu-root" data-menu-id="advertise-menu" href="http://ewtnadvertising.com" target="_blank">Advertise</a>&nbsp;
      <div id="advertise-menu" data-menu-id="advertise-menu" class="menu-items">
        <a href="http://ewtnadvertising.com/print-advertising/" target="_blank" class="item">Register Print Ads</a>
        <a href="http://ewtnadvertising.com" target="_blank" class="item">EWTN News Digital Ads</a>
        <a href="https://orders.ewtnadvertising.com/" target="_blank" class="item">Order Ads Online</a>
        <a href="http://ewtnadvertising.com/ncregister-com-job-board/" target="_blank" class="item">Post a Job ad</a>
      </div>
    </div>
    <div class="menu">
      <a class="menu-root" data-menu-id="subscriptions-menu" href="/info/subscribe">Subscriptions</a>&nbsp;
      <div id="subscriptions-menu" data-menu-id="subscriptions-menu" class="menu-items">
        <a href="https://sfsdata.com/ncr/Subscribe.aspx?KEY=918MSP" target="_blank" class="item">Subscribe</a>
        <a href="https://sfsdata.com/NCR/GiftR.html?KEY=918GIF" target="_blank" class="item">Give a Gift Subscription</a>
        <a href="/info/bulk-subscriptions" class="item">Discounted Bulk Subscriptions</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Renew Your Gift Subscription</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Payments</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Account Status</a>
        <a href="https://sfsdata.com/subscriberservices/AccountStart.html?PUB=NCR" target="_blank" class="item">Missed Issue</a>
        <a href="/info/opt-in-popup" class="subscribe-popup item">Daily or Weekly e-Newsletter</a>
      </div>
    </div>
    <a href="https://donate.ncregister.com/p-4-enews-general-fund.aspx?source=N18W" target="_blank">Donate</a>&nbsp;
    <a href="/jobs">Jobs</a>&nbsp;
    <a href="http://www.ewtn.com/cataloguefeatured/" target="_blank">Store</a>
    <a href="http://www.catholicnewsagency.com/?utm_source=NCR%20Header%20Link" target="_blank">CNA</a>
  </div>
  <div class="header-center">
    <a href="//www.facebook.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/facebook.png"></a>
    <a href="//twitter.com/NCRegister" target="_blank"><img alt="menu" src="/css/layout/images/twitter.png"></a>
    <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank"><img alt="search" src="/css/layout/images/rss.png"></a>
    <a href="/info/opt-in-popup" class="subscribe-popup"><img alt="daily update" src="/css/layout/images/newsletter.png"></a>
  </div>
</div>
<div id="header-banner-ad" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('header-banner-ad'); });
  </script>
</div>

<div id="header-logo-header">
  <div id="logo-super">
    <div class="header-left divider"></div>
    <div class="header-right divider"></div>
    <div class="header-center divider-text">A Service of EWTN</div>
  </div>
  
    <div class="header-left header-ad">
      <div id="interior-logo-left" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-left'); });
  </script>
</div>

    </div>
    <div class="header-right header-ad">
      <div id="interior-logo-right" class="ad-slot header">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('interior-logo-right'); });
  </script>
</div>

    </div>
  
  <div id="logo-header">
    
      <div id="logo" class="header-center"><a href="/"><img alt="Register Logo" src="/css/layout/images/ncregister-logo-385x115.png"></a></div>
    
  </div>
</div>


    </div>
    <div id="main-container">
      <div id="main" class="lo-row">
  <div id="main-left" class="lo-cell">
    <div id="main-left-top" class="lo-row">
      <div id="main-left-sidebar" class="lo-cell">
        
          <div>
  <div class="share-count-container">
    <div id="share-count">0</div>
    <div>Shares</div>
  </div>
  <div class="icons">
    <div class="entry">
      <a rel="nofollow" href="/site/email/56395">
        <img class="center-vertical icon" alt="Email" src="/css/layout/images/detail-email.png">
      <a>
      <div class="center-vertical caption"><a rel="nofollow" href="/site/email/56395">Email</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" href="javascript:;" class="share-fb">
        <img class="center-vertical icon" alt="Share" src="/css/layout/images/detail-facebook.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" href="javascript:;" class="share-fb">Share</a></div>
    </div>
    <div class="entry">
      <a rel="nofollow" class="share-twitter" href="javascript:;">
        <img class="center-vertical icon" alt="Tweet" src="/css/layout/images/detail-twitter.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-twitter" href="javascript:;">Tweet</a></div>
    </div>
    
      <div class="entry">
        <a class="view-comments-link" rel="nofollow" href="#article-view-comments">
          <img class="center-vertical icon" alt="Comment" src="/css/layout/images/detail-comment.png">
        </a>
        <div class="center-vertical caption"><a class="view-comments-link" rel="nofollow" href="#article-view-comments">Comment</a></div>
      </div>
    
    <div class="entry">
      <a rel="nofollow" class="share-print" href="/site/print/56395" target="_blank">
        <img class="center-vertical icon" alt="Print" src="/css/layout/images/detail-print.png">
      </a>
      <div class="center-vertical caption"><a rel="nofollow" class="share-print" href="/site/print/56395" target="_blank">Print</a></div>
    </div>
  </div>
</div>
<div id="lsb-sticky-ads-marker"></div>
<div id="lsb-sticky-ads">
  <div id="left-sidebar-a" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-a'); });
  </script>
</div>

  <div id="left-sidebar-b" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-b'); });
  </script>
</div>

  <div id="left-sidebar-c" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-c'); });
  </script>
</div>

  <div id="left-sidebar-d" class="ad-slot detail-lsb">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('left-sidebar-d'); });
  </script>
</div>

</div>

        
      </div>
      <div id="main-left-main" class="lo-cell">
        
            
  
  
  
  
  
  
    
    
    
  
      <div class="article-image"><img alt="Charles II of Spain in Adoration of the Holy Eucharist" src="/images/uploads/Charles_II_of_Spain_in_Adoration_of_the_Holy_Eucharist.png"></div>
    <div class="article-image-caption">Charles II of Spain in Adoration of the Holy Eucharist </div>
    <div class="article-section">
    <a href="/sections/blog">    Blogs  </a>&nbsp;|&nbsp; Mar. 31, 2018
  </div>
  <div class="article-title">Don&#8217;t Shy from Adoration,Paschal Blue Moon on Vigil of Easter, Death is Not the End, and More!</div>
      <div class="article-subhead">The Best in Catholic Blogging</div>
    <div class="article-author"><a href="/blog/tito-edwards">    Tito Edwards  </a></div>
    <div class="article-body"><p><a href="https://pelicansbreast.com/2018/03/15/dont-shy-from-adoration-because-you-get-distracted-in-prayer-take-your-cares-to-your-lord/"><span style="color: #800000;"><strong>Don&rsquo;t Shy from Adoration Because You Get Distracted in Prayer &ndash; Take Your Cares to Your&nbsp;Lord!</strong></span></a>&nbsp;- Vicki Burbach, Pelican&rsquo;s Breast+++</p>

<p><a href="http://wdtprs.com/blog/2018/03/2018-paschal-blue-moon-on-vigil-of-easter-and-more-moon-stuff/"><strong><span style="color: #800000;">2018 Paschal Blue Moon on Vigil of Easter &amp; More Moon Stuff</span></strong></a>&nbsp;&ndash; Fr. Z&rsquo;s Blog</p>

<p><a href="http://www.ignitumtoday.com/2018/03/15/death-is-not-the-end/" rel="bookmark" title="Permanent Link to Death is Not the End"><span style="color: #800000;"><strong>Death is Not the End</strong></span></a>&nbsp;&ndash; Elizabeth Jean Seah, Ignitum Today</p>

<p><a href="https://www.catholic.com/magazine/online-edition/does-god-pick-the-pope"><strong><span style="color: #800000;">Does God Pick the Pope?</span></strong></a>&nbsp;&ndash; Jimmy Akin, Catholic Answers Magazine</p>

<p><a href="https://dwightlongenecker.com/why-do-we-call-the-mass-a-sacrifice/"><span style="color: #800000;"><strong>Why Do We Call the Mass a &ldquo;Sacrifice&rdquo;?</strong></span></a>&nbsp;&ndash; Fr. Dwight Longenecker</p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="https://churchpop.com/2018/03/26/13-amazing-catholic-scientists-every-catholic-needs-to-know/"><strong><span style="color: #800000;">13 Amazing Catholic Scientists Every Catholic Needs to Know!</span></strong></a>&nbsp;&ndash; Church<em>Pop</em></span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://www.catholicstand.com/self-help-self-diagnose-bible-church/" rel="bookmark" title="Permanent Link to Self-Help, Self-Diagnose, the Bible and the Church"><span style="color: #800000;"><strong>Self-Help, Self-Diagnose, the Bible &amp; the Church</strong></span></a>&nbsp;&ndash; Brandon Schild, Catholic Stand</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="https://the-american-catholic.com/2018/03/26/screen-pilates-gary-oldham/"><strong><span style="color: #800000;">Silver Screen Pontius Pilates: Gary Oldman</span></strong></a>&nbsp;&ndash; Donald R. McClarey J.D., The American Catholic</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://www.catholicworldreport.com/2018/03/26/humanae-vitae-and-the-catholic-church-in-england-signs-of-hope/"><span style="color: #800000;"><strong><em>Humanae Vitae</em>&nbsp;&amp; the Catholic Church in England: Signs of Hope</strong></span></a>&nbsp;&ndash; Piers Shepherd, The Catholic World Report</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://www.catholicherald.co.uk/issues/march-16th-2018/the-unlikely-rise-of-jacob-rees-mogg/"><strong><span style="color: #800000;">The Unlikely Rise of Jacob Rees-Mogg</span></strong></a>&nbsp;&ndash; David Oldroyd-Bolt, Catholic Herald</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="https://www.spiritualdirection.com/2018/03/22/should-i-still-go-to-confession-if-i-have-nothing-to-confess"><span style="color: #800000;"><strong>Should I Still Go to Confession If I Have Nothing to Confess?</strong></span></a>&nbsp;&ndash; Fr. John Bartunek L.C., Catholic Spiritual Direction</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://www.catholicstand.com/our-frail-love-is-surcharged-with-christs-mystical-love/" rel="bookmark" title="Permanent Link to Our Frail Love is Surcharged With&nbsp;Christ’s Mystical Love"><strong><span style="color: #800000;">Our Frail Love is Surcharged with&nbsp;Christ&rsquo;s Mystical Love</span></strong></a>&nbsp;&ndash; David Torkington, Catholic Stand</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="https://www.romancatholicman.com/generational-blessing/"><span style="color: #800000;"><strong>Generational Blessing</strong></span></a>&nbsp;&ndash; Fr. Richard Heilman, Roman Catholic Man</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://www.vaticannews.va/en/vatican-city/news/2018-03/document-pre-synodal-meeting-young-people.html"><strong><span style="color: #800000;">Document of Pre-Synodal Meeting of Young People Released</span></strong></a>&nbsp;&ndash; Linda Bordoni, Vatican News</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://blog.adw.org/2018/03/new-movie-paul-apostle-christ/" rel="bookmark" title="Permanent Link to A New Movie: Paul, Apostle of Christ"><span style="color: #800000;"><strong>A New Movie: Paul, Apostle of Christ</strong></span></a>&nbsp;&ndash; Msgr. Charles Pope, Community in Mission</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="https://aleteia.org/2018/03/27/enjoy-banking-at-a-credit-union-thank-a-priest/"><strong><span style="color: #800000;">Enjoy &ldquo;Banking&rdquo; at a Credit Union? Thank a Priest</span></strong></a>&nbsp;&ndash; John Burger, Aleteia</span></span></p>

<p><span class="meta_author post-author vcard"><span class="fn"><a href="http://www.liturgicalartsjournal.com/2018/03/sacristy-tips-making-paschal-candle.html"><span style="color: #800000;"><strong>Sacristy Tips: Making Paschal Candle Incense Grains</strong></span></a>&nbsp;&ndash; Richard Hawker, Liturgical Arts Journal </span></span></p>

<p>For the Most Recent in &#39;The Best in Catholic Blogging&#39; click on&nbsp;<strong><a href="http://bigpulpit.com/" rel="noopener" target="_blank"><span style="color: #3366ff;"><span style="color: #ff0000;">&#9769;</span> Big Pulpit <span style="color: #ff0000;">&#9769;</span></span></a>.</strong></p></div>
    

        
        <div id="article-footer-ad" class="ad-slot article-footer">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('article-footer-ad'); });
  </script>
</div>

        
          <script type="text/javascript">var noMoreComments;</script>
<a name="article-view-comments"></a>
<div id="comments-hidden" class="article-view-comments view-comments-link">View Comments</div>
<div id="comments-shown" class="article-comments-container">
  <div class="article-comments-header lo-row">
    <div class="heading lo-cell">Comments</div>
    <div class="join-link lo-cell"><a href="#article-join-discussion">Join the Discussion</a></div>
  </div>
  <div class="article-comments">
    
  </div>
  <a name="article-join-discussion"></a>
  <div class="article-more-comments">
    <div class="instructions-header">Join the Discussion</div>
    <div class="instructions">
      We encourage a lively and honest discussion of our content. We ask that charity guide your words.
        By submitting this form, you are agreeing to our <a href="/info/discussion-guidelines">discussion guidelines</a>.
        Comments are published at our discretion. We won't publish comments that lack charity, are off topic, or are more than 400 words.
        Thank you for keeping this forum thoughtful and respectful.
    </div>
    <form id="comment_form" method="post" action="http://www.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="http://www.ncregister.com/blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th" />
<input type="hidden" name="URI" value="blog/tito-edwards/dont-shy-from-adorationpaschal-blue-moon-on-vigil-of-easter-death-is-not-th" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="XID" value="" />
<input type="hidden" name="entry_id" value="56395" />
<input type="hidden" name="site_id" value="1" />
</div>

 
                  
      <div class="form-fields">
                  <p>Name:<br /><input class="text" type="text" name="name" value="" /></p>
          <p>Email:<br /><input class="text" type="email" name="email" value="" /></p>
                <p><input type="hidden" name="title" value="" />
          Write your comment:<br />
          <textarea name="comment" cols="" rows="10" wrap="virtual" class="input_element"></textarea>
          <!-- <input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments. -->
        </p>
                  <p class="captcha" >Please enter the word you see in the image below:<br />
            <input class="text" type="text" name="captcha" value="" maxlength="20" /><br />
            <img src="http://www.ncregister.com/images/captchas/1522478893.0925.jpg" width="140" height="30" style="border:0;" alt=" " /></p>
                <p>
          <input type="submit" class="button" name="submit" value="Submit" />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
          <input type="reset" class="button" name="reset" value="Clear" />
        </p>
        <input type="hidden" name="save_info" value="yes" />      </div>
    </form>
  </div>
  <div class="article-no-more-comments">
    Comments are no longer being accepted on this article.
  </div>
</div>

        
      </div>
    </div>
    <div id="main-left-bottom">
    </div>
  </div>
  <div id="main-right" class="lo-cell">
    
      <div id="right-sidebar-a" class="ad-slot top">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-a'); });
  </script>
</div>

<div class="video-ad">
  <div class="title">EWTN NewsLink</div>
  <div style="position: relative; display: block; max-width: 100%;">
    <div style="padding-top: 56.25%;">
      <video class="video-js" controls data-account="1675170007001" data-application-id="" data-embed="default" data-player="4f575b12-8074-47cd-b401-253800972357" data-playlist-id="3292177820001" playsinline="" style="position: absolute; top: 0px; right: 0px; bottom: 0px; left: 0px; width: 100%; height: 100%;"> </video>
      <script src="//players.brightcove.net/1675170007001/4f575b12-8074-47cd-b401-253800972357_default/index.min.js"></script></div>
  </div>
</div>

<div id="blogger-bio">
  
    <div class="name"><a href="/blog/tito-edwards">Tito Edwards</a></div>
    <div class="image"><img src="/images/sized/images/member_photos/photo_8608-85x85.png" width="85" height="85"  alt="Tito Edwards" /></div>
    <div class="text"><p>Tito Edwards manages Catholic websites for the new evangelization that Pope John Paul II and then Cardinal Ratzinger, now Pope Benedict XVI, has asked for in the third millennium.</p>

<p>After a lifetime of living a nominal Catholic life, he reverted completely to his childhood faith that began on the eve of the funeral of Pope John Paul II.</p>

<p>He publishes <a href="http://bigpulpit.com/">Big Pulpit</a>, <a href="http://CatholicStand.com/">Catholic Stand</a>, <a href="http://IgnitumToday.com/">Ignitum Today</a>, and <a href="http://the-american-catholic.com/">The American Catholic</a>.</p></div>
    <div class="clear"></div>
  
</div>

<div id="trending">
  <h1>Trending</h1>
  <div class="trending-panel">
     
      <div id="trending-entry-1" class="trending-entry lo-row">
        <div class="count lo-cell">
          1.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/joseph-pronechen/holy-weeks-plenary-indulgences">Here are the Plenary Indulgences Available During Holy Week</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/joseph-pronechen/holy-weeks-plenary-indulgences">
                <img src="/images/sized/images/uploads/Pronechen-HW-85x85.jpg" width="85" height="85"  alt="Here are the Plenary Indulgences Available During Holy Week" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-2" class="trending-entry lo-row">
        <div class="count lo-cell">
          2.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/toys-r-us-contributes-to-its-corporate-death-wish">Toys R Us Contributes to Its Corporate Death Wish</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/toys-r-us-contributes-to-its-corporate-death-wish">
                <img src="/images/sized/images/editorial/GettyImages-932489142-85x85.jpg" width="85" height="85"  alt="Toys R Us Contributes to Its Corporate Death Wish" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-3" class="trending-entry lo-row">
        <div class="count lo-cell">
          3.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/jimmy-akin/9-things-you-need-to-know-about-good-friday">9 things you need to know about Good Friday</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/jimmy-akin/9-things-you-need-to-know-about-good-friday">
                <img src="/images/sized/images/uploads/crucifixion-85x85.jpg" width="85" height="85"  alt="9 things you need to know about Good Friday" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-4" class="trending-entry lo-row">
        <div class="count lo-cell">
          4.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/jimmy-akin/10-things-you-need-to-know-about-holy-thursday">10 things you need to know about Holy Thursday</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/jimmy-akin/10-things-you-need-to-know-about-holy-thursday">
                <img src="/images/sized/images/uploads/washing_feet_01-85x85.jpg" width="85" height="85"  alt="10 things you need to know about Holy Thursday" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-5" class="trending-entry lo-row">
        <div class="count lo-cell">
          5.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/jimmy-akin/when-precisely-did-jesus-die-the-year-month-day-and-hour-revealed">7 clues tell us *precisely* when Jesus died (the year, month, day, and hour revealed)</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/jimmy-akin/when-precisely-did-jesus-die-the-year-month-day-and-hour-revealed">
                <img src="/images/sized/images/uploads/jesus_before_pilate_jekel-85x85.jpg" width="85" height="85"  alt="7 clues tell us *precisely* when Jesus died (the year, month, day, and hour revealed)" />
            </a>
          </div>
              </div>
              <div id="right-sidebar-b" class="ad-slot middle">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-b'); });
  </script>
</div>
           
      <div id="trending-entry-6" class="trending-entry lo-row">
        <div class="count lo-cell">
          6.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/astagnaro/some-reasons-why-women-cant-be-priests">Some Reasons Why Women Can&#8217;t Be Priests</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/astagnaro/some-reasons-why-women-cant-be-priests">
                <img src="/images/sized/images/uploads/Stagnaro-PRIESTESSES-85x85.jpg" width="85" height="85"  alt="Some Reasons Why Women Can&#8217;t Be Priests" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-7" class="trending-entry lo-row">
        <div class="count lo-cell">
          7.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/cardinal-dolan-democrats-have-abandoned-catholics">Cardinal Dolan: Democrats Have Abandoned Catholics</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/cardinal-dolan-democrats-have-abandoned-catholics">
                <img src="/images/sized/images/editorial/Cardinal_Timothy_Dolan_Credit_Jeffrey_Bruno_CNA-85x85.jpg" width="85" height="85"  alt="Cardinal Dolan: Democrats Have Abandoned Catholics" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-8" class="trending-entry lo-row">
        <div class="count lo-cell">
          8.
        </div>
        <div class="title lo-cell">
          <div><a href="/blog/mfenelon/5-ways-to-make-sure-your-holy-week-isnt-a-holy-weak">5 Ways to Make Sure Your Holy Week Isn&#8217;t a Holy Weak</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/blog/mfenelon/5-ways-to-make-sure-your-holy-week-isnt-a-holy-weak">
                <img src="/images/sized/images/uploads/Fenelon-HOLYWEEK-85x85.jpg" width="85" height="85"  alt="5 Ways to Make Sure Your Holy Week Isn&#8217;t a Holy Weak" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-9" class="trending-entry lo-row">
        <div class="count lo-cell">
          9.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/student-threatened-with-rape-for-promoting-marriage-at-providence-college">Student Threatened With Rape for Promoting Marriage at Providence College</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/student-threatened-with-rape-for-promoting-marriage-at-providence-college">
                <img src="/images/sized/images/editorial/Mike_Smalanskas-85x85.jpg" width="85" height="85"  alt="Student Threatened With Rape for Promoting Marriage at Providence College" />
            </a>
          </div>
              </div>
                         
      <div id="trending-entry-10" class="trending-entry lo-row">
        <div class="count lo-cell">
          10.
        </div>
        <div class="title lo-cell">
          <div><a href="/daily-news/sdg-reviews-paul-apostle-of-christ">SDG Reviews &#8216;Paul, Apostle of Christ&#8217;</a></div>
        </div>
                  <div class="image lo-cell">
            <a href="/daily-news/sdg-reviews-paul-apostle-of-christ">
                <img src="/images/sized/images/uploads/paulapostleofchrist-85x85.jpg" width="85" height="85"  alt="SDG Reviews &#8216;Paul, Apostle of Christ&#8217;" />
            </a>
          </div>
              </div>
                        
  </div>
</div>

<div id="right-sidebar-c" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-c'); });
  </script>
</div>

<div class="ad-slot bottom">
  <a href="http://revive.registerticket.com/revive/www/delivery/ck.php?zoneid=71" target="_blank">
    <img src="http://revive.registerticket.com/revive/www/delivery/avw.php?zoneid=71">
  </a>
</div>

<div id="right-sidebar-d" class="ad-slot bottom">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('right-sidebar-d'); });
  </script>
</div>


    
  </div>
</div>
<div id="bottom-banner-ad" class="ad-slot main-center">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('bottom-banner-ad'); });
  </script>
</div>


    </div>
    <div id="footer-container">
      <div class="footer-logo">
  <div><img alt="Register Logo" src="/css/layout/images/ncregister100k.png"></div>
</div>
<div class="footer-text">
  <div class="footer-links">
    <div>
      <a href="/">Home</a>
      <a href="/info/about_the_register">About Us</a>
      <a href="/info/subscribe">Subscriptions</a>
      <a href="https://donate.ncregister.com/p-4-enews-general-fund.aspx?source=N18W" target="_blank">Donate</a>
      <a href="//ewtnadvertising.com" target="_blank">Advertise</a>
      <a href="/PR">Press Releases</a>
      <a href="//feeds.feedburner.com/NCRegisterDailyBlog" target="_blank">RSS Daily Register</a>
      <a href="//feeds.feedburner.com/NationalCatholicRegisterBloggers" target="_blank">RSS Bloggers</a>
      <a href="/info/contacts">Contact</a>
      <a href="/jobs">Jobs</a>
    </div>
    <div>
      <a href="/?mobile=1" class="mobile-only">Mobile Site</a>
      <a href="/info/opt-in-popup" class="subscribe-popup">Sign up for our E-Newsletter</a>
      <a href="https://www.facebook.com/NCRegister" target="_blank">Facebook</a>
      <a href="https://twitter.com/NCRegister" target="_blank">Twitter</a>
      <a href="https://www.youtube.com/NCRegister" target="_blank">YouTube</a>
      <a href="//instagram.com/ncregister/" target="_blank">Instagram</a>
      <a href="https://play.google.com/store/apps/details?id=com.ewtn.ncrreader&amp;hl=en" target="_blank">Android App</a>
      <a href="https://itunes.apple.com/us/app/national-catholic-register/id736212445?mt=8" target="_blank">iOS App</a>
      <a href="/info/ncr-privacy-policy">Privacy Policy</a>
    </div>
  </div>
  <div class="footer-fine-print">
    Copyright &copy; 2018 EWTN News, Inc.&nbsp; All rights reserved.<br>
    Reproduction of material from this website without written permission, or unlicensed commercial use<br>
    or monetization of <em>National Catholic Register</em> RSS feeds is strictly prohibited.<br>
    Accessed from 52.90.98.148
  </div>
</div>

    </div>
  </div>
  <div id="fixed-bottom-banner">
    <div id="fixed-bottom-banner-ad" class="ad-slot fixed-bottom-banner">
  <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('fixed-bottom-banner-ad'); });
  </script>
</div>

  </div>
  <script type="text/javascript" src="/js/jquery.fancybox.pack.js"></script>
<script type="text/javascript" src="/js/menu.js"></script>
<script type="text/javascript" src="/js/global.js"></script>
<script type='text/javascript'>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 4055;
  _sf_async_config.domain = 'ncregister.com';
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  (function() {
      function loadChartbeat() {
          window._sf_endpt = (new Date()).getTime();
          var e = document.createElement('script');
          e.setAttribute('language', 'javascript');
          e.setAttribute('type', 'text/javascript');
          e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
          document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
          loadChartbeat : function() {
              oldonload();
              loadChartbeat();
          };
  })();
</script>
<script type="text/javascript">
  function suppressOptinPopup() {
    setCookie('op-off', new Date().getTime(), 45);
    jQuery.fancybox.close();
  }

  function suppressDonatePopup() {
    setCookie('dp-off', new Date().getTime(), 45);
    jQuery.fancybox.close();
  }

  function showOptinPopup(now) {
    var opDays = 7;
    setCookie('op-off', now, opDays);
    jQuery.fancybox.open({
      href: '/info/opt-in-popup/auto',
      padding: 0,
      type: 'iframe',
      closeBtn: false
    });
  }

  function showDonatePopup(now) {
    var dpDays = 7;
    setCookie('dp-off', now, dpDays);
    jQuery.fancybox.open({
      href: '/info/donate-popup',
      padding: 0,
      type: 'iframe',
      closeBtn: false
    });
  }

  function showInterstitialPopup() {
    jQuery.fancybox.open({
      href: '/message',
      type: 'iframe',
      padding: 0,
      width: 800,
      height: 625,
      fitToView: false,
      autoSize: false
    });
  }

  function handleOrdinary() {
    var now = new Date().getTime(),
        oneDay = 86400000,
        dpCountDays = 1,
        dpThresh = 2,
        dpOff = getCookie('dp-off'),
        opOff = getCookie('op-off'),
        dpCount = getCookie('dp-count');
    dpOff = dpOff == '' ? null : parseInt(dpOff);
    opOff = opOff == '' ? null : parseInt(opOff);
    dpCount = dpCount == '' ? 0 : parseInt(dpCount);
    setCookie('dp-count', dpCount + 1, dpCountDays);

    if (!dpOff && opOff && (now - opOff) > oneDay && dpCount > dpThresh)
      showDonatePopup(now);
    if (!opOff && (!dpOff || (now - dpOff) > oneDay))
      showOptinPopup(now);
  }

  function handleSeasonal() {
    if (getCookie('ip-off') != '')
      return;

    var ipDays = 2,
        ipCount = getCookie('ip-count');
    ipCount = ipCount == '' ? 0 : parseInt(ipCount);

    setCookie('ip-off', true, ipDays);
    setCookie('ip-count', (ipCount + 1) % 3, ipDays + 1);

    if (ipCount == 2)
      showOptinPopup(new Date().getTime());
    else
      showInterstitialPopup();
  }

  var seasonalOn = '#2016-12-12T05:00Z|2017-04-14T05:00Z';
  if (seasonalOn.startsWith('#'))
    seasonalOn = false;
  else {
    var parts = seasonalOn.split('|'),
        now = new Date(),
        isStart = new Date(parts[0]),
        isStop = new Date(parts[1]);
    seasonalOn = isStart <= now && now < isStop;
  }
  if (seasonalOn)
    handleSeasonal();
  else
    handleOrdinary();
</script>
<script type="text/javascript">
  (function() {
  function async_load(script_url){
  var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
  var s = document.createElement('script'); s.src = protocol + script_url;
  var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
  }
  bm_website_code = '720BD26B5B3D490F';
  jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
  jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
  })();
</script>

  <script type="text/javascript" src="/js/comments.js"></script>

  <script type="text/javascript" src="/js/embedded-article-ad.js"></script>

<script type="text/javascript" src="//connect.facebook.net/en_US/all.js"></script>
<script type="text/javascript">
  var fbWait = [ 3000, 9000 ],
      fbShareRetry = 0;
  function getFbShares() {
    $.ajax({
      url: 'http://graph.facebook.com/?fields=share&id=' + encodeURIComponent(metaUrl),
      dataType: 'json',
      success: function(data) {
        if (data.share) {
          $('#share-count').html(data.share.share_count);
          $('.share-count-container').show();
        } else if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      },
      error: function(resp) {
        if (fbShareRetry < fbWait.length) {
          setTimeout(getFbShares, fbWait[fbShareRetry]);
          fbShareRetry++;
        }
      }
    });
  }
  getFbShares();

  $('.share-fb').click(function() {
    FB.ui({
      method: 'share',
      display: 'popup',
      href: metaUrl
    });
  });
  $('.share-print').click(function(e) {
    window.open($(e.target).attr('href'), 'Print', 'width=600,height=550,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('.share-twitter').click(function(e) {
    var url = 'https://twitter.com/intent/tweet?hashtags=NCRegister&text=' + encodeURIComponent(metaTitle) + '&url=' + encodeURIComponent(metaUrl)
    window.open(url, 'Tweet', 'width=600,height=400,toolbar=no,status=no,scrollbars=yes,location=no,menubar=no,resizable=no');
    return false;
  });
  $('#main-left-main .article-body a').attr('target', '_blank');

  function stickAdsInViewport() {
    var markerBR = $('#lsb-sticky-ads-marker')[0].getBoundingClientRect(),
        $ads = $('#lsb-sticky-ads'),
        adsBR = $ads[0].getBoundingClientRect(),
        mainLeftBR = $('#main-left')[0].getBoundingClientRect();
    if (mainLeftBR.left < 0) {
      $ads.removeClass('sticky top bottom');
      return;
    }
    if ($ads.hasClass('sticky top')) {
      if (adsBR.bottom > mainLeftBR.bottom) {
        $ads.removeClass('top').addClass('bottom');
      } else if (markerBR.top > 12) {
        $ads.removeClass('sticky top');
      }
    } else if ($ads.hasClass('sticky bottom')) {
      if (adsBR.top > 12) {
        $ads.removeClass('bottom').addClass('top');
      }
    } else {
      if (mainLeftBR.bottom - adsBR.height < 12) {
        $ads.addClass('sticky bottom');
      } else if (markerBR.top < 12) {
        $ads.addClass('sticky top');
      }
    }
  }

  $(stickAdsInViewport);
  $(window).on('scroll', stickAdsInViewport);
</script>

</body>
</html>


  
  




